Applications using libsdl1.2-alsa randomly use 100% cpu and have broken sound playback

Bug #454879 reported by João Pinto on 2009-10-18
74
This bug affects 15 people
Affects Status Importance Assigned to Milestone
hedgewars (Ubuntu)
Undecided
Unassigned
libsdl1.2 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: hedgewars

This is reproducible.
I just start a local single player game, when I try to exit the game does not exit.
The cpu usage is 100%, top processes are hedgewars and hwengine.
Killing hwengine will exit the game.

ProblemType: Bug
Architecture: amd64
Date: Sun Oct 18 19:37:29 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: hedgewars 0.9.11-5
ProcEnviron:
 LANGUAGE=pt_PT.UTF-8
 PATH=(custom, user)
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: hedgewars
Uname: Linux 2.6.31-14-generic x86_64

João Pinto (joaopinto) wrote :
João Pinto (joaopinto) wrote :

To clarify, just starting the game menu window will make the hedgewars process use 100% of one core, and the

Installing libsdl1.2debian-pulseaudio instead of libsdl1.2debian-alsa will fix the problem.

summary: - Exiting a single player game hangs the game with hwengine+hedgewars
- using 100% cpu
+ hedgewars process uses 100% cpu with libsdl1.2debian-alsa installed
João Pinto (joaopinto) wrote :

I am no longer able to reproduce the problem.

Derek (bugs-m8y) wrote :

Also launchpad bug #269082

and probably others.
Certainly a long-standing problem.

Reproduction is variable. Some days happens every game, sometimes it'll go for many games.
Various triggering factors for me including tabbing between windows while compiz was enabled, and other applications using pulseaudio while the game was running.

Without changing anython in the system (just rebooting) I am getting the problem again, so yes it seems to be triggered under some circumstances which are not reproducible.

summary: - hedgewars process uses 100% cpu with libsdl1.2debian-alsa installed
+ applcations using libsdl1.2-alsa randomly use 100% cpu and have broken
+ sound playback
summary: - applcations using libsdl1.2-alsa randomly use 100% cpu and have broken
+ Appilcations using libsdl1.2-alsa randomly use 100% cpu and have broken
sound playback
João Pinto (joaopinto) on 2009-10-31
summary: - Appilcations using libsdl1.2-alsa randomly use 100% cpu and have broken
+ Applications using libsdl1.2-alsa randomly use 100% cpu and have broken
sound playback
Jeffrey Flaker (jflaker) wrote :

From dup #372843
replaced libsdl1.2debian-alsa with libsdl1.2debian-pulseaudio

fixed the problem.

I think this is the same bug as to what I'm trying to report, but just in case it's something else, I'll describe it again here:

When I run hedgewars, it generally runs fine. However, at random moments, the sound gets distorted then stops completely. And, for some reason, once the sound gives up, the game window won't close. You can do a force quit to get rid of the window, but the process still shows up in the sound preferences window.

If it helps pin this down, I'm also using AMD and the 64-bit version of Ubuntu of 9.10, but I'm using the free ati driver instead of fglrx.

Oh, and I've just tried replacing alsa with pulseaudio as described above, and that seemed to do the trick.

Dan Quade (danquade) wrote :

Easiest way I found to reproduce this bug was to keep opening and closing xmoto. Sometimes it works correctly, sometimes it hogs up all of the CPU (or one of the cores on multi-core processors).
Installing libsdl1.2debian-pulseaudio fixed the problem for xmoto, however chromium-bsu, which also depends on libsdl1.2debian, still uses 100% CPU - every time (with -pulseaudio and -alsa). Same issue?

João Pinto (joaopinto) wrote :

Because chromium-bsu happens with different conditions is likely to be a different bug.

dylan (mrdylanc) wrote :

I had a problem with the game running unusably slow.. installed libsdl1.2debian-pulseaudio and removed libsdl1.2debian-alsa and it was fixed.

Ubunty Jaunty 9.04

Dan Quade (danquade) on 2009-11-15
Changed in libsdl1.2 (Ubuntu):
status: New → Confirmed
Tomi Juntunen (tojuntu) wrote :

I had the exact same problem. I'm using Ubuntu 9.10 with latest updates on Asus EeePC 1000H.

Installing libsdl1.2-debian-pulseaudio and removing libsdl1.2-debian-alsa fixed the problem for now. This bug should get a bit more attention, since it seems that Hedgewars isn't the only program suffering from pulseaudio failure.

Travis King (trvking) wrote :

I have the same thing happen to me with Urban Terror on 9.10. Installing libsdl1.2debian-pulseaudio and remove libsdl1.2-debian-alsa fixed things.

João Pinto (joaopinto) wrote :

This bug might be related to bug 502992 .

Hew McLachlan (hew) wrote :

The issue also occurs with Nexuiz. I see players online all the time complaining about broken sound, and they are always Ubuntu Karmic users.

Changed in hedgewars (Ubuntu):
status: New → Invalid
Changed in libsdl1.2 (Ubuntu):
importance: Undecided → Medium
Derek (bugs-m8y) wrote :

Hew, do you mind clarifying why you feel this bug is invalid?
It is still happening, and I see no resolution of it.

Hew McLachlan (hew) wrote :

It's confirmed for libsdl1.2, invalid for hedgewars. Please see the top of the page.

Derek (bugs-m8y) wrote :

Right, he did file it under hedgewars originally. I'm just concerned that the bug only seems to have a status of invalid, and I don't see any other bug filed or alternate status so I don't want it to disappear.

But maybe it is just how this bug reporting system displays things that I'm not seeing it.

They might not take non-javascript/non-css browsers into account.

daf (davydm) wrote :

It might be worthwhile, since the Ubuntu devs are adamant that Ubuntu users should be stuck with pulseaudio (which is horribly broken and obviously can't emulate alsa like it should) to change package dependencies for games like hedgewars to the pulse version of libsdl. I mean, if you're going to force a point, force it all the way. Your "average user" would try to install hedgewars and end up blaming the game -- or worse, "Linux", saying that "Linux is broken".

All I'm saying is that there is perhaps a bug to log against the package here: if Ubuntu is going to stay on the road of pulseaudio, perhaps the install candidate for libsdl should be the pulseaudio one by default?

Adam Reeve (adreeve) wrote :

The only dependency that would need to be changed is for libsdl1.2debian, as all games depend on this package rather than libsdl1.2debian-alsa directly. That's why this bug is filed against libsdl1.2 rather than hedgewars (or any other game where this bug occurs).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.