SDL apps incorrectly report that "X11 driver not configured with OpenGL" and fail to start

Bug #328932 reported by nullack
68
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libsdl1.2 (Ubuntu)
Fix Released
High
Unassigned
Jaunty
Fix Released
High
Unassigned

Bug Description

It seems that the -nvidia driver isnt working with OpenGL. When I try for example to run Warzone2100, the following message is displayed:

nullack@PPP:/usr/games$ warzone2100
error : [screenInitialise] Error: SDL_SetVideoMode failed (X11 driver not configured with OpenGL).

This is occurring on jaunty as of 13/02/09.

Revision history for this message
nullack (nullack) wrote :
Revision history for this message
nullack (nullack) wrote :
Revision history for this message
nullack (nullack) wrote :

Noting that a test of glxgears works, so the problem seems more to do with SDL.

Revision history for this message
Ernesto Manriquez (alejandronova) wrote :

A compilation from source, with default options, and with source downloaded from http://www.libsdl.org, fixed this for me. This is an issue with packaging. I suggest trying to compile libsdl with default options.

Revision history for this message
Pitabred (ubuntu-pitabred) wrote :

I will confirm this as well. I can't start armagetronad or foobillard, both give the same error with X11 driver not supporting OpenGL.

Revision history for this message
Michael Marley (mamarley) wrote :

I confirm this, too. Any 3D app that uses SDL quits, but screensavers and GLXGears work just fine.

Changed in libsdl1.2:
status: New → Confirmed
Revision history for this message
Michael Marley (mamarley) wrote :

I have just uploaded a build to my PPA that should work, if anyone would like to try that once it compiles.

Revision history for this message
Michael Marley (mamarley) wrote :

I just ran into a very strange problem with the PPA build. The version built on my system works, but when I upload it to the PPA it does not.

Revision history for this message
Michael Marley (mamarley) wrote :

OK, it is working now. To fix the problem, I had to add libglu1-mesa-dev and mesa-common-dev to the build-depends.

Daniel Hahler (blueyed)
Changed in libsdl1.2:
importance: Undecided → High
status: Confirmed → Triaged
Revision history for this message
vnieto (vnieto) wrote :

doing this work:

Code:

1. Download the tarball from http://www.libsdl.org.
2. # tar xvfz [tarball]
3. # ./configure --prefix=/usr && make && make install

This is definitely a packaging issue, and that fact makes it a quickly fixable bug.

Show in : http://ubuntuforums.org/showthread.php?p=6731480

Revision history for this message
Durand D'souza (durand1) wrote :

The compile method works well. The PPA method also works and that is probably a better option.
Thanks everyone!

Revision history for this message
Martin Olsson (mnemo) wrote :

I got the same problem for chromium and extremetuxracer.

Revision history for this message
Tuomas Aavikko (taavikko) wrote :

Error from UrbanTerror on jaunty x86_64
Nvidia-glx-180.29 drivers

QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed

Revision history for this message
Durand D'souza (durand1) wrote :

Same error here:
http://ubuntuforums.org/showthread.php?p=6729000

Those two solutions will fix the problem temporarily.

Revision history for this message
Martin Olsson (mnemo) wrote :

Currently, xmoto consistently runs into a SEGV on startup:
https://bugs.launchpad.net/ubuntu/+source/xmoto/+bug/330073
(I suspect the xmoto crash was exposed only when some libsdl function started to fail due to this bug)

Another game that is broken is "supertuxkart". On startup it current prints (the part that says "FATAL: ssgInit called without a valid OpenGL context." smells a lot like this libsdl bug again):
Data files will be fetched from: '/usr/share/games/supertuxkart/'
AL lib: alsa.c:785: no playback cards found...
AL lib: alsa.c:853: no capture cards found...
Highscores will be saved in '/home/mnemo/.supertuxkart/highscore.data'.
FATAL: ssgInit called without a valid OpenGL context.
AL lib: ALc.c:1302: exit() 1 device(s) and 1 context(s) NOT deleted
AL lib: alSource.c:2291: alcDestroyContext(): 18 Source(s) NOT deleted

The game SDL "glest" also prints a fatal error at startup:
Exception: Couldn't set video mode 640x480 (32bpp 0 stencil 16 depth-buffer). SDL Error is: X11 driver not configured with OpenGL

Revision history for this message
Martin Olsson (mnemo) wrote :

So in summary it looks like these games are confirmed to be broken:
xmoto, sypertuxkart, glest, chromium, extremetuxracer, armagetronad, foobillard
UrbanTerror, Warzone2100, Tremulous

However, 2D SDL games like Epiphany still works though.

Revision history for this message
Savvas Radevic (medigeek) wrote :

Has anyone been using libsdl1.2 before 2009-02-12 (February 12th)? Was it ok?
It could be due to the removal of arts, an unsupported package:
https://bugs.launchpad.net/ubuntu/+source/arts/+bug/320915
https://launchpad.net/ubuntu/+source/libsdl1.2

Revision history for this message
Martin Olsson (mnemo) wrote :

I don't know about libsdl but I know for sure that I was playing chromium using jaunty all the time in january.

Revision history for this message
Durand D'souza (durand1) wrote :

libsdl was definitely working before the 12th. However, I don't think the removal of arts is to blame, at least not directly. It just seems to be a simple configuration change when the debs were built.

Bryce Harrington (bryce)
description: updated
Revision history for this message
Savvas Radevic (medigeek) wrote : Re: -nvidia driver not configured with OpenGL

Good catch!

Is everyone here using nvidia graphics card?
$ dpkg -l nvidia-glx*
ii nvidia-glx-180 180.29-0ubuntu2 NVIDIA binary Xorg driver

Revision history for this message
pablomme (pablomme) wrote :

No, I'm using an Intel 945GM, and I get the same problem with all the mentioned games. The recompiled libsdl does the trick for me too.

Revision history for this message
Martin Olsson (mnemo) wrote :

I got an ATI machine where I can play chromium just fine (with all updates) however I also have an Intel G45 machine where I get the open GL error printed when I launch chromium. The ATI machine where it works has a "RV350 AP" (Radeon 9600) card.

Revision history for this message
Bryce Harrington (bryce) wrote : Re: X11 driver not configured with OpenGL

You can look at `glxinfo` to see if it is correct that GL is not enabled for you in X. From the Xorg.0.log it looks like GL is loading up without errors or warnings.

This may not be a driver-specific issue; it could just be a libsdl1.2 packaging bug. Try reverting it to an earlier version and see if you can reproduce the problem or not.

Revision history for this message
pablomme (pablomme) wrote :

@Bryce: It definitely is a packaging problem. Using the packages from Michael Marley's PPA (see comments #7-#9 above) I get the 3D SDL games working again.

At no point did compiz stop working, so OpenGL is definitely enabled in X11 and running smoothly as usual.

I don't know about the problem being driver-specific, since I'm only testing Jaunty on a laptop with an Intel 945GM (my desktop with an ATI card runs Intrepid), but other people should be able to confirm whether this is the case.

Revision history for this message
pablomme (pablomme) wrote :

Hopefully the title change should prevent confusions regarding what the problem is.

Revision history for this message
Paul Broadhead (pjbroad) wrote :

I have this problem too, ATI Mobility Radeon 7000, X31 Thinkpad.

Revision history for this message
Brian Rogers (brian-rogers) wrote :

I rolled back to the previous version of libsdl1.2debian-alsa: 3D stuff works
Rebuilt and installed that version from source package: 3D works
Rebuilt and installed current version from source package: 3D works
Reinstalled current version in repository: 3D doesn't work

(My test programs for 3D were ppracer and wings3d)

Looks like something funny happened when libsdl was last built, and the problem isn't actually due to a change in libsdl. A simple rebuild might fix this.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsdl1.2 - 1.2.13-4ubuntu3

---------------
libsdl1.2 (1.2.13-4ubuntu3) jaunty; urgency=low

  * debian/control:
    - add libglu1-mesa-dev as a build dependency, so SDL gets built with
      OpenGL support (LP: #328932)
    - Fix typo in svn URL (LP: #330457)

 -- Luke Yelavich <email address hidden> Fri, 20 Feb 2009 13:15:42 +1100

Changed in libsdl1.2:
status: Triaged → Fix Released
Revision history for this message
Martin Olsson (mnemo) wrote :

Great work Luke! Thanks for fixing it. All games work again on my machine after I installed the update.

Revision history for this message
Crabro (dickruck) wrote :

Can I just add that, as a relative noob to linux, and a complete noob to this site, that I had this problem, too, using intrepid. However I have downloaded the .diff file and applied the patch, re-ran ./configure and make install and my system now works!

So - many thanks, Luke.

But the reason for the post is that I have spent many hours following many links before arriving here. Once I had applied the patch (it is amazing how much I learned on the way) and got my system working again (tested with openarena and chromium) it occurred to me that the libsdl1.2 version in the intrepid repository is 1.2.13-2ubuntu1 whilst I now have 1.2.13-4ubuntu3

From the amount of posts on the net, plenty of other intrepid users are suffering this problem. It is probably out of place asking here, and if I am breaking protocol I apologise in advance, but is it possible for someone to get this fix in the repository for the benefit of all?

Many thanks again.

Revision history for this message
Martin Olsson (mnemo) wrote :

I've not experience this problem on Intrepid and I tried again using the latest updates for intrepid as of march 18th and chromium and openarena both launch file on this unpatched intrepid system. If there is a bug on intrepid that needs to be analyzed more in depth, i.e. find repro steps etc.

Revision history for this message
Dylan Evans (floobit) wrote :

I don't know the current status of this issue, but I have the latest version of sdl1.2 (libsdl1.2debian_1.2.13-4ubuntu4_i386.deb) and I have this issue. I am trying to remotely run gaussview with ssh and X11 forwarding. The display window (which renders with opengl) shows a static frame of the background screen at the time of window formation. This implies to me that opengl is broken in x11 forwarding. I can, however, run opengl code natively (ie opengl tests installed locally).

Thanks,
Dylan

Revision history for this message
pipo65 (pipo65) wrote :

the problem is in opengl glx not active on intel to activate and resolve other problems follow links

http://wiki.redaven.com/spip.php?article11

http://www.ubuntu-guia.com/2009/07/problemas-con-drivers-de-intel-en.html

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments