libsdl1.2-dev:i386 cannot be installed on 64-bit systems

Bug #1165014 reported by Colsta on 2013-04-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libsdl1.2 (Ubuntu)
Undecided
Unassigned

Bug Description

Platform:
Ubuntu Precise 12.04.2 LTS 3.2.0-39-generic #62-Ubuntu SMP Thu Feb 28 00:28:53 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Reference:
I also refer you to bug #1068374 which is very similar in behaviour.

Behaviour:
When I try to bring in libsdl1.2-dev:i386, apt wants to uninstall half my system!

Expectation:
I would expect the library to be installed seamlessly along with the other i386 libraries I had already obtained.

Detail:
I was in the throes of installing Neverwinter Nights game natively under linux using instructions found on "http://ubuntuforums.org/showthread.php?t=113259" and on
"http://social.bioware.com/forum/Neverwinter-Nights-1/NwN-1-Technical-Support-Self-help-for-all-versions-and-expansions/nwmouse-and-friends-64bit-linux-5212955-1.html".
I wanted this package to cross-compile the nwmouse.so component to assist with the installation of a hardware mouse within the game.

Additional:
Using the instructions for further information requested in bug #1068374 I've already attached the output for further analysis.

On 05/04/2013 10:30 PM, "Colsta" <email address hidden> wrote:
> Behaviour:
> When I try to bring in libsdl1.2-dev:i386, apt wants to uninstall half my
system!
>
> Expectation:
> I would expect the library to be installed seamlessly along with the
other i386 libraries I had already obtained.
>

This *-dev* package is arch: all, there is no ":i386" version. You install
it without this suffix, can still cross compile.

The corresponding library package can be installed for i386 no problem.

status invalid

Colsta (colsta) wrote :

OK - I wasn't aware the package status was arch:all as I was simply going on results. I couldn't cross-compile with libsdl1.2-dev alone as it kept complaining about missing SDL libraries. This was also true of other libraries until I explicitly installed their 32 bit counterparts (below):

ia32-libs-multiarch libsdl1.2debian:i386 libgtk2.0-0:i386 libsdl-image1.2:i386 libsdl-ttf2.0-0:i386 libglu1-mesa:i386 libopenal-dev:i386 libsndfile1-dev:i386 libxcursor-dev:i386 libelf-dev:i386 libx11-dev:i386

These all installed without any complaints and stopped the compile rejecting on missing libraries. Essentially libsdl1.2-dev:i386 was the last required to complete the task (according to the error messages) but when I tried to install it it wanted to uninstall half my system. So the question is why would it be requested if it wasn't required and secondly why would half the system need to be uninstalled when all the other :i386 libs installed without issue?
Thank you.

On 6 April 2013 21:32, Colsta <email address hidden> wrote:
> OK - I wasn't aware the package status was arch:all

My mistake, it is not. In any case, apt is not at fault here as the
dependency chain of this package is not fully converted to multi-arch.
 That process will be completed in time.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
timfelgentreff (timfelgentreff) wrote :

Any updates on this? I'm still seeing this behavior in 14.10

Juhani Numminen (jsonic) on 2018-12-17
affects: apt (Ubuntu) → libsdl1.2 (Ubuntu)
Andreas Hasenack (ahasenack) wrote :

In ubuntu disco, I can "apt install libsdl1.2-dev:i386" just fine on an x86_64 system, after having run "dpkg --add-architecture i386". Is this a correct test for this issue? I also installed native libsdl1.2-dev (64bits).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers