Ubuntu

dosbox does not react to function keys

Reported by sds on 2013-01-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libsdl1.2 (Ubuntu)
Undecided
Unassigned

Bug Description

Running under X, dosbox does not notice when I press Ctrl-F1, Ctrl-F9, etc.
Emacs receives these keys fine, so it appears to be a dosbox problem, not a unity one.

When I run dosbox under the console, the screen is scrambled, Ctrl-f9 is ignored,
and I have to use killall in another console to exit dosbox.

I tried usescancodes = false in .dosboxrc but it did not change anything
(I run dosbox with the -conf key, so the conf file is read, as I can see from the output from the [autoexec] section).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: dosbox 0.74-2
ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
Uname: Linux 3.2.0-35-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Thu Jan 17 15:24:46 2013
ExecutablePath: /usr/bin/dosbox
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
SourcePackage: dosbox
UpgradeStatus: No upgrade log present (probably fresh install)

sds (sds-gnu) wrote :
shankao (shankao) wrote :

Function keys work for me in an updated raring installation. dosbox uses SDL for input [0], so it could be a problem in SDL under precise. Moving there.
Please, file a different bug report for the problem with running it under a virtual console; maybe, have a look to the link at [0] for that matter too. Thanks!

[0] - http://vogons.zetafleet.com/viewtopic.php?t=31335&sid=eb7502d53495804b291df681b9b3affd

affects: dosbox (Ubuntu) → libsdl1.2 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libsdl1.2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers