Ubuntu

FTBFS on amd64 in precise: /«PKGBUILDDIR»/gtk-engine/svg-main.c:63: undefined reference to `g_module_make_resident'

Reported by Andreas Moog on 2012-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
librsvg (Ubuntu)
High
Unassigned

Bug Description

Tried to build the package, but failed:

libtool: link: gcc -shared -fPIC -DPIC .libs/libsvg_la-svg-draw.o .libs/libsvg_la-svg-main.o .libs/libsvg_la-svg-render.o .libs/libsvg_la-svg-rc-style.o -Wl,-rpath -Wl,/«PKGBUILDDIR»/.libs -Wl,--as-needed ../.libs/librsvg-2.so -L/usr/lib/x86_64-linux-gnu -lm -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 /usr/lib/x86_64-linux-gnu/libfreetype.so -lfontconfig -lgdk_pixbuf-2.0 -lgio-2.0 -lpangocairo-1.0 -lpango-1.0 -lgobject-2.0 /usr/lib/x86_64-linux-gnu/libcairo.so -lpng12 -lcroco-0.6 -lglib-2.0 /usr/lib/x86_64-linux-gnu/libxml2.so -pthread -pthread -O2 -O2 -Wl,-Bsymbolic-functions -Wl,-z -Wl,relro -Wl,-z -Wl,defs -Wl,-O1 -pthread -Wl,-soname -Wl,libsvg.so -o .libs/libsvg.so
.libs/libsvg_la-svg-main.o: In function `g_module_check_init':
/«PKGBUILDDIR»/gtk-engine/svg-main.c:63: undefined reference to `g_module_make_resident'
collect2: ld returned 1 exit status
make[4]: *** [libsvg.la] Error 1
make[4]: Leaving directory `/«PKGBUILDDIR»/gtk-engine'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/«PKGBUILDDIR»/gtk-engine'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/«PKGBUILDDIR»'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/«PKGBUILDDIR»'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Full buildlog attached.

Andreas Moog (amoog) wrote :
Leo Iannacone (l3on) on 2012-03-02
Changed in librsvg (Ubuntu):
assignee: nobody → Leo Iannacone (l3on)
status: New → In Progress
Leo Iannacone (l3on) wrote :

I can't reproduce this bug in Precise...

Changed in librsvg (Ubuntu):
assignee: Leo Iannacone (l3on) → nobody
status: In Progress → Incomplete
Leo Iannacone (l3on) wrote :

I tried to rebuild package in i386 and amd64 as well and nothing happened.

I'm going to close this bug.

Changed in librsvg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers