Namespace prefix sodipodi on namedview is not defined

Bug #1867766 reported by hugh chao
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
librsvg (Ubuntu)
Critical
Unassigned
ubuntu-themes (Ubuntu)
High
Olivier Tilloy

Bug Description

[Summary]
Since the package "gir1.2-rsvg-2.0:amd64" been upgraded from 2.46.4-1ubuntu1 to 2.48.0-1 in Focal's daily build, ubiquity will crash as attached crash log.

[Steps to reproduce]
1. Boot with OEM mode,
2. Finish the 1st stage
3. Reboot
4. Boot into OOBE(oem-config)

[Expected result]
Should start oobe without any error.

[Actual result]
The error message 『The installer encountered an unrecoverable error. A desktop session will now be run so that you may investigate the problem or try installing again.』shown on the screen.

[Failure rate]
100%

[Additional information]
No idea why, but some "nm-signal-*-secure" images will fail in Gtk.IconTheme().lookup_icon(n, 22, 0).load_icon(), and below error message will show:

"
Gtk-WARNING **: 18:23:31.380: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
gi.repository.GLib.GError: rsvg-error-quark: XML parse error: error code=201 (3) in (null):40:466: Namespace prefix sodipodi on namedview is not defined
"

Related branches

Revision history for this message
hugh chao (hugh712) wrote :
summary: - gi.repository.GLib.GError: rsvg-error-quark: XML parse error: error
- code=201 (3) in (null):40:466: Namespace prefix sodipodi on namedview is
- not defined
+ Namespace prefix sodipodi on namedview is not defined
Revision history for this message
hugh chao (hugh712) wrote :

" lsb_release -rd

Description: Ubuntu Focal Fossa (development branch)
Release: 20.04

"apt-cache policy gir1.2-rsvg-2.0

gir1.2-rsvg-2.0:
  Installed: 2.48.0-1
  Candidate: 2.48.0-1
  Version table:
 *** 2.48.0-1 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        100 /var/lib/dpkg/status
     2.46.4-1ubuntu1 500
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages
        500 file: Packages

tags: added: oem-priority
Revision history for this message
Olivier Tilloy (osomon) wrote :

As suggested by seb128, the ubiquity autopkgtests fail with the same error.

Changed in librsvg (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Olivier Tilloy (osomon)
Revision history for this message
Olivier Tilloy (osomon) wrote :

I bet this is caused by this upstream change in librsvg:

- Librsvg's XML parser now supports namespaces (xmlns), and is
  stricter than before about it. Files may fail to parse if there are
  attributes or elements with namespace prefixes (e.g. foo:bar instead
  of plain bar), but without a corresponding namespace declaration
  (e.g. xmlns:foo="http://example.com/foo").

  This may happen especially with incorrectly-written SVGs that use
  xlink:href or xi:include attributes without the corresponding
  namespace declarations. If you run into this, just add the
  following to your toplevel SVG element:

      <svg xmlns="http://www.w3.org/2000/svg"
           xmlns:xlink="http://www.w3.org/1999/xlink"
    xmlns:xi="http://www.w3.org/2001/XInclude">
           ^^^^^^^^^ these ones

The nm-signal-*.svg icons in /usr/share/icons/ubuntu-mono-light/status/22 use sodipodi: prefixed attributes (exported by inkscape) without the corresponding namespace declaration (http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd).

Revision history for this message
Olivier Tilloy (osomon) wrote :

The invalid SVGs appear to be generated by the scavenge.py script in ubuntu-themes.

Revision history for this message
hugh chao (hugh712) wrote :

even in building ubiquity it will fail in :

(run:75635): Gtk-WARNING **: 23:32:02.334: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
Exception in GTK frontend (invoking crash handler):
Traceback (most recent call last):
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 330, in __init__
    self.view = NetworkManagerTreeView(self.state_changed)
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 96, in __init__
    self.configure_icons()
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 196, in configure_icons
    ico = ico.load_icon()
gi.repository.GLib.GError: rsvg-error-quark: XML parse error: error code=201 (3) in (null):40:466: Namespace prefix sodipodi on namedview is not defined
 (0)

Traceback (most recent call last):
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 330, in __init__
    self.view = NetworkManagerTreeView(self.state_changed)
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 96, in __init__
    self.configure_icons()
  File "./ubiquity/frontend/gtk_components/nmwidgets.py", line 196, in configure_icons
    ico = ico.load_icon()
gi.repository.GLib.Error: rsvg-error-quark: XML parse error: error code=201 (3) in (null):40:466: Namespace prefix sodipodi on namedview is not defined
 (0)
xauth/Xrdb output:

Olivier Tilloy (osomon)
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → In Progress
Changed in librsvg (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Committed
Changed in librsvg (Ubuntu):
assignee: Olivier Tilloy (osomon) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 19.04-0ubuntu3

---------------
ubuntu-themes (19.04-0ubuntu3) focal; urgency=medium

  * Preserve namespace declarations in the script that combines multiple
    SVG files into one (LP: #1867766)

 -- Olivier Tilloy <email address hidden> Tue, 17 Mar 2020 16:56:03 +0100

Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers