misrendering of SVG files (clipping paths)

Bug #1207538 reported by Mark on 2013-08-01
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
librsvg
Confirmed
Medium
cairosvg (Ubuntu)
Medium
Unassigned
librsvg (Ubuntu)
Medium
Unassigned

Bug Description

Generating an SVG file using matplotlib,

from pylab import *

x = linspace(0,2,101)
plot(x,x)
xlim(0,1)
savefig('test.svg')

gives the SVG file attached. This file views fine in Inkscape, Firefox, Chromium. However in Ristretto the blue line is not clipped properly and extends past the right side of the plot. The file's XML is pretty simple, with just one clip rectangle.

It seems there are a few image viewers with this problem including Ristretto but also gpicview, comix, gthumb. I'm not sure why they all share this issue (same library?). I'll submit the bug report here in hopes it gets forwarded upstream to the right place.

Mark (nanite) wrote :
madbiologist (me-again) wrote :

What version of Ubuntu and with what version of ristretto is this occurring?

This also occurs in eog 3.6.2-0ubuntu1 on Ubuntu 13.04 "Raring Ringtail".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ristretto (Ubuntu):
status: New → Confirmed
tags: added: trusty
Sergio Benjamim (sergio-br2) wrote :

also affects Ristretto and gThumb in Trusty.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1207538

tags: added: package-qa-testing
Sergio Benjamim (sergio-br2) wrote :

It affects eog too in trusty.

intherye (intherye) wrote :

I don't know which Standard of SVG is implemented in Ristretto.

When I saw the same issue in Gwenview I did some searching and found that the Qt library only implemented the SVG 1.2 Tiny standard, which doesn't support the clipping path feature.

More info from the KDE/Qt side:
https://bugreports.qt-project.org/browse/QTBUG-28636
https://bugreports.qt-project.org/browse/QTBUG-28636

So, still not sure if this is the same cause of problem for Ristretto.

Changed in ristretto (Ubuntu):
importance: Undecided → Medium

Also affects the basic SVG viewer rsvg-view-3.

affects: ristretto (Ubuntu) → librsvg (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

madbiologist (me-again) on 2015-03-15
tags: added: raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cairosvg (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in librsvg (Ubuntu):
status: Confirmed → Triaged
Changed in librsvg:
importance: Unknown → Medium
status: Unknown → Confirmed
madbiologist (me-again) wrote :

Still occurring on Ubuntu 15.04 with librsvg2-2 2.40.9-1.

tags: added: vivid
Changed in cairosvg (Ubuntu):
importance: Undecided → Medium
madbiologist (me-again) wrote :

Fixed on Ubuntu 17.04 "Zesty Zapus" with eog 3.24.0-0ubuntu1 and librsvg2-2 2.40.16-2~svn1

Changed in librsvg (Ubuntu):
status: Triaged → Fix Released
Changed in cairosvg (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.