Ubuntu

[Upstream] Libreoffice can't select printer tray

Reported by Lisandro Laura on 2012-05-04
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Fix Released
Critical
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

When selecting a tray different than default in network printer libreoffice prints in default tray anyway.
This does not happen with other programs (you can select a diferent tray an it prints in that tray).
Ubuntu 12.04

"File -> Print... -> select printer -> Properties..."
Change the paper tray setting from "Printer default" to "Manual Feeder" and click "ok". Open the properties again and the setting is again "Printer default"!

Change "Paper size", "Orientation" and "Duplex" will be saved.

You must change the paper tray setting in "File -> Printer Settings..." to print over the "Manual Feeder".

We do not have this problem with LibreOffice 3.3.x.
Ubuntu 10.04 LTS amd64

Reproduced the same problem on Mandriva 2008 (x64), LibreOffice 3.4.4 (340m1 Build:402).

*** Bug 44138 has been marked as a duplicate of this bug. ***

Regression due to original report

@Ivan:
Might be UI related, may be not ... . Can you shed light on the dark?
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.

It seems the set-tray-feature actually works, just need to update the UI... I'll take a look.

Same problem with LibreOffice 3.4.5 OOO340m1 (Build:502) on Ubuntu 10.04 x64

the problem still exists with libreoffice 3.4.5 on ubuntu 11.10 64bit.

Hum, I'm sorry, I didn't succeed with fixing...

My feeble attempt to fix:
http://nabble.documentfoundation.org/REVIEW-fdo-43932-try-to-fix-paper-tray-settings-td3657361.html

Reset Assignee to default.

- same problem on 3.4.3 on ubuntu 11.04
- it always uses the thefault printer from cups print server
- version 3.3.4 is working with multiple paper trays

This bug also affects 3.5.0 RC2.

I witnessed the same problem when switching from openoffice (Debian stable) to libreoffice (debian stable with backports).

I have written a BASIC macro that works perfectly in our office and in the office where my wife works, with the following code:

[CODE]
 DIM oDoc AS Object
 oDoc = ThisComponent

 REM Set backgroundImage-option in DocumentSettings to False
 DIM oSettings AS Object
 oSettings = oDoc.createInstance("com.sun.star.text.DocumentSettings")
 oSettings.PrintPageBackground = bBg1

 REM choose a certain printer
 DIM mPrinterOpts(3) AS NEW com.sun.star.beans.PropertyValue
 mPrinterOpts(0).Name = "Name"
 mPrinterOpts(0).Value = "MFC8880DN"
 mPrinterOpts(1).Name = "PaperFormat"
 mPrinterOpts(1).Value = com.sun.star.view.PaperFormat.A4
 mPrinterOpts(2).Name = "PaperOrientation"
 mPrinterOpts(2).Value = com.sun.star.view.PaperOrientation.PORTRAIT
 oDoc.Printer = mPrinterOpts()

 REM set Papertray in Styles
 DIM oStyle AS Object
 DIM sPageStyle AS String
 sPageStyle = oDoc.CurrentController.getViewCursor().PageStyleName
 ostyle = oDoc.StyleFamilies.getByName("PageStyles").getByName(sPageStyle)
 oStyle.PrinterPaperTray = sTray

 REM Set printOptions
 DIM mPrintOpts(3) AS NEW com.sun.star.beans.PropertyValue
 mPrintOpts(0).Name = "CopyCount"
 mPrintOpts(0).Value = 1
 mPrintOpts(1).Name = "Collate"
 mPrintOpts(1).Value = True
 mPrintOpts(2).Name = "Pages"
 mPrintOpts(2).Value = sPageNr
 mPrintOpts(3).Name = "Wait"
 mPrintOpts(3).Value = True

 REM Print
 oDoc.Print(mPrintOpts())
[/CODE]

This worked perfectly with Openoffice.org v3.2.1. When I upgraded to LibreOffice in backports (first v3.3, now v 3.4.3 OOO340m1 build 302), this stopped working.

printing complete documents to tray 1 WORKS
printing complete documents to tray 2 WORKS
printing the first page to tray 1 and following pages to tray 2 DOES NOT WORK.

Maybe this is related to the bug at hand, and it might even help solving this bug (and my problem ;-)) - to that end, I will be crossposting this info to bug #39220

we also tested with 3.5 RC2.
paper tray is also not working.

I cant write a fix, so its not possible to help that much.
only if you have to test something, im able to test if its working.

now I have to migrate our 250 computers to OpenOffice!!!!
we need du update form 3.3.x because of other fixes and we cant, because our 60 printer would stop printing from multiple paper trays.

if i can help something, let me know now!!!

tnx

chris -- which is scripting migration to OO ... sniff

Same problem with LibreOffice 3.4.5 OOO340m1 (Build:502)
on Ubuntu 11.10 (GNU/Linux 3.0.0-16-generic i686) 32bit

(In reply to comment #11)

> now I have to migrate our 250 computers to OpenOffice!!!!
> we need du update form 3.3.x because of other fixes and we cant, because our 60
> printer would stop printing from multiple paper trays.

@ chris,

you can change the paper tray setting in "File -> Printer Settings..."

@ Samuel

That is no solution if you use a letterhead and you need to print every first page to tray X and every next page to tray Y. In an office environment this is unacceptable.

> you can change the paper tray setting in "File -> Printer Settings..."

@samuel
tnx for reply, yes i also found that hint at redhat bugzilla.

sadly we cant handle it that way.
letterhead, internal documentation, we are a school with 250 employee,
teachers are not that flexible :-)

they want a solution, comming wendsday i have to push the software rollout of
open office.

tnx anyway

chris

PS: hopefully we will migrate back to LibreO this year

"LibreOffice 3.5.0 German UI/Locale [Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735] on German WIN7 Home Premium (64bit) prints to the correct OKI 14ex tray and settings from Print dialog will not be lost. So it indeed seems to be LINUX related.

Version due to comment 8
<http://wiki.documentfoundation.org/BugReport_Details#Version>

I can't see any particular BASIC problem here.

This one will not block anything. But IMHO a 3.5 Most Annoying one.

@All:
Really limited to WRITER or also visible with CALC, DRAW, ...?

(In reply to comment #16)

> I can't see any particular BASIC problem here.
>
> This one will not block anything. But IMHO a 3.5 Most Annoying one.

I'm the one that pasted the BASIC-macro, so I should add that the pasted macro worked in openoffice perfectly (print page 1 to tray2 and consequent pages to tray1), but since I made the switch to libreoffice v3.3 and later 3.4, the problem surfaced.

I added this information because it rules out the possibility that it is a GUI-problem. The cause is to be sought underneath.

> @All:
> Really limited to WRITER or also visible with CALC, DRAW, ...?

I have tried it just now (in v3.4.4) and both CALC and DRAW are also not able to print to tray2 when selected in the CTRL+P print-dialog > properties of printer.

@change from 'blocker' to 'critical':
I'm not happy with this change, because it costs me money: letterhead-paper doesn't come cheap and for every printed page of a letter consisting of more than 1 page, I have to throw away a letterhead-page that is not printed correctly.

I agree that only affects printers with more than one tray, and thus rules out most consumers and even a lot of (small) businesses.

Due to Comment 17 I modify Component.

I have nothing further to add, other than that I just migrated 15 schools to LO (using debian squeeze-backport packages), and because a handfull of their 70+ printers sees activ use of different trays for different papers, I now need to downgrade to Openoffice 3.2 because of this bug.

I tried the 3.5 deb-packages downloaded directly from openoffice.org, and the problem is there also.

(In reply to comment #19)
Thank you for your testimony and posting your result in testing LO 3.5. I hope this shows that a significant portion of the LO-targeted audience is affected by this bug.

This shows that the regression was hit from OOo3.2 -> LO3.3 and that all LO-releases are affected.

David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d4cca9c22c52b5a7742adc47ebf1a2930e29764

fix setting of paper tray from print dialog (fdo#43932)

fixed in master, requested review for 3.5 and 3.4

David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=504aead0573befc744a00b8b1d68e3ebbaca8c47

Revert "fix setting of paper tray from print dialog (fdo#43932)"

DT, Thank you for your work on this. I was contemplating building libreoffice from GIT with the patch you submitted yesterday. Since I have never built anything myself, I was happy to see that there is an AUR-package to build LO from GIT.

Since you reverted the patch, I presume no testing is needed at this moment, but I will keep a close look on this and try a patch when available.

(In reply to comment #25)
> Since you reverted the patch, I presume no testing is needed at this moment,
> but I will keep a close look on this and try a patch when available.

Yes. And when there is a patch, you often can find a build to test it here:
http://dev-builds.libreoffice.org/daily/

The paper input (paper source) option in the Printing's "Preferences" dialogue always gets set back to Tray 1, even if I have the multi-purpose-tray selected.
When I change the default settings in CUPS, the printer will print from whatever I choose as default settings.

The printer is a Kyocera FS-C5030N, used as a network printer. It was installed through CUPS.

Other settings (Multiple Pages on one side, Duplex Unit etc) seem to work fine.
The multi-purpose tray was selected as installed in CUPS, and shows in the printing's Preference dialogue.

For me it's the same:
Debian Systems with Cups and a Kyocera Printer TASKalfa 250ci
Not only in Writer but in all Components the same effekt:
I use the printer with two trays = paper boxes, one with DIN A 4 and one with DIN A 3 (this is one of the possible standards)
If I use paper size A 3 (A 4 and tray 1 is standard) and choose tray 2 in the printings preferences, it didn't work: the printer try to print on A 3 with paper from tray 1 - but this didn't work, so the printer sends an error message. And Libreoffice didn't save the tray choice.

The only possiblity is, to chance the standard to A 3 and tray 2, but then other way (A4, tray 1) didn't work.

I forgot two important informations:

There are no similar problems with other programs than LibreOffice.

I suppose, that the problem isn't Kyocera-specific, but may be.

I have so the same problem with libreoffice 3.4 : it's impossible to choose the correct tray with printers which have multiple source trays. The problem don't exist with libreoffice version 3.3.4 that I used on another pc with the same network printer.
I used gentoo on a pc with libreoffice 3.3.4 without problem.
I used openSuse on another pc with libreoffice 3.4.5 with the problem.
My network printer, for the 2 pc, is a lexmark optra t610 with 3 trays.
Others softwares, like xournal, okular, evince, etc., can print with the correct tray.
Cordialement,
Yann

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

(In reply to comment #2)
> There are no similar problems with other programs than LibreOffice.
>
> I suppose, that the problem isn't Kyocera-specific, but may be.

Same on my side - can confirm for Kyocera FS-1028MFP (network printer, recent PPD) on Ubuntu 10.04 LTS using LibreOffice 3.5.2.2, Build-ID: 350m1(Build:202).

(In reply to comment #3)
> I have so the same problem with libreoffice 3.4 : it's impossible to choose the
> correct tray with printers which have multiple source trays. The problem don't
> exist with libreoffice version 3.3.4 that I used on another pc with the same
> network printer.
> I used gentoo on a pc with libreoffice 3.3.4 without problem.

I can confirm that it works fine with LO 3.3.4.
Thanks for pointing this out!
Would still like to get a fix though, because I don't want to use the old version.

Michael Zaugg (AOI) (it-oas) wrote :

Ubuntu 10.04
Libreoffice 1:3.5.3-0ubuntu1~lucid1

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

Same problem on LibreOffice 3.5.3.2 / Ubuntu 12.04

For me at least, it isn't resetting to the CUPS default. The CUPS default is set to tray 2, but LibreOffice always resets to tray 1. This is extremely annoying, because my printer refuses to print from tray 1 (which has A3, instead of A4).

All other programs remember the tray setting, only LibreOffice keeps forgetting it.

My printer is a Konica Minolta Bizhub C252, so the problem probably exists across all printers.

P.S. To make things even more annoying, I have to go through "File -> Printer settings" to even temporarily change the paper tray.

If I go to "File -> Print" and select "Properties" to change the paper tray, it gets reset immediately, i.e. I can't print!

confirmed by multiple affected users.

@dtardon: Care to have a look?

Seems to be a 3.3->3.4 regression by comment 3 and 5 though.

It is possible it is several issues mixed together... But yes, I will look into it.

summary: - Libreoffice can't select printer tray
+ [Upstream] Libreoffice can't select printer tray
Changed in df-libreoffice:
status: New → Confirmed
amsri (tomtum2004-linux) wrote :

This bug is affecting us very badly. I am a legal professional and use ubuntu-linux and libreoffice in our business which provides legal advice and services. Abilty to print to mutiple trays is aboslutey essential for us. We have a toshiba estudio 351C with several trays containing letter head, A3, A4 papers etc. I hope for an early resolution.

Michael Zaugg (AOI) (it-oas) wrote :

Bug #49149 seems a duplicate of #43923 which ist fixed in 3.6.0 Beta1 (http://wiki.documentfoundation.org/Releases/3.6.0)/Beta1

Changed in df-libreoffice:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → Confirmed
Paddy Landau (paddy-landau) wrote :

@itoas: "Bug #49149 seems a duplicate of #43923"

No, that is incorrect, because this bug is referring to a different numbering system. This one:
https://bugs.freedesktop.org/show_bug.cgi?id=49149

Paddy Landau (paddy-landau) wrote :

Re: My previous comment: Sorry, *I* was looking at the wrong place!

https://bugs.freedesktop.org/show_bug.cgi?id=49149
https://bugs.freedesktop.org/show_bug.cgi?id=43932

iotas, you were right.

Isn't this a duplicate of bug #49149 ?

(In reply to comment #27)
> Isn't this a duplicate of bug #49149 ?

If both reports describe the same bug, then it should be the other way around. The numbering of the bugreports should have given that away :)

Works in version 3.6.0.4 (Build ID: 932b512).

seeing as samuel originally reported this problem and now it works in version 3.6.0.4 for him it's apparently resolved now

Changed in df-libreoffice:
status: Confirmed → Fix Released
Jure Kodzoman (kodzoman) wrote :

- Used Linux Mint 13 Libreoffice
- Upgraded from PPA as suggested to 3.6
- Tray selection works as expected

Paddy Landau (paddy-landau) wrote :

I now have 3.6.0.2 and it now works correctly. Fix confirmed, thank you.

Created attachment 72818
set correct paper tray in UI

This was fixed in 38f8241859cdef4dd7c3098e365947dd5b64f78c by David Tardon, but unfortunately this bug wasn't referenced in the commit message (unlike his previous attempt which he had to reverse), so it never had the chance to appear in this bug report and to get into later 3.5.x releases, its only resolved in 3.6 releases.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=38f8241859cdef4dd7c3098e365947dd5b64f78c

I've applied that commit as a patch without change against Ubuntu 12.04 LTS's version 3.5 build which they call 3.5.4-0ubuntu1.1 and was able to build, run, and see this bug is resolved. (launchpad bug #994388). Didn't notice any regressions with some brief testing, and the patch appears to be a limited in it's scope.

I'm now going to deploy that particular build to real users in a 10 desk office running Ubuntu 12.04 where this bug has been of concern and see if they notice any regressions due to this fix being applied.

I believe this bug was still present in 3.5.7. I will confirm, and try this patch against against an unadulterated LibreOffice 3.5.7 when I get the chance, particularly if interest is expressed.

lp#994388: released on Fedora 17 and upstream (see also: bug 1103056)

fixed with 3.6/quantal.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.