Ubuntu

[needs-packaging] libreoffice-report-builder

Reported by Manos Nikiforakis on 2012-04-30
218
This bug affects 37 people
Affects Status Importance Assigned to Milestone
libreoffice (Baltix)
Medium
Mantas Kriaučiūnas
libreoffice (Ubuntu)
Wishlist
Björn Michaelsen

Bug Description

After upgrading to ubuntu i386 12.04 and installing libreoffice 3.5.2update3 I saw the is no libreoffice-report-builder-bin extention any more. Although there is one in the experimental brance of debian http://packages.debian.org/experimental/libreoffice-report-builder. I can no longer work without reports as they don't open. I use libreoffice base as a frontend to a mysql database.

This is not an SRU candidate due to the following outstanding issues:

+ To include report-builder in main:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/32
The root of the problem is the Java-Maven-dependency-mess -- this makes it nontrivial to enable Report-Builder to be included in main -- I would need the help of the Java team to get that done in time.

+ To include report-builder in universe:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/35
That would essentially mean rewriting the build system of the extensions it is currently build inside LO.

WORKAROUND: In Precise only:
sudo add-apt-repository ppa:libreoffice/ppa
sudo add-apt-repository ppa:libreoffice/libreoffice-universe
sudo apt-get update
sudo apt-get install libreoffice libreoffice-report-builder

Manos Nikiforakis, thank you for reporting this and helping make Ubuntu better. As per https://launchpad.net/ubuntu/precise/i386/libreoffice-report-builder it was deleted for Precise on 2012-03-01 by Martin Pitt. May want to ask him about it.

Bjoern's answer:

Hi,

The package is too heavy dependancy-wise for main. We would need to MIR
libloader which has quite a lot of deps in itself.

Best,

Bjoern

Well, as a workaround it would be not too hard to make a ppa (which is allowed to use universe) which builds LibreOffice with the package:
1) apt-get source libreoffice
2) remove the:

 ENABLE_REPORTDESIGN=n

line in debian/rules.
http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=blob;f=rules;h=159473dca10b3146d5f270510f0428c655f22be1;hb=ubuntu-precise-3.5#l475
3) possibly reduce number of l10ns to make it fit in a ppa
4) update changelog
5) regenerate control file: rm ./debian/control && ./debian/rules control
6) build sourcepackage: dpkg-buildpackage -S -v${LASTVER}
7) dput ${PPAURL} *.changes
8) done.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

I did a build with the instructions from https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/3 at
https://launchpad.net/~libreoffice/+archive/libreoffice-universe/+packages

if the build is finished, you should be able to use the report builder from there.

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress

I've installed the new packages (from libreoffice-universe) but although report-builder is installed along with all others paskages, it doesn't show in the extention manager, nor does it open any reports. If I press the report wizard, it pops up libreoffice default report wizard and not the one of the libreoffice report builder extention. I tried removing any ./config/libreoffice settings but that diidn't help either...

Garry (s61kiwi) wrote :

Report builder 1.2.1 is installed in extension manager (locked) on my build, however there seems to be dependencies issues with L0 3.5 and above which won't let it work. I have tried the Oracle version with no luck. The table filtering in Base is also broken... maybe a JAVA issue?

Bruce Fowler (brf531) wrote :

It's hard to believe that this bug has been hanging around for over a month and is still of "undecided" severity and unassigned. It is also hard to believe that it only affects nine users. You can bet that for everyone who found this bug and added their vote, a hundred have said, "The heck with it!," and gone back to Microsoft Access. What good is a database without a report generator? I have reports that I need to get out soon, people are tired of hearing excuses. And what really frosts me is, this has to be a simple packaging or configuration file change, this all used to work. Come on, people, think of your users!
And, to be complete, I have spent a few hours trying to figure out how to patch around this, downloading the Openoffice version and all that. Unfortunately I am technically incompetent, so all that's left for me is to bitch. Sorry about that.

Luc Dens (luc-dens) wrote :

I can only concur wiyh Bruce. I have the same problems ads also spent hours trying to fix this damn unnessary bug. Remember that regressing is the worst thing in user experience.

John (john-bannister) wrote :

I've been waiting for over a month now expecting this to be fixed. Should I go back to open office I've been hanging on hoping a fix will be found.

This cant be fixed easily inside precise as it does not fit the limits of an SRU. Please note this is not a shortcoming of LibreOffice. If you care about certain bugs and features, you are invited to test them on the alpha and beta releases of Ubuntu, to make sure they work as you intend to use them.
https://wiki.ubuntu.com/StableReleaseUpdates

Included in the 3.6.0~beta1 upload in the libreoffice-prereleases ppa.

Bruce Fowler (brf531) wrote :

Björn, thanks. I'll give it a try...

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

I did a compile with that fix in the libreoffice-universe ppa. On precise, please do:
sudo add-apt-repository ppa:libreoffice/libreoffice
sudo add-apt-repository ppa:libreoffice/libreoffice-universe
sudo apt-get update
sudo apt-get install libreoffice libreoffice-report-builder
and report back if the problem is fixed for you on precise with that. Thx.

Changed in libreoffice (Ubuntu):
status: In Progress → Incomplete
Bruce Fowler (brf531) wrote :

When I do:
   # add-apt-repository ppa:libreoffice/libreoffice
I get:
   Cannot access PPA (https://launchpad.net/api/1.0/~libreoffice/+archive/libreoffice) to get PPA information,
   please check your internet connection.
So then I try:
   # ping -c3 https://launchpad.net
I get:
   ping: unknown host https://launchpad.net
For the record:
   # uname -a
gives:
   Linux odie 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:33:05 UTC 2012 i686 i686 i386 GNU/Linux
and:
   # lsb_release -a
gives:
   No LSB modules are available.
   Distributor ID: Ubuntu
   Description: Ubuntu 12.04 LTS
   Release: 12.04
   Codename: precise

If I can figure out where the "launchpad" URL is coming from, I will try putting a "www." in the front.
It does not seem to be in "/etc/apt" anywhere...

Ah, sorry the URL for the first ppa is ppa:libreoffice/ppa

Bruce Fowler (brf531) wrote :

Björn,

That ppa fixes the problem. Thank you very much for the help.

closing as per comment 18

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released

yes indeed it is fixed. thanks Björn !

Ann Brzezinski (aebrzezinski) wrote :

My reports are also working fine now. Thank you!

Garry (s61kiwi) wrote :

Also fixed for me.

Now if I can just figure out how to get the filtering on tables to work with dates I'll be a happy camper! I can filter a date but not for a range of dates, however another problem all together.

will this patch be included in the next update of the main packages?

Edgar (edgar-nl) wrote :

When will this patch come in the main package ???
I need this one on our production desktops...
And on these computers I dont like to install something that says:

"Most of the packages in this ppa have only experienced minor testing -- in fact it is the place to enable a wider audience to test packages before they are published into the distro proper. In general this ppa is _not_ for the average user to install without a closer look (if it would be, its packages would be in the main repositories)."

DwalerXIII (dwalerxiii) wrote :

This fixed it for me!

Thank you very much for this fix!!!
It works aswell for me.
I'm in charge of Chief of Studies in a Secondary School and I'm using OpenOffice and LibreOffice Calc to arrange groups of students in levels, groups, optative subjects and so. Then I used Base and Report Builder to print lists of students.

Until now I was stuck to an Ubuntu 10.10 installation at my work place and the reports didn't work at my home Ubuntu 12.04 computer. Now both computers are working well with reports!!!

Thanks.

Joan S. Salelles

Garry (s61kiwi) wrote :

The update yesterday has introduced another interesting bug on my machine. When you go Tools < Options it crashes LO. Have depreciated versions, purged config files and repositories, tried various Betas and custom builds from various PPA's and just haven't been able to find a combo where everything works as advertised.
In exasperation went to Libreoffice web site and downloaded and installed from there and bingo... everything works (including report builder) except table filtering by date and I can live with that.
I am a huge fan of Ubuntu and LO, but 12.04 has been the worst Ubuntu experience since I started using in 2007 (I like the direction but the bugs seem never ending). Grumble over.

Lenovo T420

"The update yesterday has introduced another interesting bug on my machine." <= This isnt helpful at all, please specify what you changed/updated.

Garry (s61kiwi) wrote :

Apologies. I don't have the exact update but it was the last update from the libreoffice-universe repo perhaps 3 days ago. I neglected to take note of the update because I didn't pick up the bug for a couple of days.

The Tools < Options crash is;
* not present in 3.6 but base is very unstable in 3.6 and the forms crash. (installed from PPA libreoffice-prereleases)
* is present in the libreoffice-universe repo version
* is present in 1:3.5.3-0ubuntu from main.
* is not present if installed directly from Libreoffice website. Base and report builder work out of the gate with this install - Ver 3.5.4. The only slight issue is I had to load 64bit Mysql connector from Open Office.

Each install had a fresh config folder.

libreoffice-gtk3 was not installed on any of the versions.

asf100 (asf100) wrote :

Thanks Björn Michaelsen,

I'm using Kubuntu 12.04 and now I can edit my reports on report-buider. I adapted to:

sudo add-apt-repository ppa:libreoffice/ppa
sudo add-apt-repository ppa:libreoffice/libreoffice-universe
sudo apt-get update

kubuntu Auto update starts and update libreoffice

sudo apt-get install libreoffice-report-builder

thanks again...

come on guys...
will we have the same problem in 3.6 release?

from https://launchpad.net/ubuntu/quantal/+source/libreoffice/1:3.6.0~rc2-0ubuntu3 :
"
libreoffice (1:3.6.0~rc2-0ubuntu3) quantal-proposed; urgency=low
  * remove reportbuilder dep as long as we still have it disabled
"

Why? until one month ago (in beta2) the report builder was there...
should we do something? (perhaps fill another bug?)

In ubuntu 12.04 took a lot time to get the report builder back and thanks to Bjorn now we've upgrated our company computers to precise...

@Manos: The root of the problem is the Java-Maven-dependency-mess -- this makes it nontrivial to enable Report-Builder to be included in main -- I would need the help of the Java team to get that done in time.

pinco (sportegioco) wrote :

I'm using Ubuntu 12.04 and oracle report-buider don't go. The problem i have found is the permits.
I solved bugs with this simply command from command line:

sudo chmod 655 /usr/lib/libreoffice/program/librptlo.so
sudo chmod 655 /usr/lib/libreoffice/program/librptxmllo.so
sudo chmod 655 /usr/lib/libreoffice/program/librptuilo.so

Thank toy for your big work.

James Page (james-page) wrote :

@Bjorn

Would it be possible to have a reportbuilder only source package which still resides in universe? It would allow us to workaround the Java-Maven dependency explosion

discussed with seb128: dropping this for quantal main.

@James: That would essentially mean rewriting the build system of the extensionas it is currently build inside LO.

Same problem on 3.6.0 (PPA on Kubuntu 12.04).

When I open an report, I get an error message:
"Oracle report builder extension is missing"

same here on build 3.6.0.2 :-( ... it is a pity as we can't use libreoffice updates in bussiness...

Chris Moller (moller) wrote :

Yes, I know this is for Ubuntu LO bugs, but I can't find an appropriate place for Fedora LO bugs--does anyone know how I can get report builder working under Fedora? I just installed Version 3.6.1.2 (Build ID: e29a214) LibO_3.6.1_Linux_x86_install-rpm_en-US.tar.gz, but it's still not working.

FWIW, the new install went into /opt/libreoffice3.6, but the default install is still in /usr/lib/libreoffice. Could that be screwing things up?

Thanks

Woolly (nigelw119) wrote :

This problem make Base unusable. I cannot produce any reports. What good is a database that can't produce reports. Since Ubuntu 12.04 has been released I have had nothing but problems.

Yleeyas (yleeyas) wrote :

Well, I can atleast generate the reports I had, with the 'fix' but when I try to create a new report (wizard or design view), it just goes away and I have to recover/unlock the db. This is a problem, which I don't have time to bitch about or follow up on.

Björn Michaelsen, I found it odd that this report should be marked Fix Released if libreoffice-report-builder is not available in an officially supported Ubuntu repository, but only in a the LO Universe PPA for Precise. Since you noted how this is non-trivial for main, and this is not an SRU candidate, could this be published into universe repository instead, like lo-menubar is?

Thank you for your time and consideration and I look forward to your response.

Please toggle Status appropriately if I pursued an incorrect procedure.

Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
status: Fix Released → Triaged

I second that. I have so far not been able to install the fix.

On Thu, Oct 18, 2012 at 9:27 AM, Christopher M. Penalver <
<email address hidden>> wrote:

> Björn Michaelsen, I found it odd that this report should be marked Fix
> Released if libreoffice-report-builder is not available in an officially
> supported Ubuntu repository, but only in a the LO Universe PPA for
> Precise. Since you noted how this is non-trivial for main, and this is
> not an SRU candidate, could this be published into universe repository
> instead, like lo-menubar is?
>
> Thank you for your time and consideration and I look forward to your
> response.
>
> Please toggle Status appropriately if I pursued an incorrect procedure.
>
> ** Changed in: libreoffice (Ubuntu)
> Importance: Undecided => Wishlist
>
> ** Changed in: libreoffice (Ubuntu)
> Status: Fix Released => Triaged
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (981665).
> https://bugs.launchpad.net/bugs/992232
>
> Title:
> no libreoffice-report-builder in precise
>
> Status in “libreoffice” package in Ubuntu:
> Triaged
>
> Bug description:
> After upgrading to ubuntu 12.04 and installing libreoffice 3.5.2update3
> I saw the is no libreoffice-report-builder-bin extention any more. Although
> there is one in the experimental brance of debian
> http://packages.debian.org/experimental/libreoffice-report-builder. I can
> no longer work without reports as they don't open. I use libreoffice base
> as a frontend to a mysql database.
> (I use the i386 desktop ubuntu 12.04)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/+subscriptions
>

--
Wolfram Neff
14 Gardner Avenue
Woburn, MA 01801

Cell: (978)408-3681

check out my band "Pretty Boss"
http://www.facebook.com/pages/Pretty-Boss/102284119809677

I was on 12.04 and had the report builder installed. I upgraded to 12.10 yesterday and am horrified to find I no longer have my Base reports. Do I really have to spend another 2 days rebuilding my system yet again on 12.04 just to have this?

Is there any way at all I can at least try to install it?

I tried the ppas above, but all I get is:

W: Failed to fetch http://ppa.launchpad.net/libreoffice/libreoffice-universe/ubuntu/dists/quantal/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/libreoffice/libreoffice-universe/ubuntu/dists/quantal/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/libreoffice/libreoffice-universe/ubuntu/dists/quantal/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

and then the install fails to find the report-builder

Help!

When I try to open my reports or edit them, LO crashes.
The same when I try to create new ones.

Ubuntu 12.04.1 + LO 3.6.0.2

Same reports open perfectly in Windows version.

Tonton Manu (dubreucq) wrote :

Same problem as above / Antonio Gómez-Muriana (antoniogm)

Ubuntu 12.10 + LO 3.6.2.2 (Build ID 360m1 (Build:2))
Oracle Report Builder 1.2.1

http://ppa.launchpad.net/libreoffice/libreoffice-universe/ubuntu/dists/

Only supports Precise. Did you not check the supported releases before adding the PPA??? Not all PPAs support all releases.

tags: added: needs-packaging precise quantal

I would like to expand the release scope of this bug to include Quantal (and future releases), as a request for this has been filed for Quantal https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1078624 , and comment https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/45 . Also, it would not be a stretch to think when Raring and future releases are out, people will want report-builder to work.

As well, I would like to expand the implementation scope from just an SRU request to also needs-packaging. This is in full understanding how this is not an SRU candidate as per https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/11 . However, this may be a backport candidate as defined in https://wiki.ubuntu.com/UbuntuBackports#Requesting_a_Backport .

If this is objectionable, please retoggle as desired.

Thank you for your understanding.

summary: - no libreoffice-report-builder in precise
+ [needs-packaging] libreoffice-report-builder
description: updated
Tom Schutter (t-schutter) wrote :

As I found at http://www.liberiangeek.net/2012/11/libreoffice-3-6-3-is-now-availableinstall-in-ubuntu-12-10-quantal-quetzal/ there is a libreoffice-prereleases ppa that supports quantal and provides the libreoffice-report-builder package.

Purge the existing install:

    sudo apt-get purge libreoffice-core

Add the libreoffice-prereleases ppa:

    sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases

Install from the ppa:

    sudo apt-get update && sudo apt-get install libreoffice libreoffice-report-builder

Many thanks for the solution!!

Greatings

Am 21.11.2012 05:19, schrieb Tom Schutter:
> As I found at http://www.liberiangeek.net/2012/11/libreoffice-3-6-3-is-
> now-availableinstall-in-ubuntu-12-10-quantal-quetzal/ there is a
> libreoffice-prereleases ppa that supports quantal and provides the
> libreoffice-report-builder package.
>
> Purge the existing install:
>
> sudo apt-get purge libreoffice-core
>
> Add the libreoffice-prereleases ppa:
>
> sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases
>
> Install from the ppa:
>
> sudo apt-get update && sudo apt-get install libreoffice libreoffice-
> report-builder
>

Hi, I tried that solution in Ubuntu 12.04.

I got libreoffice 3.6 installed with libreoffice-report-builder 1.2 but neither the builder and the wizard worked.
I didn't received any error.

Any help?

Am 25.11.2012 16:50, schrieb Matteo Galvani:
> Hi, I tried that solution in Ubuntu 12.04.
>
> I got libreoffice 3.6 installed with libreoffice-report-builder 1.2 but neither the builder and the wizard worked.
> I didn't received any error.
>
> Any help?
>
Hi,

the best way I tried is

- download the original version from LibreOffice.org
- unpack the file
- uninstall the installed version with e.g. synaptic
- install the version 3.6 (sudo dpkg -i *.deb)
- be carefull, you have to install all file, also the files in the
subdirectories,
   in case of the wrong sequence, you will get an error

Good luck!

Greatings

Indeed this is the only solution but I don't get it how in the vanilla
version of libreoffice works and when it s packaged by Ubuntu doesn't since
Ubuntu 12.04. I'm talking about the main repocitory not the universe ...
Why is this happening?
One bad thing with the vanilla version is that it doesn't include the mysql
native connector and you have to use JDBC (slow) or ODBC to get a mysql
connection
Στις 26 Νοε 2012 10:20 π.μ., ο χρήστης "Dietmar Poddey" <
<email address hidden>> έγραψε:

> Am 25.11.2012 16:50, schrieb Matteo Galvani:
> > Hi, I tried that solution in Ubuntu 12.04.
> >
> > I got libreoffice 3.6 installed with libreoffice-report-builder 1.2 but
> neither the builder and the wizard worked.
> > I didn't received any error.
> >
> > Any help?
> >
> Hi,
>
> the best way I tried is
>
> - download the original version from LibreOffice.org
> - unpack the file
> - uninstall the installed version with e.g. synaptic
> - install the version 3.6 (sudo dpkg -i *.deb)
> - be carefull, you have to install all file, also the files in the
> subdirectories,
> in case of the wrong sequence, you will get an error
>
> Good luck!
>
> Greatings
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/992232
>
> Title:
> [needs-packaging] libreoffice-report-builder
>
> Status in "libreoffice" package in Ubuntu:
> Triaged
>
> Bug description:
> After upgrading to ubuntu i386 12.04 and installing libreoffice
> 3.5.2update3 I saw the is no libreoffice-report-builder-bin extention
> any more. Although there is one in the experimental brance of debian
> http://packages.debian.org/experimental/libreoffice-report-builder. I
> can no longer work without reports as they don't open. I use
> libreoffice base as a frontend to a mysql database.
>
> This is not an SRU candidate due to the following outstanding issues:
>
> + To include report-builder in main:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/32
> The root of the problem is the Java-Maven-dependency-mess -- this makes
> it nontrivial to enable Report-Builder to be included in main -- I would
> need the help of the Java team to get that done in time.
>
> + To include report-builder in universe:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/35
> That would essentially mean rewriting the build system of the extensions
> it is currently build inside LO.
>
> WORKAROUND: In Precise only:
> sudo add-apt-repository ppa:libreoffice/ppa
> sudo add-apt-repository ppa:libreoffice/libreoffice-universe
> sudo apt-get update
> sudo apt-get install libreoffice libreoffice-report-builder
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/+subscriptions
>

Thank you.

It worked.

I have no expirience with the vanilla-kernel.
I work only with the original Kubuntu-versions and found
the discribed way.
Sorry

Am 26.11.2012 17:54, schrieb Manos Nikiforakis:
> Indeed this is the only solution but I don't get it how in the vanilla
> version of libreoffice works and when it s packaged by Ubuntu doesn't since
> Ubuntu 12.04. I'm talking about the main repocitory not the universe ...
> Why is this happening?
> One bad thing with the vanilla version is that it doesn't include the mysql
> native connector and you have to use JDBC (slow) or ODBC to get a mysql
> connection
> Στις 26 Νοε 2012 10:20 π.μ., ο χρήστης "Dietmar Poddey" <
> <email address hidden>> έγραψε:
>
>> Am 25.11.2012 16:50, schrieb Matteo Galvani:
>>> Hi, I tried that solution in Ubuntu 12.04.
>>>
>>> I got libreoffice 3.6 installed with libreoffice-report-builder 1.2 but
>> neither the builder and the wizard worked.
>>> I didn't received any error.
>>>
>>> Any help?
>>>
>> Hi,
>>
>> the best way I tried is
>>
>> - download the original version from LibreOffice.org
>> - unpack the file
>> - uninstall the installed version with e.g. synaptic
>> - install the version 3.6 (sudo dpkg -i *.deb)
>> - be carefull, you have to install all file, also the files in the
>> subdirectories,
>> in case of the wrong sequence, you will get an error
>>
>> Good luck!
>>
>> Greatings
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/992232
>>
>> Title:
>> [needs-packaging] libreoffice-report-builder
>>
>> Status in "libreoffice" package in Ubuntu:
>> Triaged
>>
>> Bug description:
>> After upgrading to ubuntu i386 12.04 and installing libreoffice
>> 3.5.2update3 I saw the is no libreoffice-report-builder-bin extention
>> any more. Although there is one in the experimental brance of debian
>> http://packages.debian.org/experimental/libreoffice-report-builder. I
>> can no longer work without reports as they don't open. I use
>> libreoffice base as a frontend to a mysql database.
>>
>> This is not an SRU candidate due to the following outstanding issues:
>>
>> + To include report-builder in main:
>>
>> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/32
>> The root of the problem is the Java-Maven-dependency-mess -- this makes
>> it nontrivial to enable Report-Builder to be included in main -- I would
>> need the help of the Java team to get that done in time.
>>
>> + To include report-builder in universe:
>>
>> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/35
>> That would essentially mean rewriting the build system of the extensions
>> it is currently build inside LO.
>>
>> WORKAROUND: In Precise only:
>> sudo add-apt-repository ppa:libreoffice/ppa
>> sudo add-apt-repository ppa:libreoffice/libreoffice-universe
>> sudo apt-get update
>> sudo apt-get install libreoffice libreoffice-report-builder
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/+subscriptions
>>

Changed in libreoffice (Ubuntu):
status: Triaged → In Progress
Prx (info-productivix) wrote :

Hi,
I do not understand the strategy to make Base and Libreoffice been accepted: please make simple for users !

- I have a station with Ubuntu 11.10 with LO (libre office) 3.5.7.2 through the http://ppa.launchpad.net/libreoffice/libreoffice-3-5/ubuntu (I had to change this ppa recently otherwise I was still in previous version : not simple as well !)
- I have a notebook with Ubuntu 12.04 with LO 3.5.4.2 without ppa change, originaly installed

On Ubuntu 11.10 :
1/ I had to add BAse to be installed (why is not it from scratch ?)
2/ After a use of Base as a front end to Mysql DB, I mention that I can not modify the reports made by the wizard !!
Why it is not installed from scrach ?

3/ I read that I have to install report-builder, so I go to synaptic and choose that (it is a version 1.2 .1 only), I install : then not report builder nor wizard runs !! (desintall builder and reinstall base with synaptic wizard runs after)

SO , in clear : to use Base and design reports : what do I have to do (simple)?
Tkanks in advance.

Eglė (egle) wrote :

Why libreoffice-report-builder package isn't included in the latest LibreOffice 3.6 packages repository (https://launchpad.net/~libreoffice/+archive/libreoffice-3-6 )?
I've added this repository with command:
sudo add-apt-repository ppa:libreoffice/libreoffice-3-6 && sudo apt-get -qq update

But there are no libreoffice-report-builder :(

But I've found latest libreoffice-report-builder for LibreOffice 3.6.5 in Debian experimental repository, see:

http://packages.debian.org/experimental/libreoffice-report-builder
http://packages.debian.org/experimental/libreoffice-report-builder-bin

I will test how these libreoffice-report-builder packages work with the latest LibreOffice 3.6 from ppa:libreoffice/libreoffice-3-6 and if they work fine then it would be nice to see these libreoffice-report-builder packages in the main Baltix GNU/Linux repository (ppa:baltix-members/ppa).

The best way for the moment:

- deinstall LibreOffice as installed from the system
- download the original three packages (mainprogramm, desktop,
translation)from
   libreoffice.org
- install all modules with dpkg -i *.deb

Am 06.02.2013 15:22, schrieb Eglė:
> Why libreoffice-report-builder package isn't included in the latest LibreOffice 3.6 packages repository (https://launchpad.net/~libreoffice/+archive/libreoffice-3-6 )?
> I've added this repository with command:
> sudo add-apt-repository ppa:libreoffice/libreoffice-3-6 && sudo apt-get -qq update
>
> But there are no libreoffice-report-builder :(
>
> But I've found latest libreoffice-report-builder for LibreOffice 3.6.5
> in Debian experimental repository, see:
>
> http://packages.debian.org/experimental/libreoffice-report-builder
> http://packages.debian.org/experimental/libreoffice-report-builder-bin
>
> I will test how these libreoffice-report-builder packages work with the
> latest LibreOffice 3.6 from ppa:libreoffice/libreoffice-3-6 and if they
> work fine then it would be nice to see these libreoffice-report-builder
> packages in the main Baltix GNU/Linux repository (ppa:baltix-
> members/ppa).
>

Changed in libreoffice (Baltix):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
Phil Munck (pmunck) wrote :

A database program without a good report builder is mostly useless junk. If you won't build the report builder into the basic program, at least don't lock us out of the Sun system. I have reinstalled 3.6 and will wait for a real release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.0~beta2-0ubuntu2

---------------
libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

  * Build using the internal libmspub for a first build.
 -- Matthias Klose <email address hidden> Tue, 19 Feb 2013 00:05:26 +0100

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Steve Cornell (rbrt-cornell) wrote :

I have used Ubuntu since Intrepid and out of fustration, tried the report builder in Windows 7. To my surprise, it worked fine with the database I use in Ubuntu

wneff (wneff2) wrote :

Version 4 of Libreoffice has it fixed. All my reports work with 4

On Fri, Mar 1, 2013 at 6:05 PM, Steve Cornell <email address hidden>wrote:

> I have used Ubuntu since Intrepid and out of fustration, tried the
> report builder in Windows 7. To my surprise, it worked fine with the
> database I use in Ubuntu
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (981665).
> https://bugs.launchpad.net/bugs/992232
>
> Title:
> [needs-packaging] libreoffice-report-builder
>
> Status in “libreoffice” package in Ubuntu:
> Fix Released
> Status in “libreoffice” package in Baltix:
> Confirmed
>
> Bug description:
> After upgrading to ubuntu i386 12.04 and installing libreoffice
> 3.5.2update3 I saw the is no libreoffice-report-builder-bin extention
> any more. Although there is one in the experimental brance of debian
> http://packages.debian.org/experimental/libreoffice-report-builder. I
> can no longer work without reports as they don't open. I use
> libreoffice base as a frontend to a mysql database.
>
> This is not an SRU candidate due to the following outstanding issues:
>
> + To include report-builder in main:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/32
> The root of the problem is the Java-Maven-dependency-mess -- this makes
> it nontrivial to enable Report-Builder to be included in main -- I would
> need the help of the Java team to get that done in time.
>
> + To include report-builder in universe:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/35
> That would essentially mean rewriting the build system of the extensions
> it is currently build inside LO.
>
> WORKAROUND: In Precise only:
> sudo add-apt-repository ppa:libreoffice/ppa
> sudo add-apt-repository ppa:libreoffice/libreoffice-universe
> sudo apt-get update
> sudo apt-get install libreoffice libreoffice-report-builder
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/+subscriptions
>

--
Wolfram Neff
14 Gardner Avenue
Woburn, MA 01801

Cell: (978)408-3681

Patrick Mulligan (muldune6910) wrote :

Had the same issue as everyone else...
Ubuntu 12.04 LTS and LO 3.6.x = missing report builder

executed the workaround...
    WORKAROUND: In Precise only:
    sudo add-apt-repository ppa:libreoffice/ppa
    sudo add-apt-repository ppa:libreoffice/libreoffice-universe
    sudo apt-get update
    sudo apt-get install libreoffice libreoffice-report-builder

Now I have LO 4.0.2.2 and Report Builder 1.2.3; no crashes yet.

I hope this issue gets permanently resolved. I'm trying to kick MS out of my company, installing LO in our base WIN image.
Next is moving office computers to Linux. I need LO Base working well in Ubuntu.

Working on getting Linux/FLOSS compentent but until then I've got to depend on you guys.

Ann Brzezinski (aebrzezinski) wrote :

Just saw wneff's note from 2 March and gave it a try myself. I installed report builder from the Software Center and my reports are now all working fine. I'm running LibreOffice 4.0.2.2 on Ubuntu 13.04 (64-bit).

Thank you for one more reason not to have to reboot into Windoze!

Thanks a lot Bjoern Michaelson!

A fresh Ubuntu upgrade! Same problem as Patrick Mulligan. Would expect the report builder by now to be be included in the official repository if Ubuntu 12.04 packages Libre Office 3-6. as a default program. I was getting error messages from the updater and an prompt for an partial upgrade, although I had all the Security and most of the recommended updates installed and Ubuntu was running fine!

Björn, you saved my day.

Now I have the Libre Office 4.0.2.2 on Ubuntu 12.04 (64-bit) running. And it seems so far very stable. And the updater shows no Error messages or prompts for partial upgrade! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions