[Upstream] CONFIGURATION: Too small select lists in Language Settings > Writing Aids

Bug #991059 reported by Alain Berney on 2012-04-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

The select lists in Language Settings > Writing Aids are too small, especially the first one (Available language modules).

Using Ubuntu Precise Pangolin, first line (Hunspell SpellChecker) below
Available language modules is not selectable with up and down arrow keys, but
only with the scroll wheel. Furthermore the scroll bar is too much "compressed"
and can't be used (except for the down arrow button).

[...]

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sun Apr 29 13:42:59 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Alain Berney (alainberney) wrote :
Alain Berney (alainberney) wrote :
Logan Rosen (logan) on 2012-04-30
summary: - Options window not resizeable
+ Options window not resizable

Raphael Frey, this is:
- a clearcut upstream issue. Your welcome to send this to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status.
- won't be fixed in LibreOffice Packaging
Resolving as Won't Fix in LibreOffice Packaging. This does not mean the issue will not be cared about, but if it is cared about (even by Ubuntu/Canonical contributors), it is done upstream at LibreOffice.

libreoffice (Ubuntu) => Won't Fix Wishlist

Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
status: New → Won't Fix

Created attachment 60955
Screenshot - Ubuntu Precise Pangolin

PROBLEM DESCRIPTION

The select lists in Language Settings > Writing Aids are too small, especially the first one (Available language modules).

Using Ubuntu Precise Pangolin, first line (Hunspell SpellChecker) below Available language modules is not selectable with up and down arrow keys, but only with the scroll wheel. Furthermore the scroll bar is too much "compressed" and can't be used (except for the down arrow button).

Using Mac OS Lion, the scroll bar below Available language modules can't be used at all (clicking on it and moving the mouse up and down / moving up and down on the trackpad doesn’t move the scroll bar). Scrolling up with the trackpad always shows OpenOffice.org New Thesaurus. Scrolling down also shows the other lines/options, but the the first line can't be viewed at all. Using the up and down keys, all options but the first line can be viewed.

Possible troubleshooting:

* Options window should be made resizable, or
* Larger select lists

PLATFORM

* Ubuntu 12.04 LTS (Precise Panglin), LibreOffice 3.5.2 -> See downstream bug report: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/991059
* Mac OS X 10.7.3 (Lion), LibreOffice 3.5.3

Created attachment 60956
Screenshot - Mac OS X Lion

I agree that the importance of this bug isn't very high because it doesn't produce data loss or the like. But I don't think that this is a enhancement request given that one option is not selectable at all and thus it is not possible to en-/disable or edit it.

Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed

For me it is a regression from LO 3.4.

Raphael Frey, here is the problem with trying to correctly triage this bug:

1) Your downstream bug is completely different then this upstream one. In the downstream, you are requesting the ability to resize the window (ENHANCEMENT), and noting you are having a UI bug in Linux.

2) Here you include all that, plus a similar but potentially different UI problem on the Mac platform.

3) All totaled, you have at least 1 bug and an ENHANCEMENT.

Please re-file this bug, one for the ENHANCEMENT, one for the problem on Linux, and one for the problem on Mac. Thank you for your understanding in this.

Changed in df-libreoffice:
importance: Wishlist → Undecided
status: Confirmed → New
description: updated
Changed in df-libreoffice:
status: New → Incomplete

I propose to ask Ivan Timofeev to have a look, indeed he has fixed several bugs in the layout of various dialogs.

Best regards. JBF

Jean-Baptiste Faure, please do not extend this report any further due to https://bugs.freedesktop.org/show_bug.cgi?id=49421#c4 .

Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31182ed08494ed6afa3371aa246b155c6b58e8b3

fdo#49421: the "Available language modules" list is too small and unusable

I don't know what extent of cleanness we have to demand from bug-reports ...
For me this one is clean enough. :) So - hopefully fixed now.

My commit enlarges the "Available language modules" list so that it now
contains *2* entries and is well scrollable. The Mac OS X scrollbar problem
should disappear, but I can't test on Mac OS X.

And... resizable windows will be a feature of the future LibO versions I think... :)

(In reply to comment #8)
> My commit enlarges the "Available language modules" list so that it now
> contains *2* entries and is well scrollable.

Oh dear! It was well scrollable when the scaling is set to 130%, normally it is not... Sorry, I need to have a look at this problem as well.

haste, haste - mistakes, mistakes...

Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b07d7d348a728fc54991320ff7bc882f341478af

fdo#49421: do not divide by zero when scrollbar cannot be moved

(In reply to comment #4)
> Raphael Frey, here is the problem with trying to correctly triage this bug:
>
> 1) Your downstream bug is completely different then this upstream one. In the
> downstream, you are requesting the ability to resize the window (ENHANCEMENT),
> and noting you are having a UI bug in Linux.
>
> 2) Here you include all that, plus a similar but potentially different UI
> problem on the Mac platform.
>
> 3) All totaled, you have at least 1 bug and an ENHANCEMENT.
>
> Please re-file this bug, one for the ENHANCEMENT, one for the problem on Linux,
> and one for the problem on Mac. Thank you for your understanding in this.

Okay, I see the problem and I'm very sorry for causing this confusion ... Let me just explain the situation briefly: I remarked the problem using LibreOffice in Ubuntu and I thought the problem comes from the options window which is not resizable. (There were similar problems with other programmes in Ubuntu in the past, with options/settings windows which were too small and not resizable). Then I noticed the same problem using LibreOffice on my MacBook. As you might know, settings windows on Mac OS X usually aren't resizable. So I thought the problems on my Ubuntu and Lion system were the same and therefore I reported the bug here (only once).

To sum up, this bug report only concerns the bug itself (i.e.: too small select lists in Language Settings > Writing Aids). I don't know how the bug can be solved (resizable options window could be one possible solution, but I think larger select lists may be the better solution). Therefore this bug report is really a bug report and not an enhancement request. I'll adjust the bug title and description on Launchpad (Ubuntu) if possible, because it is misleading and differs from this bug request.

summary: - Options window not resizable
+ CONFIGURATION: Too small select lists in Language Settings > Writing
+ Aids
description: updated

Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4979a3cfd43b9f79005bf76da9e2dbdffc9e91f5

Revert "fdo#49421: the "Available language modules" list is too small and ...

Created attachment 61229
Fixed listboxes - Ubuntu

(In reply to comment #3)
> For me it is a regression from LO 3.4.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a64e5bbd43e262d87e291dcc411628efac61fde
makes lisboxes look like in 3.3 I think.

Changing to Triaged Medium due to the upstream discussion and patch.

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
Changed in libreoffice (Ubuntu):
importance: Wishlist → Medium
status: Won't Fix → Triaged
summary: - CONFIGURATION: Too small select lists in Language Settings > Writing
- Aids
+ [Upstream] CONFIGURATION: Too small select lists in Language Settings >
+ Writing Aids
Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Fix Released

Fix will be released with LibreOffice 3.6.X.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.10
Sebastien Bacher (seb128) wrote :

3.6 is in quantal, closing the bug

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.