[Upstream] LibreOffice Calc unshows comments importing MS Office xlsx

Bug #990868 reported by peterzay on 2012-04-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Calc via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/990868/+attachment/3114178/+files/Workbook1-2.xlsx && localc --nologo Workbook1-2.xlsx

is MS Excel file has the the comments in sheet 1 - Control Menu remain unshown, as it does in OpenOffice 3.2.0 Build 9483 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/990868/+attachment/3117617/+files/Good_Display.png .

4) What happens instead is the comments are shown as noted in the screenshot https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/990868/+attachment/3117619/+files/Bad_Display.png .

WORKAROUND: Open with OpenOffice, save as ods, then open the ods file in LibreOffice.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice-calc 1:3.5.2-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sat Apr 28 22:11:35 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 56854
Function "show comments" is always enabled

When i open xlsx spreadsheet with comments in cells, function "show comments" is always enabled (see in screenshot). Please fix it.

Created attachment 59075
Calc Comment Mess image

My client uses popup comments to extensively document his spreadsheets. When I open these documents, all the comments are shown opened. I normally use Ubuntu and LibreOffice to open and view these spreadsheets, but I just began using LibreOffice on Windows 7.

I cannot find a way to close all the comments for the whole spreadsheet. And it takes a long time to close them one by one.

Could this be added? Maybe to the View menu or configuration for Calc (Tools: Options: Calc: View).

[Reproducible] with "LibreOffice 3.5.2.2 - Windows XP SP3 (32bit) Spanish UI"

peterzay (peterzay) wrote :
peterzay (peterzay) wrote :

If I open the Microsoft sheet with OpenOffice, save as ods, then open the ods file in LibreOffice, everything works fine.

But that defeats the point of using LibreOffice.

peterzay, thank you for reporting this and helping make Ubuntu better. Could you please post a screenshot of how it should look like and then one of how it is corrupted specifically?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
peterzay (peterzay) wrote :

Here is a screenshot of how the sheet should look (OpenOffice).

peterzay (peterzay) wrote :

Here is a screenshot of how the sheet is corrupted (LibreOffice).

Changed in libreoffice (Ubuntu):
status: Incomplete → New

peterzay, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

description: updated
tags: added: regression-release
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in df-libreoffice:
status: New → Incomplete
summary: - LibreOffice Calc corrupts complex multi tab sheet
+ LibreOffice Calc unshows comments
summary: - LibreOffice Calc unshows comments
+ LibreOffice Calc unshows comments importing MS Office xlsx
Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - LibreOffice Calc unshows comments importing MS Office xlsx
+ [Upstream] LibreOffice Calc unshows comments importing MS Office xlsx
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

[Reproducible] with parallel installation of Master "LOdev 3.6.0alpha0+ – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 52348aa]" (tinderbox: Win-x86@6-fast, pull time 2012-04-27 21:25:23) and sample document from "FILEOPEN MS2007 .xlsx shows comments what should be hidden" <https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/990868/+attachment/3114178/+files/Workbook1-2.xlsx>

Not shown in 3.4.5, so Regression.

Old Master bug, already visible with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 3b32204-7f92fce-2ba0a9f)]" (2011-09-03) and in
even more old Master build from July 2011

OS=All due to DUPs

@Kohei:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug

*** Bug 49150 has been marked as a duplicate of this bug. ***

*** Bug 49288 has been marked as a duplicate of this bug. ***

Changed in df-libreoffice:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

The bug still exists in LO 3.5.3.

As per https://bugs.freedesktop.org/show_bug.cgi?id=47904#c1 , Version -> LibO 3.5.0 Release.

tags: added: needs-bisect

@Christopher M. Penalver
No. The problem appeared much before 3.5.0 in LibO-DEV 3.5.0 – for details see Comment 1.

(In reply to comment #6)
> @Christopher M. Penalver
> No. The problem appeared much before 3.5.0 in LibO-DEV 3.5.0 – for details see
> Comment 1.

No. LO 3.4.5 opens xlxs with comments correctly.

Thanks for bugreport
Please, attach sample xlsx document that demonstrates this problem

Created attachment 62430
sample document

Here you are and sorry for the delay.

and sorry for my english ;)

Thanks for attachment
reproduced in 3.5.0 beta 3 on Windows XP and 3.5.4 on Fedora 64 bit
NOT reproduced in 3.3.4 and 3.4.2, therefore regression

I confirm that the bug still exists in 3.5.4.2. In my case it rendered several documents basically unreadable: it is impossible to manually close hundreds of comments, and those comments in turn obscure the bulk of the spreadsheet. The mess is even worse than in Dirk Huizenga's example, alas confidential info so can't post it here.

This bug reports the same problem:

Bug 47904 - FILEOPEN MS2007 .xlsx shows comments what should be hidden

*** Bug 47904 has been marked as a duplicate of this bug. ***

*** Bug 47753 has been marked as a duplicate of this bug. ***

Changed in df-libreoffice:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.0~beta2-0ubuntu2

---------------
libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

  * Build using the internal libmspub for a first build.
 -- Matthias Klose <email address hidden> Tue, 19 Feb 2013 00:05:26 +0100

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.