soffice.bin crashed with SIGSEGV in EditView::ShowCursor()

Bug #956130 reported by Xavier Guillot on 2012-03-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

I had 2 Libre Office Calc documents opened, without macros, just normal tables.

I clicked on the "close" button on 1 document, nothing happened, I switched to the other with Unity icon, then got the grey window with error message, I choose "Wait", but suddendly the 2 documents shut down.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libreoffice-core 1:3.5.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Thu Mar 15 16:50:50 2012
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --calc /home/username/Bureau/Corn-Lavaur-2011ods --splash-pipe=6
SegvAnalysis:
 Segfault happened at: 0x5d087e7 <_ZN8EditView10ShowCursorEhh+39>: mov 0x4(%esi),%eax
 PC (0x05d087e7) ok
 source "0x4(%esi)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 EditView::ShowCursor(unsigned char, unsigned char) () from /usr/lib/libreoffice/program/../program/libeditenglo.so
 ?? () from /usr/lib/libreoffice/program/../program/libsclo.so
 ?? () from /usr/lib/libreoffice/program/../program/libsclo.so
 ?? () from /usr/lib/libreoffice/program/../program/libsclo.so
 ?? () from /usr/lib/libreoffice/program/../program/libsclo.so
Title: soffice.bin crashed with SIGSEGV in EditView::ShowCursor()
UpgradeStatus: Upgraded to precise on 2012-03-13 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Xavier Guillot (valeryan-24) wrote :

StacktraceTop:
 EditView::ShowCursor (this=0x0, bGotoCursor=0 '\000', bForceVisCursor=1 '\001') at /build/buildd/libreoffice-3.5.0/editeng/source/editeng/editview.cxx:461
 ?? ()
 ?? ()

Changed in libreoffice (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

debconf version 1.5.41ubuntu2 required, but 1.5.42ubuntu1 is available

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
Xavier Guillot (valeryan-24) wrote :

I can not upgrade debconf to a previous version !

visibility: private → public
Changed in libreoffice (Ubuntu):
status: Invalid → New

Xavier Guillot, thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?
* You are not using the most recent version of this package for your Ubuntu release. Could you please upgrade to the most recent version and let us know if you are still having this issue?

This will help us to find and resolve the problem.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Xavier Guillot (valeryan-24) wrote :

Since this crash, I did not reproduce the bug, now LibreOffice is 3.5.3.2 on Ubuntu Precise on my computer.

I precise I used lo-menubar at the crash time (I still use it), as for the print view crash, but this one happened when closing a document.

If it occurs again, I'll post the crash logs here.

Xavier Guillot, this bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers