LibreOffice quicklists are not translated

Bug #950825 reported by Nicolas Delvaux
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Fix Released
High
Unassigned
libreoffice (Ubuntu)
Fix Released
Undecided
Björn Michaelsen
Precise
Fix Released
Undecided
Björn Michaelsen

Bug Description

The "ubuntu-quicklists.diff" patch does not seem to work properly.

For example, if you run "cat /usr/share/applications/libreoffice-calc.desktop" you will see that the "New Spreedsheet" quicklist is translated to "New Spreedsheet" in all languages, whereas correct translations are in the patch.

I downloaded the patch from https://launchpad.net/ubuntu/+archive/primary/+files/libreoffice_3.5.0-2ubuntu1.debian.tar.gz (this is the libreoffice version I have).

This bug happens only on Precise (quicklists are translated on Oneiric).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice-core 1:3.5.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
CheckboxSubmission: 8cf001b4b1d1f2fddc8b471a28b5eaa6
CheckboxSystem: d89cfecb506be0562834433b44d8bcb5
Date: Fri Mar 9 14:40:08 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111222)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-02-16 (21 days ago)

Revision history for this message
Nicolas Delvaux (malizor) wrote :
Revision history for this message
Gabor Kelemen (kelemeng) wrote :

Also, we used https://wiki.ubuntu.com/Translations/Wanted to translate these strings, but now the subpages say these should be translated upstream. These strings however do not appear in the upstream po file: https://translations.documentfoundation.org/hu/libo35x_ui/sysui/desktop/share.po/translate/

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Changed in libreoffice (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
no longer affects: hundredpapercuts
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Revision history for this message
Gabor Kelemen (kelemeng) wrote :

It seems that quicklists became parts of the desktop entry spec, so I guess upstream LO could be convinced easily about including these:

http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html#extra-actions

Revision history for this message
filorin (filorin-deactivatedaccount) wrote :

We're not far from the final realease and this "little" problem still exists. It's a problem because poeple who want to discover Ubuntu will see this problem ...

Revision history for this message
David Planella (dpm) wrote :

Had a chat with Björn this morning and he'll try to fix it, although it's low on the priority list of all things to fix before release, and it reportedly isn't just a trivial fix.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :
Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Nicolas, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Revision history for this message
Claudio Arseni (claudio.arseni) wrote :

It seems that the bug was fixed with last update of libreoffice (with proposed enabled). Quicklists appear now translated.

Revision history for this message
Mozaic (mozaic) wrote :

i confirm

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng)
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers