Personal settings are lost after upgrading to LibreOffice 3.5/Precise

Bug #950794 reported by joehill
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Opinion
Undecided
Unassigned

Bug Description

I just upgraded from Ubuntu 11.10 to 12.4 and LibreOffice no longer uses any of my personal settings from the previous version (file history, spelling, autocorrect, extensions, etc.). Everything is still in my ~/.libreoffice/3/user/ folder, but LibreOffice simply doesn't seem to see it. Maybe the new version stores things in another location but if so I can't tell where this is or how to import my settings.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice 1:3.5.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
Date: Fri Mar 9 14:37:10 2012
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-03-09 (0 days ago)

Revision history for this message
joehill (joseph-hill) wrote :
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

as per http://wiki.documentfoundation.org/UserProfile the profile moved to:
/home/<user name>/.config/libreoffice/3/user (since LibreOffice 3.5.0)
to conform with XDG_CONFIG_HOME.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Revision history for this message
joehill (joseph-hill) wrote :

Isn't it still a bug if the only way to upgrade from LibreOffice 3.4 to 3.5 is to do extensive searching on-line about where the config files go? Is this something an average user is supposed to know? I've spent hours doing Google searches for how to migrate. Shouldn't there be some warning when you upgrade, or perhaps some way to migrate the settings manually?

I would think developers would want upgrading to be as transparent a process as possible for non-technical users so people would not to have to dig around in config files and Google just to keep using software.

Thanks for looking at the report.

Revision history for this message
Jack Leigh (leighman) wrote :

Can the folder not be copied across on upgrade?

Revision history for this message
joehill (joseph-hill) wrote :

I would think that would be the ideal solution (either copying or moving or symlinking). Otherwise everyone's going to wonder where their settings went and will waste a lot of time trying to figure out how to fix it.

Changed in libreoffice (Ubuntu):
status: Invalid → New
summary: - After upgrading to LibreOffice 3.5/Precise, LibreOffice stops using my
- personal settings
+ Personal settings are lost after upgrading to LibreOffice 3.5/Precise
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Silently modifying data in the user directory is not option.

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
joehill (joseph-hill) wrote :

I'm not advocating doing it silently. There are many packages that ask on upgrading if the user wants to update configuration or user details to conform with the new standard. It seems it would be relatively easy to have a dialog that says something like "This version of LibreOffice stores user data in a different location than the one you have been using. What would you like to do? * Leave user data where it is. * Copy user data to the new location (~/.config/libreoffice/) * Move user data to the new location.

Or at the very least have a warning: "Warning: This new version of LibreOffice stores user data in a different folder than previous versions. If you would like to use your existing user data, please move it . . ." Or have a dialog come up at the first startup saying something like "LibreOffice has detected user data from a previous version. Would you like to import that data?"

In my view silently changing where data is supposed to be is as objectionable as silently changing it to the correct location. Neither is necessary though.

Revision history for this message
joehill (joseph-hill) wrote :

So I know we all have opinions about this and I'm not a developer, but in my view it's a big (not invalid) bug to make people lose their settings on upgrading. I guarantee there are lots of users like me who want to use their settings and don't want to spend hours Googling and going through Launchpad to figure out how to do it--people expect to be able to use all their applications immediately after upgrade, not to find things broken (which losing your personal settings does--it breaks your work flow and is as important as having other aspects of the program work correctly).

Changed in libreoffice (Ubuntu):
status: Invalid → Opinion
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

We are past UI freeze, so we cant do anything with dialogs (esp. not since they require l10n).

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

also note: https://bugs.freedesktop.org/show_bug.cgi?id=46155

profile migration would be quite tricky.

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

What would be a complete workaround for this, while keeping existing configuration/profile data ?

komputes (komputes)
affects: df-libreoffice → ubuntu-release-notes
tags: added: css-sponsored-p
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

So, 3.5.2 should do a profile migration from .libreoffice to .config/libreoffice. A way to test that is to remove/move .config/libreoffice while having the old .libreoffice around. LibreOffice should then migrate the profile again. Note there there still might be issues (esp. if the profile is broken in some way already although it was unnoticed in 3.4, for example by extensions).

Revision history for this message
Etienne Goyer (etienne-goyer-outlands) wrote :

Not directly related to this bug, here's a tangential question: are the profile personal setting from OO.org 3.2.0 on lucid get migrated to LibreOffice 3.5.2 during LTS-to-LTS upgrade? I presume not; if that is the case, perhaps it ought to be documented in the release note.

Revision history for this message
Andy Whitcroft (apw) wrote :

Based on comment #13 we should have migration, therefore no release note is required.

Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.