[Upstream] LibreOffice doesn't update printer list on netbook WiFi to router to ethernet to PC w/ cups server usb to HP OfficeJet Pro 8500

Bug #911235 reported by Alexander Kallenbach on 2012-01-03
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

1) Ubuntu 11.10

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installiert: 1:3.4.4-0ubuntu1
  Kandidat: 1:3.4.4-0ubuntu1
  Versionstabelle:
 *** 1:3.4.4-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

3) What is expected to happen on a netbook WiFi connected to router to ethernet to PC hosting cups server USB connected to HP OfficeJet Pro 8500 is with the printer off, LibreOffice Writer running, is when one turns the printer on Writer immediately recognizes the printer is available to be printed to.

4) What happens instead is the printer is not available to be printed to. This occurs every time this is tested. However, Evince and Firefox can print to the printer with no problem.

WORKAROUND: Turn on the printer, restart Writer.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Jan 3 14:40:37 2012
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to oneiric on 2011-11-17 (46 days ago)

1. Start LibreOffice Writer
2. Add new printer in Cups
3. Open the print dialog

EXPECTED:
You can see the newly added printer

OBSERVED:
Printer is not there. You need to colse Writer and open it again for it to notice the printer.

P.S. OpenOffice didn't have this problem, I could even start/stop cups and Writer would update printing dialog correspondingly.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

I've tested this issue on 3.5beta2
It does get reproduced

Alexander Kallenbach, thank you for reporting this and helping make Ubuntu better. Please answer the following questions:
+ Does this issue occur every time the printer is off and you turn it on?
+ Can other programs print to the printer in the same situation that LO cannot?
+ What is the printer manufacturer and model?
+ When you say network printer, how is it connecting to the PC specifically, bluetooth, WiFi, USB, ethernet, etc.?

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
description: updated

Does this issue occur every time the printer is off and you turn it on?
 - Yes it does.

Can other programs print to the printer in the same situation that LO cannot?
- Yes, they can. Tested with Evince and Firefox.

What is the printer manufacturer and model?
- HP Officejet Pro 8500

When you say network printer, how is it connecting to the PC specifically, bluetooth, WiFi, USB, ethernet, etc.?
- The printer is connected to my desktop PC which is as well running Ubuntu. In fact I didn't start my printer but my desktop PC. I tried to print a document on my netbook which is connected via Wifi with the network.

description: updated

Alexander Kallenbach,

1) Regarding your comments:

"When you say network printer, how is it connecting to the PC specifically, bluetooth, WiFi, USB, ethernet, etc.?
- The printer is connected to my desktop PC which is as well running Ubuntu. In fact I didn't start my printer but my desktop PC. I tried to print a document on my netbook which is connected via Wifi with the network."

Unfortunately, this did not answer the question. It is understood the desktop PC and printer are connected. Specifically, how is the desktop PC your reporting this problem about network connected to the printer? WiFi, as is the netbook? Ethernet?

2) Does the netbook also have the same problem printing from LO Writer via WiFi?

3) Please execute the following on your desktop PC from the Terminal and post to this bug report:
apt-cache policy libreoffice-writer

The printer is connected via USB to my desktop PC. On my desktop PC a CUPS-Server is running. The desktop-PC is connected via Ethernet with the router. My netbook, from which I wanted to print a document, is connected via Wifi with the router.

On my desktop PC I haven't seen this bug (the printer is directly connected to the PC via USB).
So I will post the apt-cache from my netbook.

The asked apt-cache-output from my netbook:

libreoffice-writer:
  Installiert: 1:3.4.4-0ubuntu1
  Kandidat: 1:3.4.4-0ubuntu1
  Versionstabelle:
 *** 1:3.4.4-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Alexander Kallenbach, please answer the following questions:

+ Does the problem occur with your printer USB connected to desktop?
+ Does the problem occur with your printer WiFi connected to netbook?

description: updated

Does the problem occur with your printer USB connected to desktop?
- Yes. The printer is connected to my desktop. But the problem doesn't occur on my desktop but on my netbook, which is connected via Wifi.

Does the problem occur with your printer WiFi connected to netbook?
- No. The printer doesn't have a Wifi functionality. But the netbook is connected via Wifi with the network.

description: updated
summary: - Libreoffice doesn't update printer list
+ Libreoffice doesn't update printer list to USB connected HP OfficeJet
+ Pro 8500

Alexander Kallenbach, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
Changed in df-libreoffice:
status: New → Incomplete
summary: - Libreoffice doesn't update printer list to USB connected HP OfficeJet
- Pro 8500
+ Libreoffice doesn't update printer list

I had to change the bug description cause you made a complete other bug out of it. I hope everybody understands what I mean.

description: updated
description: updated

I wanted to print a document out of Libreoffice-Writer from my netbook (which is connected via Wifi with the router/network). The printer is connected to my desktop PC (via USB) and is shared via the network. At first my desktop was of, so it is clear that the printer wasn't shown in the printer list of Libreoffice. But then I turned on my desktop and expected that the printer would appear in the printer list. But he didn't appear. This occurs every time the printer is off, and Writer is running.
I've tested it with other applications (Evince and Firefox) and there it worked fine.

I had to restart Libreoffice to make it recognize the printer.

I already posted a bug report on launchpad: https://bugs.launchpad.net/bugs/911235

Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Libreoffice doesn't update printer list
+ Libreoffice doesn't update printer list on netbook WiFi to router to
+ ethernet to PC w/ cups server
summary: - Libreoffice doesn't update printer list on netbook WiFi to router to
- ethernet to PC w/ cups server
+ [Upstream] Libreoffice doesn't update printer list on netbook WiFi to
+ router to ethernet to PC w/ cups server
summary: - [Upstream] Libreoffice doesn't update printer list on netbook WiFi to
+ [Upstream] LibreOffice doesn't update printer list on netbook WiFi to
router to ethernet to PC w/ cups server

Alexander Kallenbach, thank you for filing the upstream bug. Please do not edit the Bug Description. I wrote it incorrectly due to your contradictory answers in comment #7. Now that I know which answers you provided are the correct ones, I have edited it appropriately. :D

description: updated
summary: [Upstream] LibreOffice doesn't update printer list on netbook WiFi to
- router to ethernet to PC w/ cups server
+ router to ethernet to PC w/ cups server usb to HP OfficeJet Pro 8500

Importance -> lowest trivial due to incredibly easy WORKAROUND: Restart LibreOffice.

Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → New

*** Bug 44452 has been marked as a duplicate of this bug. ***

Changed in df-libreoffice:
importance: Low → Unknown
status: New → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

*** Bug 50027 has been marked as a duplicate of this bug. ***

Chrescht (sekateur) wrote :

This is still happening in Ubuntu 12.04 and LibreOffice 3.5.7.2.
Printer list is empty.
Fortunately restarting LibreOffice is still a valid workaround..

tags: added: 12.04 libreoffice-3.5
tags: removed: 12.04 libreoffice-3.5

should be fixed by:

commit 02efbed152a3a9e364cdb73628af0aed0f5d6f7a
Author: Caolán McNamara <email address hidden>
AuthorDate: Wed Dec 4 16:48:08 2013 +0000

    Resolves: rhbz#1038189 refresh printer list when print dialog launched

Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07f0566026db8f5ec048297785f82a43e73a14f6&h=libreoffice-4-2

fdo#41760 rhbz#1038189 refresh printer list when print dialog launched

It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) on 2014-02-23
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged

Print dialog error message:-

If I use the LO print dialogs every other time
I print I get a message

Could not start printer
Please check your printer configuration

It still prints, is this related to this bugs fix

If I use the system dialogs I don't get the message

This is openSuse 13.1, LO 4.2.3 from factory and KDE 4.12.4

mal, please create a new bug. this is years old and has been fixed. if you think what you are seeing is related, add this bug here to the "see also:" section.

The bug is really old but the fix is only 2 months old and the fixer said test and give feedback?

Regards

Mal

Someone has reported this already as a regression
Added to 'See Also'

Fixed upstream at 4.3.0 and 4.2.3, we ship newer versions, thus closing as fix released.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Raul Dias (rsd) wrote :

This still happens on 15.10 and libreoffice 5.x up to today.

Raul Dias, you would want to upgrade to confirm this is also fixed for you. If it isn't, then you have a completely different root cause (same symptom), and would want to file a new report.

Raul Dias (rsd) wrote :

It still happens on 16.04.
Please see bug https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1568339 .

Raul Dias, to advise, this report is closed, and has nothing to do with your problem. Posting to this report will not help address your problem in any way.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.