[Upstream] Printing/Exporting to PDF adds text to the side of form elements

Bug #891522 reported by HPO on 2011-11-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

apt-cache policy acroread
acroread:
  Installed: 9.5.1-1precise1
  Candidate: 9.5.1-1precise1
  Version table:
 *** 9.5.1-1precise1 0
        500 http://archive.canonical.com/ubuntu/ precise/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Writer via the Terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2600734/+files/testdocument.odt && lowriter -nologo testdocument.odt

and either:
File -> Print -> button OK

or:
File -> Print -> tab Options -> check checkbox Print to File

and the resulting print or PDF looks as it does in Writer.

4) What happens instead the print and PDF have text overlapping as in the PDF https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2599557/+files/printout .

WORKAROUND: For printing, switch 'Printer Language Type' to PostScript.

WORKAROUND: For exporting PDF, use File -> Export as PDF.

Original Reporter Comments: I use oneiric libreoffice, all updated: Libreoffice 3.4.3 (OOO340m1, Build 302)

---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
Lpstat:
 device for canon: ipp://canon.v.hsg.oerinet.ch/ipp
 device for lj: ipp://lj.v.hsg.oerinet.ch/ipp?waitjob=false
 device for NEC: ipp://nec.v.hsg.oerinet.ch/ipp/port1
MachineType: Hewlett-Packard HP Compaq 8000 Elite CMT PC
Package: cups 1.5.0-8ubuntu4
PackageArchitecture: amd64
Papersize: letter
PpdFiles:
 lj: HP LaserJet P3005 Postscript (recommended)
 NEC: NEC PinWriter P6 plus Foomatic/necp6 (recommended)
 canon: Canon iR-ADV C5045/5051 PS
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-3.0.0-12-generic root=UUID=5e2bd312-cd41-4acd-9ddc-ff20a0e59419 ro rootflags=subvol=@ quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Tags: oneiric
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786G7 v01.02
dmi.board.asset.tag: CZC018BLK5
dmi.board.name: 3647h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: CZC018BLK5
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786G7v01.02:bd10/22/2009:svnHewlett-Packard:pnHPCompaq8000EliteCMTPC:pvr:rvnHewlett-Packard:rn3647h:rvr:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP Compaq 8000 Elite CMT PC
dmi.sys.vendor: Hewlett-Packard

HPO, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 891522
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

As well, please attach all relevant information requested in: https://wiki.ubuntu.com/DebuggingPrintingProblems#Capturing_print_job_data

affects: libreoffice (Ubuntu) → cups (Ubuntu)
Changed in cups (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Please folllow the instructions of the sections "CUPS error log" and "Capturing print job data" of https://wiki.ubuntu.com/DebuggingPrintingProblems for two print jobs, first the form printed with default settings ('Printer Language Type' set to 'PDF') and second, with 'Printer Language Type' set to 'PostScript'.

Attach the files one by one, do not compress them and do not package them together. It is no problem to create more than one comment by that.

HPO (hpo) wrote :

In the PDF 'printout', please see the 'overlay' just right of checkboxes/radio buttons

HPO (hpo) wrote :

in the second printout, please note the absence of those overlays

HPO (hpo) wrote : BootDmesg.txt

apport information

tags: added: apport-collected oneiric
description: updated
HPO (hpo) wrote : CupsErrorLog.txt

apport information

HPO (hpo) wrote : CurrentDmesg.txt

apport information

HPO (hpo) wrote : Dependencies.txt

apport information

HPO (hpo) wrote : Locale.txt

apport information

HPO (hpo) wrote : Lspci.txt

apport information

HPO (hpo) wrote : Lsusb.txt

apport information

apport information

HPO (hpo) wrote : ProcCpuinfo.txt

apport information

HPO (hpo) wrote : ProcInterrupts.txt

apport information

HPO (hpo) wrote : ProcModules.txt

apport information

HPO (hpo) wrote : UdevDb.txt

apport information

HPO (hpo) wrote : UdevLog.txt

apport information

As the captured jobs (comments #3 and #4) which you obtain via the "Capturing print job data" instructions are the original data of the application sent to CUPS, before any CUPS filtering starts and the problem already appears in the PDF job the bug is in LibreOffice, moving ...

affects: cups (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Incomplete → New

HPO, could you please attach the LibreOffice document that you are exporting to PDF and PS?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
HPO (hpo) wrote :

HPO, this is unreproducible in Ubuntu 11.10 32-bit, LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2600734/+files/testdocument.odt && lowriter -nologo testdocument.odt

saved to pdf and noticed no overlapping as shown in: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2599557/+files/printout

When exporting to pdf what options did you choose to generate the overlay?

lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.4.4-0ubuntu1~ppa1
  Candidate: 1:3.4.4-0ubuntu1~ppa1
  Version table:
 *** 1:3.4.4-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

apt-cache policy acroread
acroread:
  Installed: 9.4.6~enu-0oneiric1
  Candidate: 9.4.6~enu-0oneiric1
  Version table:
 *** 9.4.6~enu-0oneiric1 0
        500 http://archive.canonical.com/ubuntu/ oneiric/partner i386 Packages
        100 /var/lib/dpkg/status

HPO (hpo) wrote :

There seems to be a misunderstanding:
I'm NOT EXPORTING, but PRINTING!

I don't see any PDF options for printing. Other than the printer language selection (PDF/PS), of course.

HPO (hpo) wrote :

However, exporting to PDF - irrespective of export options - produces the same result here.... it cannot be a 32bit/64bit problem, can it?

HPO (hpo) wrote :

I tried 3.4.4 from above-mentioned ppa - same result.

However:
If an actual PDF FORM is created, the overlays disappear. The form elements are rendered differently, however.

Changed in libreoffice (Ubuntu):
status: Incomplete → New

HPO, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in df-libreoffice:
status: New → Incomplete

Created attachment 55048
writer document with form elements

Printing with printer language PDF or exporting to PDF a document with form elements, the resulting PDF has added further text to the side of form elements ('checkbox',...).

Exporting to actual PDF forms, this does not happen. The graphical representation of the elements changes, however.

Printing with printer language PS does not include that additional text either.

Created attachment 55049
printout in pdf format

Created attachment 55050
printout in ps format

HPO (hpo) wrote :
Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Forms printed with Printer Language PDF get mangled
+ [Upstream] Printing/Exporting to PDF adds text to the side of form
+ elements
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → New

Hi Hans-Peter,
I've seen this before, I think.

I think I solved it by removing the default names of the elements, or narrowing the boxes, or ... ?
Abyway, I confirm this, also in 3.5.0rc1

Changed in df-libreoffice:
status: New → Confirmed
description: updated
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
description: updated

1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

apt-cache policy acroread
acroread:
  Installed: 9.5.1-1precise1
  Candidate: 9.5.1-1precise1
  Version table:
 *** 9.5.1-1precise1 0
        500 http://archive.canonical.com/ubuntu/ precise/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Writer via the Terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2600734/+files/testdocument.odt && lowriter -nologo testdocument.odt

and either:
File -> Print -> button OK

or:
File -> Print -> tab Options -> check checkbox Print to File

and the resulting print or PDF looks as it does in Writer.

4) What happens instead the print and PDF have text overlapping as in the PDF https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/891522/+attachment/2599557/+files/printout .

WORKAROUND: For printing, switch 'Printer Language Type' to PostScript.

WORKAROUND: For exporting PDF, use File -> Export as PDF.

Changed in df-libreoffice:
importance: High → Medium

I tested it with LO 4.4.0.0.beta1 (Win 8.1) with EXPORT AS PDF and with PRINT -> pdf printer.

-> I could not reproduce it as it is seen in the pdf attachment (but I don't see the logo in the top left).

This bug is already quite old. Therefore, is this issue for others still reproducible with the latest releases of LO?
Or is this a Linux only issue?

As of 2015-01-05, the issue still stands (see attached PDF printout).

The added text seems to be the control's 'label' text. Emptying all 'label' properties, seems a good workaround.

Still, the handling of PDF control 'labels' differs from screen an PS.

Created attachment 111757
printout in PDF 2015-01-05

HPO (hpo) wrote :

With current ubuntu LO (4.3.3) the issue stands.

As I wrote upstream, the added text seems to be the control's 'label' property.

(In reply to Hans-Peter Oeri from comment #6)
> The added text seems to be the control's 'label' text. Emptying all 'label'
> properties, seems a good workaround.

That was what I meant to say with my comment #3. Sorry if that was not clear ;)

I am also affected by this. I wanted to add that it only occurs when ISO 19005-1 conformity is checked (which however is something preferred where I work.
This is on 4.4.0.1 and 4.0.5 (regardless of OS).

However, on current master (Version: 4.5.0.0.alpha0+
Build ID: 57626f2132f73e4e42b31e364b25c5867336e718) the problem occurs irrespective of the selection of PDF/A-1a

Not reproducible in Wily.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.