Ubuntu

icon is replaced by a question mark

Reported by loicjacquardtest on 2011-10-14
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

icon is replaced by a question mark. same for the dash. relocation does not change.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice-writer 1:3.4.3-3ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 12:00:45 2011
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Victor (vic-tor) wrote :

Same problem here.
The icon exists as
/usr/share/icons/hicolor/48x48/apps/libreoffice34-writer.png

In /usr/share/applications/libreoffice-writer.desktop I had Icon=libreoffice34-writer
I tried to specify the absolute path to the icon like this: Icon=/usr/share/icons/hicolor/48x48/apps/libreoffice34-writer.png. I also tried without the extension .png. But neither worked, there is still a question mark in the dash.
This also affects the icon of Impress

Interestingly, the icon of Calc is ok. I can't see any difference between calc's .desktop file and the other two ones. The icons also have the same properties. I compared them with "ls -lh" and "file".

I am experiencing this issue (a default "X" icon is shown instead of the correct one) with KDE on one PC, but not another. Both have been upgraded from Kubuntu 11.04, both are x86_64 based. Installed libreoffice packages look identical so far. The main difference between both machines is the graphics card (and consequently the X server): The PC with the broken icons is using the proprietary nvidia driver whereas the working one is using the intel xserver.

For those subscribers, who can reproduce the issue: What graphics driver / xserver are you running? Which display color-depth is your X running at?

Victor (vic-tor) wrote :

Mine also uses the proprietary nvidia driver.

My machine is an nvidia (proprietary) at a depth of 24.

I have a laptop with Intel graphics and there is no issue.

In the meantime I switched over from the proprietary nvidia drivers to
nouveau. The problem persists, so it is certainly not strictly related
to the nvidia drivers.

Jim McKean (jimmckean) wrote :

Using Asus 1018P with 11.10. Intel graphics. Same problem with Writer. All other LO icons are OK, but WorkSpace switcher is the same generic icon.

Are these all upgrades? Because I just found out that there's a ~/.local/share/applications folder that takes priority over the installed .desktop files. I deleted the libreoffice writer .desktop file and the icon is there and all works dandy. Perhaps there is an inconsistency between 11.04 and 11.10,

Victor (vic-tor) wrote :

Indeed, mine was an upgrade too. Chauncellor's fix worked for me: I deleted the libreoffice .desktop files in ~/.local/share/applications, and the icons now reverted to normal. Thanks!

On Thu, Nov 17, 2011 at 13:47, Victor <email address hidden> wrote:
> Indeed, mine was an upgrade too. Chauncellor's fix worked for me: I
> deleted the libreoffice .desktop files in  ~/.local/share/applications,
> and the icons now reverted to normal. Thanks!

While my system has also been upgraded, ~/.local/share/applications
does not contain any relevant files (locate confirms that the only
.desktop files for LibreOffce are located in
/usr/share/app-install/desktop/ and /usr/share/applications/ - why
both?)...

Jim McKean (jimmckean) wrote :

In my case, the *.desktop file located in ~/.local/share/applications had an error in the ICON= string. It said 'libreoffice-writer.png' instead of 'libreoffice34-writer.png.' Not sure what created that local file, but whatever it is might be the root cause.

fixed in ubuntu 12.04

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers