Ubuntu

some function names in Calc appear in english others in local language (mixed up)

Reported by SWUbuntu on 2011-10-13
250
This bug affects 44 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Björn Michaelsen
Oneiric
High
Björn Michaelsen
Precise
High
Björn Michaelsen

Bug Description

Ubuntu 11.10
LibreOffice 3.4.3 OOO340m1 (Build:302) (Ubuntu-build)

UI is set to German
Function Wizard shows some function names in english others in german

demonstrated this bug to Björn Michaelsen at LibreOffice-Conference in Paris today.

This is severe, because in order to use the functions one must use english function names for some functions and german function names for other functions, but you don´t know for which function exactly which language is to be used.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
.cobnet (mattias-campe) wrote :

I can confirm this bug with an UI set to Dutch. This is indeed a severe bug.

Nukeador (nukeador) wrote :

I can confirm it too using Spanish as main language, the problem is critical since calc documents created with Spanish functions names no longer work that's 100% of my files.

jsiebold (jsi150) wrote :

Kubuntu 11.10
LibreOffice: 3.4.3-3ubuntu2

I can confirm this error.

System Language and UI-Language: German
Entering summe(xn:yn) throws an error, sum(xn:yn) does not.

Martin Vogel (marvodor) wrote :

A strange detail of this severe bug is that the help texts refer to the right functions under the false names.

Martin Vogel (marvodor) wrote :

I tried to purge the existent libreoffice and openoffice(?) files by entering
sudo apt-get purge 'openoffice*'
and
sudo apt-get purge 'libreoffice*'
in a terminal.

In Synaptic I added the packet source
ppa:libreoffice/ppa
to be sure to receive the latest version of the libreoffice packet.

After the whole procedure the bug is still there.

Nukeador (nukeador) wrote :

Do we know if the bug was reported upstream or it's just a Ubuntu packaging bug? This bug should be considered critical since major feature is broken.

Could anyone ping the package maintainer?

Martin Vogel (marvodor) wrote :

After uninstalling/purging the complete LibreOffice suite again I made a fresh install from the LibreOffice 3.4.3-302 DEBs at http://www.libreoffice.org/download

Everything works fine now, so it seems to be a packaging error in Oneiric.

Yvon Henel (yvon-henel) wrote :

I confirm it in French too.

Moreover some functions appear with their French Name in the menu (fx icon) but are not recognize either (for instance ANNEE = YEAR).

Tobias (ulbricht-tobias) wrote :

Confirm this bug again.
Since Björn Michaelsen is the libreoffice packaging guru, I'll stop my heuristic search for the bug at this point:

1. Looking at the libreoffice-translations archiv:
At least I found that all those functions that are _only_ present in
scaddins/source/analysis.po (e.g.)
and _not_ also in
formula/source/core/resource.po

seem to be in GERMAN language, e.g.:

tobias@einstein:de$ grep MONAT * -lr
formula/source/core/resource.po
helpcontent2/source/text/scalc/01.po
scaddins/source/datefunc.po
scaddins/source/analysis.po
tobias@einstein:de$ grep MONATE * -lr
helpcontent2/source/text/scalc/01.po
scaddins/source/datefunc.po

While MONATE() is german, MONTH() is english.

2. It seems a little weird with the _ADD functions, since
e.g. the GGT is wrongly displayed in english as GCD(),
but the GGT_ADD() function is german.
I cannot find the msgid in either po-file, only in
helpcontent2/source/text/scalc/01.po
So I guess these are composed internally to the GGT_ADD() somehow.

3. Comparing with other platforms: Also tried to build libreoffice to find out what is different to other platforms, but hey, I would need help here. Looking at the debian/rules it's no big deal to predict that the deb-packages from libreoffice.org/download are different than the ubuntu-packages.
One should check if this bug exists in the debian/testing or debian/sid releases.

4. Also: It does not change anything using the configuration switch: "LibreOffice Calc -> Formula -> Use english function names"

5. This bug is severely keeping me away from installing it.
All educational institutions should not install this localized version.

Hope something helps here.

Nukeador (nukeador) wrote :

I can't believe it's been 8 days since this bug was reported and no one has raised the priority.

Where is the person in charge of this package? No one from canonical QA is reading this to ping someone?

Dave Gilbert (ubuntu-treblig) wrote :

High: Renders essential features or functionality of the application or dependencies broken or ineffective

(IMHO this is mad behaviour on the file format, I'd have thought it would store it as a token so that any one in any language could use it)

Changed in libreoffice (Ubuntu):
importance: Undecided → High
tags: added: regression-release

Please, ...
as the poster of the bug said, he showed it directly to a person with
all the knowledge, but, as you might have noticed, there is a
libreoffice conference in Paris at the moment. So I would give the whole
another wekk or two before we can expect an answer...

Greetings, Tobias

Am 21.10.2011 00:13, schrieb Nukeador:
> I can't believe it's been 8 days since this bug was reported and no one
> has raised the priority.
>
> Where is the person in charge of this package? No one from canonical QA
> is reading this to ping someone?
>

Tobias (ulbricht-tobias) wrote :

Thank you Dave,

but I don't think it is the file format. As you, I would think this is
not stored in file format. It would'nt work otherwise.

And indeed: If I open an old file, which was definitely showing the
right localized functions then, they are now mostly english.

Am 21.10.2011 00:24, schrieb Dave Gilbert:
> (IMHO this is mad behaviour on the file format, I'd have thought it
> would store it as a token so that any one in any language could use it)

C de-Avillez (hggdh2) wrote :

Assigning to ubuntu-desktop; this is bad.

Changed in libreoffice (Ubuntu):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
Jeremy Bicha (jbicha) on 2011-10-20
Changed in libreoffice (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Jeremy Bicha (jbicha) on 2011-10-20
Changed in libreoffice (Ubuntu):
assignee: Ubuntu Desktop (ubuntu-desktop) → Canonical Desktop Team (canonical-desktop-team)
Tobias (ulbricht-tobias) wrote :

Another possibility:

This might be the same bug as described upstream here https://bugs.freedesktop.org/show_bug.cgi?id=32686 for LO 3.3.0 RC2 and _all_ platforms, when the configuration button "Use english function names" is checked.

Guessing in the blue:
So it might be, that regardless of the checked button, every Calc is trying to use the english names which fails, because it is still buggy?

On the other hand: I have created a list of bogus function names based on the work of GerardF for the bug by Kohei Yoshida, see attached.
The bogus _ADD functions are not in the list, and since I don't know how the list of ca. 300 function names was created in first place, I don't know if it is up-to-date.

Martin Pitt (pitti) on 2011-10-21
Changed in libreoffice (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Björn Michaelsen (bjoern-michaelsen)
importance: High → Medium
Changed in libreoffice (Ubuntu Oneiric):
importance: High → Medium

Investigating issue for oneiric-updates.

Probably a weird side effect of the -l10n source package split. Merge and rebuild fixed the issue:

http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=commit;h=d218052e8570bae8a8283a9925a2024db1085b7b

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed

Planned to be released as SRU with the upstream 3.4.4 release, which will be released on 2011-11-09.

Changed in libreoffice (Ubuntu Oneiric):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → oneiric-updates
Damien Lecan (dlecan) wrote :

> ... will be released on 2011-11-09.

Still 2 weeks to wait to see this issue fixed ??!? It's too long for me.
Any workaround until this date ?
Any testing PPA ?

Thanks

Guillermo Molleda (gmolleda) wrote :

Damien:
Martin Vogel (mail-martinvogel) wrote on 2011-10-19: #8

After uninstalling/purging the complete LibreOffice suite again I made a fresh install from the LibreOffice 3.4.3-302 DEBs at http://www.libreoffice.org/download

Everything works fine now, so it seems to be a packaging error in Oneiric.

I am building a libreoffice-3.4.4~rc1-0ubuntu1 release right now locally. If there is no problem I will upload it to the libreoffice ppa.

Martin Vogel (marvodor) wrote :

Björn, did you upload the 64-bit-build, too?

In Synaptic I can see two libreoffice packages now:

libreoffice 1:3.4.3-3ubuntu2
and
libreoffice:i386 1:3.4.4~rc1-0ubuntu1~ppa1

Nevertheless – the function names are all consistent now - thank you very much!

Damien Lecan (dlecan) wrote :

Martin, 64bits build was finished when you sent this message :-)
https://launchpad.net/~libreoffice/+archive/ppa/+build/2883015

Andros83 (mail-ceandrea) wrote :

Today 06/11/2011 the is present in my system Ubuntu 11.10 64 bit with all updates....italian version

I think it's very serious that default productivity suite have these problems and regressions especially after one month from the date of issue...
This is not a good advertising for the political "support for all languages​​" ...

Rafał Roncoszek (r-roncoszek) wrote :

I confirm the bug in Polish 11.10 64bit.
Importing MS Excel sheets works fine, but then working with Calc is "pretty uncomfortable".

Changed in libreoffice (Ubuntu Oneiric):
status: Confirmed → Triaged
Jorge E. Gómez (jorgeegomez) wrote :

I can confirm bug was fixed with the 2011-11-09 update from the LibreOffice PPA: (1:3.4.4-0ubuntu1~ppa1), but I found the bug again after updating from Oneiric main on 2011-11-22 (1:3.4.4-0ubuntu1).

Were the PPA fixes supposed to be included in main by now? or should I have indicated to apt-get to keep the PPA version?

Rafał Roncoszek (r-roncoszek) wrote :

I agree with Jorge - after today's update from Oneiric Main nothing's changed in my system. The bug still exists. Didn't try Libre PPA - I'm waiting for the bugfix in Main.

Jens Grüntjes (jenzuslongus) wrote :

The same holds for me. The function names are all in english after the update to 1:3.4.4-0ubuntu1

Aquilon (marc-descharles) wrote :

It-s same for me with french

Uwe Kaspers (4-uwe-h) wrote :

Installed LibreOffice 3.4.4 OOO340m1 (Build:402), still the same problem

Jürgen (j-w-ott) wrote :

this is one of the worst bugs I ever had in ubuntu. Think of all the users who rely on their linux machines. Solution is to delay dist-upgrades for non experts in future. Bad !

Investigating: First result however is that the ppa version 3.4.4-0ubuntu1~ppa1 confirmed to be good in #28 only differs from 3.4.4-0ubuntu1 in oneiric by one fix for bug 856210, which should never cause this issue. So essentially the two packages are identical sourcewise.

Jens Grüntjes (jenzuslongus) wrote :

That sounds really strange, but something must have changed so that the function names are messed up.

stef33560 (stef33560) wrote :

DAMNED ! :-#

It's a new argument to move from Ubuntu to Mint !!

Nicolas11 (ngranier) wrote :

Bonjour,
I just have to say i totally agree with Jürgen : in schools we just can't install Oneiric with this issue…

Erben Péter (erben-peter) wrote :

Same problem under oneiric 64bit Hungarian version, LibreOffice 3.4.4

Giliard (giliarde) wrote :

Same problem under oneiric 64bit Brazilian Portuguese version, LibreOffice 3.4.4

Jens Grüntjes (jenzuslongus) wrote :

@Björn: Is it possible to help you investigating? If yes, what can I do?

Doudz (sebastien-ramage) wrote :

I confirm it under oneiric 32bits French version, LibreOffice 3.4.4

any idea to solve this problem?

Rafał Roncoszek (r-roncoszek) wrote :

Jurgen is right - importance of this bug should be changed to high or very high. Of course it doesn't affect the stability of the system itself, but - as the office suite, used almost by everyone, is the integral part of the system - the people will see functionality of the system through the functionality of its integral components - especially the office suite.

Jens Grüntjes (jenzuslongus) wrote :

Do you think this bug will ever be fixed? It would be helpful to have some information on the progress. The bug is really very annoying. I can only confirm what Rafał wrote, it is an integral part of the system so it should have a higher priority.

Erben Péter (erben-peter) wrote :

Please give us some hope, that this bug will be fixed in the near future. The langauge of the function names is crucial in educational environment.

mario (marava1) wrote :

I too confirm in 1:3.4.4-0ubuntu1, Oneiric 32 bit italian localization. Some functions are in english and other in italian, in the help they are all in italian and "Use english function names" is unchecked

Changed in libreoffice (Ubuntu Precise):
importance: Medium → High
Changed in libreoffice (Ubuntu Oneiric):
importance: Medium → High
Francesco G. (francygazz) wrote :

I too confirm in ubuntu, Oneiric 64 bit italian localization. Some functions are in english and other in italian, in the help they are all in italian and "Use english function names" is unchecked

Fixed in 3.5.0-beta2-2ubuntu3 for good with the removal of a split -l10n source package.

Not reproducable in 1:3.4.5-0ubuntu1~ppa1 uploaded to https://launchpad.net/~libreoffice/+archive/ppa/ .

libreoffice 1:3.4.5-0ubuntu1~ppa1 will be uploaded identically (modulo ubuntu version change) to oneiric-proposed, when the build finishes, it clearly needs checking again.

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu Oneiric):
status: Triaged → Fix Committed
Changed in libreoffice (Ubuntu Precise):
milestone: none → precise-alpha-2
Jens Grüntjes (jenzuslongus) wrote :

Thanks Björn, 3.4.5 works for me in Oneiric.
I made a quick test with german function names.

Changed in libreoffice (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.