LibreOffice should depend on libreoffice-gtk

Bug #841696 reported by Colin Norris on 2011-09-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

I'm using Xubuntu Oneiric amd64 Beta1. I installed LibreOffice Writer via the Ubuntu Software Centre, but when I launched it, the DPI was wrong and it looked ugly. I then closed it and installed libreoffice-gtk via Synaptic and that fixed it. Surely that should happen automatically to prevent users seeing an ugly UI.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice-core 1:3.4.2-2ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Mon Sep 5 11:07:14 2011
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Colin Norris (sirrontm) wrote :
summary: - LibreOffice Writer should depend on libreoffice-gtk on Xubuntu
+ LibreOffice should depend on libreoffice-gtk
Sérgio Faria (sergio91pt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

A bit of context:
Currently libreoffice suggests libreoffice-gnome | libreoffice-kde and libreoffice-gnome depends on libreoffice-gtk. libreoffice-kde provides qt widgets and therefor doesn't depend on libreoffice-gtk.

I agree that the gtk/qt gui should be automatically installed but according to http://www.debian.org/doc/FAQ/ch-pkg_basics.en.html#s-depends, libreoffice-gnome | libreoffice-kde | libreoffice-gtk doesn't qualify as a dependency but it might as a recommendation..

Does the software-center install recommendations by default? How are the packages for the "extra" section chosen?

Sérgio Faria (sergio91pt) wrote :

Actually its called Addons not extra section, my bad

Colin Norris (sirrontm) wrote :

Cheers, I don't know much about debian packages and that link helped.

A list of "Add-ons" is displayed on the LibreOffice Writer page in the Ubuntu Software Centre, but libreoffice-gtk isn't actually visible in that list.

I believe it should be automatically installed somehow, because even if it was in that list, it isn't a good user experience when you put the Ubuntu Software Centre into the context of an "App Store", and I would consider integration into the user's desktop environment as a basic feature, not an optional extra. All software should respect the user's DPI and colour settings for example as it could adversely affect the software's accessibility for people with sight problems.

Can the Ubuntu Software Centre itself decide which desktop integration package to install depending on the desktop environments that the user has installed?

Or could libreoffice-gnome, libreoffice-kde and libreoffice-gtk all be rolled into one package (depended on by the base LibreOffice package) that does not itself depend on all three desktops being installed (to prevent KDE being installed in my case), and then find out which one to use at runtime?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

@Pitti: Should we make the libreoffice metapackage depend on libreoffice-gtk?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

You can make libreoffice Recommends: -gnome | kde, or just -gtk | -kde if you want a lighter weight default. Depends is definitively too strong, though.

I think it's a good enough compromise. kubuntu-desktop depends on libreoffice-kde, so only the GTK-based derivatives like Xubuntu do not install LibO by default.

Changed in libreoffice (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed

Hello Colin, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers