LibreOffice ignores default email client

Bug #841184 reported by komputes on 2011-09-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

LibreOffice has many email features in File > Send. However LibreOffice ignores that I have a default email client (Thunderbird). When I try to send a document as an email I get the following error:

LibreOffice 3.4
LibreOffice was unable to find a working e-mail configuration. Please save this document locally instead and attach it from within your email client.

LibreOffice lacks integration into the Ubuntu desktop. Ideally using this feature would check the default email application (System > Settings > System > Info > Default Applications) and use the preferred email client to send an email with the attachment.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sun Sep 4 12:55:24 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to oneiric on 2011-08-27 (7 days ago)

komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) on 2011-09-04
tags: added: ugjqc-11.09
Eric Beaurivage (sipherdee) wrote :

I am using KDE (4.7.0 - Oneiric Ocelot) and KMail is opened by default. I haven't customized anything, the operating system was installed yesterday so this seem to be a Unity problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Alexandr (olexandr-dmitriev) wrote :

Hi,
I'm running thunderbird 7 from ppa on Natty and I have the same problem!

When I try to send an email from libreoffice evolution is opened despite the fact that I have thunderbird as my default email application.

Alexandr (olexandr-dmitriev) wrote :

The quick workaround to open in libreoffice Tools -> Options -> Internet -> E-Mail and to inpute there 'thunderbird' (without quotes)

karatedog (karatedog) wrote :

The email client is set to 'sensible-ooomua' in LibreOffice however there is no such utility installed, only sensible-editor, sensible-pager and sensible-browser (as of Ubuntu 11.04). Nevertheless this magic word will start Evolution. But if I change this to 'sensible-ooomuB', then it will fail.

JrZabott (jrzabott) wrote :

That on was easy.... just write manually, "thunderbird" without the quotes. Worked for me...

hugs.

Hein (hhanssen) wrote :

The same problem applies to me. After upgrading to Oneiric Libroffice still wants to send emails via Evolution and is not starting the standard email client: Thunderbird. I'm now looking how to manually adjust this. But in Libreoffice it doesn't look very straightforward: any one that has done this with success? I hate to tinker with my system a lot more: I already had to make some adjustments.

Apart from that, after upgrading my (evolution) contacts have been migrated to Thunderbird, but emails and the link to google calendar has not been migrated to Thunderbird, nor has any calendar related data.

I would have expected that migration to another mail client have been tested a lot better.

Hein (hhanssen) wrote :

I just added thunderbird as suggested here. Works as a charme, but is not really what you'd like when upgrading that you'll have to adjust all kind of settings by hand.

Erdal Ronahi (erdalronahi) wrote :

To write thunderbird there does not change anything in Lucid. Still evolution comes up every time

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Mantas Kriaučiūnas (mantas) wrote :

Is this bug fixed in Ubuntu Lucid and Natty versions of LibreOffice backports from this PPA: https://launchpad.net/~libreoffice/+archive ?

Joseph Naz (naz-joseph-canuel) wrote :

Really helpful. Just write "thurderbird" without quotes. i'm running ubuntu 12.04 LTS

Grant Ingram (g-l-ingram) wrote :

Just to note that I have 12.04 with all patches installed and the File->Send behaviour does not pick up the default e-mail client. Having "sensible-lomua" in Options -> Internet -> E-mail still picks up Evolution putting "thunderbird" in picks up Thunderbird quite nicely.

Voidcode (terkelsorensen) wrote :

This bug still ship with Ubuntu 13.10
To fix this goto:

1)
Liberoffice->Tools->Options->Internet->E-mail:

2)
Then changed.
sensible-lomua
To.
thunderbird

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers