Libre Office Presenter console doesn't display controls

Bug #824466 reported by iGadget on 2011-08-11
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

On Natty (tried both my updated x64 install and a fresh 32 bit live system), with both the stock Libre Office and version 3.3.3, the Presenter Console only displays the presentation on the secondary screen, but doesn't show the presentation controls on the primary. Instead, the regular LO Impress interface is shown on the primary screen.

I've checked the presentation settings and these settings are correct (the presentation is diplayed properly on the secondary display when having LO on the primary display).

Please see the attached screenshots to get an idea of the problem.

What I expected to happen:
-Get the presentation on the secondary display and the presentation controls on the primary display

What happens instead:
-The presentation displays on the secondary screen, but no controls appear on the primary display. Instead, the plain LO Impress interface is shown. The typical Presenter keyboard shortcuts seam to work, except for ALT-1, ALT-2 and ALT-3.

This problem does not occur in LO downloaded from libreoffice.org .

iGadget (igadget) wrote :

Example of the presenter console controls

iGadget (igadget) wrote :

Just installed LO 3.4.2 following the instructions on this page:

http://www.libre-software.net/how-to-install-libreoffice-on-ubuntu-linux-mint

Now the presenter console controls work fine. So it's definitely a bug in the packages which are in the repo.

iGadget (igadget) wrote :

This bug is still present in Ubuntu 11.10. And the situation has gotten worse because of bug #883478 (although that bug doesn't seem to be happening every time) .

It doesn't make a difference if the libreoffice-presenter-console package is installed or not, the result is the same.

Paál, Balázs (paalb) wrote :

This bug occurs on my system as well (Oneiric). I installed several extensions at the same time from Synaptic.
Neither presenter console, nor menubar integration worked.

After a system restart, things got worse. Seemed like menubar integration started to do something finally. It removed the menubar from the application window. But there was no menu integration on the top menu bar (still showing the generic desktop menu).
This meant that libreoffice was practically unusable - no menu anywhere.

I removed lo-menubar from Synaptic. After a restart, bingo! Presenter console started to function normally.

List of packages installed:

libcommons-logging-java (1.1.1-8)
libhsqldb-java (1.8.0.10-9ubuntu1)
libjaxp1.3-java (1.3.05-1ubuntu1)
libreoffice-base (1:3.4.3-3ubuntu2)
libreoffice-java-common (1:3.4.3-3ubuntu2)
libreoffice-ogltrans (1:3.4.3-3ubuntu2)
libreoffice-pdfimport (1.0.5+LibO3.4.3-3ubuntu2)
libreoffice-presenter-console (1.1.0+LibO3.4.3-3ubuntu2)
libreoffice-report-builder (1:1.2.1+LibO3.4.3-3ubuntu2)
libreoffice-report-builder-bin (1:3.4.3-3ubuntu2)
libreoffice-style-crystal (1:3.4.3-3ubuntu2)
libreoffice-style-galaxy (1:3.4.3-3ubuntu2)
libreoffice-style-hicontrast (1:3.4.3-3ubuntu2)
libreoffice-style-oxygen (1:3.4.3-3ubuntu2)
libreoffice-style-tango (1:3.4.3-3ubuntu2)
libservlet2.5-java (6.0.32-5ubuntu1)
libxerces2-java (2.9.1-4.1ubuntu3)
lo-menubar (0.1.0-0ubuntu3)

iGadget (igadget) wrote :

@ Paál - I don't have lo-menubar installed and I never have.
I just tested the latest 3.4.4 release from the ppa:libreoffice/ppa and this bug is still present there as well. So I guess I'll be downloading the packages myself again from the LO website... *sigh*

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.04
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
iGadget (igadget) wrote :

I think I might have discovered the 'guilty' packages causing the controls of the Presenter Console not being displayed.
At first, I was shocked to learn that even when I installed the 3.4.4 packages from LO's website on Ubuntu 11.10, the issue still remained.
I then started looking (with the help of Synaptic) for any remaining packages which had any reference to libreoffice and which were coming from the Ubuntu repo's.

Turns out that even while I expected to be rid of all LO packages when removing any package starting with 'libreoffice', there are still other packages which don't have 'libreoffice' in their name, but still influence the behaviour of LO (luckily this is mentioned in their description). The suspect here is the "Libreoffice UNO runtime environment". Removing all packages related to this environment and then re-installing the packages from the LO site fixed the problem!

The packages provided on the LO website ship with their own version of the UNO runtime environment (exact package name is libreoffice3.4-ure).
Without having any extensive knowledge on packaging it's kind of weird to be suggesting this, but perhaps there should be some kind of 'conflicts' dependency (?) added to either of these packages, so Ubuntu's version of the UNO environment automatically gets removed when libreoffice3.4-ure is installed?

Jeremy Bicha (jbicha) wrote :

Yesterday, I installed the presenter extension and experienced this bug where the non-presentation monitor wouldn't show the nice presentation controls. The bug persisted even after I completely close libreoffice. Today, after a reboot, I was quite surprised that it worked just fine and I didn't apply any system upgrades between yesterday's and today's testing.

Personally, I'm on precise so that was with version 1:3.4.4-0ubuntu1 and Unity.

Joseph (josephl) wrote :

I have the same problem... just thought I would let you know... I was glad to find that I was not the only one with this issue...

iGadget (igadget) wrote :

I can hardly believe it, but this issue is STILL present in 12.04 beta. What on earth must I do to get this bug to be fixed before 12.04 becomes final?

Mozaic (mozaic) wrote :

In libreOffice 3.5 features, we can read:
"Presenter Console now features a "Exchange Screen Images" button to work around the bug that in some cases the projector/presentation screen was picked for the Presenter Console instead of the speaker's laptop screen. (Michael Meeks, Astron). " http://www.libreoffice.org/download/3-5-new-features-and-fixes/
I think it could help to change easly the display.
For me the problem get around.

Currently cant reproduce, as lacking a working dual-head setup on precise.

Changed in libreoffice (Ubuntu):
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
milestone: ubuntu-12.04 → none
iGadget (igadget) wrote :

What. The. F***. You don't have a second monitor lying around so this bug is postponed yet again?!!

My dear Björn - if you mail me your address, I will personally send you my spare monitor.
For me that is a small price to pay when compared to having to face YET ANOTHER release (an LTS for crying out loud!) with this bug present.

I'm serious. Please let me help you fix this. Please?

iGadget (igadget) wrote :

@ Mozaic - yes, this button is really useful... IF the Presenter Console would work. But that's the whole point - it doesn't! See #1 and #2.

papukaija (papukaija) on 2012-04-05
tags: added: natty oneiric precise
tags: added: usability

Matthijs ten Kate, your welcome to file this upstream following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Jeremy Bicha (jbicha) wrote :

I can't reproduce this either, except that I have needed to reboot after installing the presenter extension.

Have those of you experiencing this bug reproduced this bug from a clean Precise install, not an upgrade? Comment #8 is suspicious in that it was an older install where someone tried installing LibreOffice in a non-supported way.

iGadget (igadget) wrote :

@ Christopher - that's no use since the bug is only present in the Ubuntu packages, not in upstream. I already indicated this in #3, #6 and #8.

@ Jeremy - why would you need to install any extension? The presenter console is has been integrated in LO since at least version 3.4.
And yes, I have tried a clean install. This makes no difference. Just try and boot a live 12.04 beta2, connect a secondary display, start LO Impress, change the presentation settings so the presentation is displayed on the secondary display and hit F5.
No way you will see the Presenter Console controls on your primary display. Instead, you will see what I posted in #1.

And as for comment #8, that 'someone' would be me. Why is what I'm describing there suspicious? I was simply trying to debug the problem. And to me, it's been pretty obvious for quite some time:
- Upstream LO is working perfectly (at least for this issue)
- Ubuntu LO is not, and hasn't been for the past 3 releases. Something is going wrong in our packaging and I suspect it has something to do with the UNO runtime environment, is indicated in #8.

What else can I do to help solve this bug?

Changed in df-libreoffice:
status: New → Invalid
iGadget (igadget) on 2012-04-05
tags: added: needs-reassignment packaging
description: updated
tags: removed: needs-reassignment
Jeremy Bicha (jbicha) wrote :

libreoffice-presenter-console is not installed by default. Install it, then reboot.

I believe it ought to be installed by default as it seems like a core feature of a presentation app to me (& to the LibreOffice developers) but see bug 798299.

"Suspicious" was a bad word choice. I'm just trying to help triage the bug and part of triaging is trying to figure out how to reliably reproduce the bug.

iGadget (igadget) wrote :

Jeremy, do you mean to say that we actually _remove_ it from LO and then package it? Because the presenter console has been an integral part of LO since several versions. Why on earth would we do such a thing?

And what is the name of the package to be installed? I've been searching in SC on a 12.04 beta2 live environment and was not able to find anything.

papukaija (papukaija) wrote :

I can't reproduce this bug in Precise. The presenter console was shown on the secondary screen but that's a different bug. I tested this with a Compaq MV740 VGA monitor.

@Matthijs: Yes, Ubuntu's LO extensions are packaged separately. I don't know the reason for this though it saves CD space (but I know that the extensions could be installed with proper dependencies). The package to be installed is libreoffice-presenter-console.

Jeremy Bicha (jbicha) wrote :

Matthjis, the presenter console is an extension and not part of core LibreOffice. The extension is bundled with the release though since LibreOffice split off OpenOffice.

As it's pretty small and a great value-add, I'd love to see it installed by default.

iGadget (igadget) wrote :

Just confirmed that it's working on 12.04 after manually installing libreoffice-presenter-console.
So I've marked this bug a dup of bug 798299.

Boy-oh-boy if only I had known about that bug earlier...

papukaija (papukaija) wrote :

Unduplicating and marking as fixed since the original reporter and I can confirm that this bug is fixed in Precise.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
Tomasz (dextras) wrote :

I would not say it was fixed in Precise. The problem is still present at least in my case. What is interesting I solved it! Those are the steps that i followed:
1. install libreoffie-presenter-console (lo-menubar already installed)
(started the presentation and the presenter console does NOT work)
2. Uninstall lo-menubar
(started the presentation and the presenter console WORKS!)
3. install lo-menubar
(started the presentation and the presenter console still works!).
4. logged out and in and the presenter console still works.

I believe it has something to do with lo-menubar package.

iGadget (igadget) wrote :

@ Tomasz - Interesting. I have not installed lo-menubar nor the package libreoffice-presenter-console. However, I HAVE installed the metapackage libreoffice and (although I am starting to get doubts now as I am writing this) I believe the presenter console is actually working...

At any rate, I have never had lo-menubar installed when I was able to get the presenter console working, so you might have a point.
I will check tomorrow if what I mentioned above is actually true.

Paál, Balázs (paalb) wrote :

In my case the problem was definitely connected with lo-menubar. See my comment #5.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers