Ubuntu

soffice.bin crashed with SIGSEGV in XkbUseExtension()

Reported by Yaron on 2011-07-31
68
This bug affects 7 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Björn Michaelsen
Precise
Medium
Unassigned

Bug Description

Using Ubuntu 11.04 Live CD

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sun Jul 31 07:11:34 2011
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin -writer -splash-pipe=5
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x836855d <XkbUseExtension+29>: mov 0x530(%esi),%eax
 PC (0x0836855d) ok
 source "0x530(%esi)" (0x00000530) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 XkbUseExtension () from /usr/lib/i386-linux-gnu/libX11.so.6
 XkbQueryExtension () from /usr/lib/i386-linux-gnu/libX11.so.6
 SalDisplay::GetKeyboardName(bool) () from /usr/lib/libreoffice/basis3.3/program/libvclplug_genli.so
 ?? () from /usr/lib/libreoffice/basis3.3/program/libvclplug_gtkli.so
 g_cclosure_marshal_VOID__VOID () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: soffice.bin crashed with SIGSEGV in XkbUseExtension()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Yaron (sh-yaron) wrote :
visibility: private → public

StacktraceTop:
 XkbUseExtension (dpy=0x0, major_rtrn=0xbfb47e80, minor_rtrn=0xbfb47e7c) at ../../../src/xkb/XKBUse.c:633
 XkbQueryExtension (dpy=0x0, opcodeReturn=0xbfb47e8c, eventBaseReturn=0xbfb47e88, errorBaseReturn=0xbfb47e84, majorReturn=0xbfb47e80, minorReturn=0xbfb47e7c) at ../../../src/xkb/XKB.c:46
 GetKeyboardName () from /usr/lib/libreoffice/basis3.3/program/libvclplug_genli.so
 signalKeysChanged () from /usr/lib/libreoffice/basis3.3/program/libvclplug_gtkli.so
 g_cclosure_marshal_VOID__VOID (closure=0x8605b48, return_value=0x0, n_param_values=1, param_values=0x85a7538, invocation_hint=0xbfb48000, marshal_data=0x0) at /build/buildd/glib2.0-2.28.6/./gobject/gmarshal.c:79

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Fixed upstream by removal of the problematic code for LibreOffice 3.6:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=04b9c2f633f0be1b676933943bdd0b1dc58b5471

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

Hello Yaron, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libreoffice (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Yaron (sh-yaron) wrote :

I threw that old PC away and it doesn't happen on my new PC so I guess we can never actually verify that...

tags: added: verification-done
removed: verification-needed
Changed in libreoffice (Ubuntu Precise):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers