Wizard doesn't run without libreoffice-java-common installed. The user should be notified to install it when running a wizard.

Bug #780399 reported by KevinM on 2011-05-10
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

Binary package hint: libreoffice

With LibreOffice Writer open I select File-Wizards-Letter and nothing seems to happen. It's the same for letters and agendas.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice-core 1:3.3.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue May 10 10:05:47 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110415)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

KevinM (kevbert1) wrote :

Do you have all libreoffice-packages installed (including libreoffice-java-common)?

Changed in libreoffice (Ubuntu):
status: New → Incomplete

#2 worked for me. Thanks!

So why isn't the java package installed by default? I think libreoffice should at least tell the user to install it if they want the wizards (and other functions?) to work.

KevinM, marking back to New as you answered Björn Michaelsen's question. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
summary: - Wizards not working in Writer
+ Wizard doesn't run without libreoffice-java-common installed. The user
+ should be notified to install it when running a wizard.
Changed in libreoffice (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → Medium
Lokard (darkdadaah) wrote :

This is still a bug in Precise. Installing the libreoffice-java-common solves the issue, but nobody would know this.

There should either be no option for wizards that can't work, or the package should be installed by default, but right know it is just wrong.

Neal McBurnett (nealmcb) wrote :

As I noted in bug 926594, for Precise, installing libreoffice-java-common did not solve the issue for me - it was already installed. Installing libreoffice-base did solve the problem.

For background and implications of not installing Java with LibreOffice, see also this blueprint proposed for the 12.10 Ubuntu release (Quantal):

 LibreOffice package split collateral damage analysis : Blueprints : Ubuntu
 https://blueprints.launchpad.net/ubuntu/+spec/desktop-q-libreoffice-split

and this work proposed for the summer of 2011:

LibreOffice Wizards: Java to Python conversion : Blueprints : Ubuntu
 https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-libreoffice-python-wizards

dierre (fdr) wrote :

Using Ubuntu 12.04 and the bug is present. Installing libreoffice-java-common solves it, but the user can't be expected to know it.

What about File-Wizards-Letter showing a dialog that explains what needs to be installed? Right not it is silently failing, which is very bad IMHO.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: Triaged → In Progress

Mostly solved in libreoffice4: Wizards either do not depend on Java anymore or pop up a info window asking to install Java.

The exception is the webwizard: It still does neither without Java.

In Ubuntu 12.10 with LibreOffice 3.6.2.2 even the installation of libreoffice-java-common doesn't solve the issue as far as I'm concerned.

Graeme Hewson (ghewson) wrote :

In Kubuntu 12.10, the letter wizard doesn't work, with no indication of why not, until libreoffice-java-common is installed. I agree with earlier comments: tell the user to install the package, or (better) install it by default. The lack of feedback to the user without the package installed is very poor.

tags: added: quantal

In LibreOffice 4beta2/raring: Letter, Fax, Presentation, Document Conversion, Euro Conversion just work.
Agenda, Webpage still need a session installer.

Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package libreoffice - 1:4.0.1-0ubuntu1

---------------
libreoffice (1:4.0.1-0ubuntu1) raring; urgency=low

  [ Bjoern Michaelsen ]
  * new upstream release
    - fixes CRASH in action after Undo (LP: #785518)
    - fixes fontconfig warning (LP: #1034928)
    - fixes desktop file translations (LP: #1131470)
  * add transitionals for -presenter-console and -binfilter
  * add sessioninstaller for remaining wizards (LP: #780399)
  * merge from debian at 1:4.0.1~rc1-2
  * remaining delta on debian/control:
    - drop ${java-common-depends} from Recommends to Suggests on
      libreoffice-help-*
    - add libreoffice-gnome | libreoffice-kde Recommends on libreoffice
    - add libreoffice-style-human Suggests to libreoffice-common
    - add libreoffice-common self Conflicts with << 3.5.0
    - drop java-common-depends and java-runtime-depends from Recommends to
      Suggests on libreoffice-writer
    - add libreoffice-pdfimport Recommends on libreoffice-draw
    - drop libreoffice-core from Depends to Recommends on libreoffice-style-*
    - add libreoffice-style-human
    - add C/P/R against lo-menubar from libreoffice-gtk
    - alternatively Recommends libreoffice-style-human from libreoffice-gtk3
    - add C/R against libreoffice-core (<< 1:3.9999) from libreoffice-gnome
    - add Conflicts against libreoffice-common (<< 1:3.5.0) from python3-uno
    - add libreoffice-subsequentcheckbase
    - add libreoffice-presenter-console transitional
  * remaining delta on debian/patches:
    - add Ubuntu brand palette
    - add session-installer for Java Wizards
  * remaining delta on rules:
    - fix configure switch for human theme
    - use internal jfreereport because of huge component mismatch otherwise
    - white progressbar instead of Debian Purple (or Ubuntu orange)
    - adjust bug reporting destination for ppa builds
    - disable tests on armel, armhf, powerpc
    - enable parallel build and mergelibs
    - disable evolution
    - use internal liblangtag for now
    - disable help building on armel/armhf
    - Ubuntu backport fixes
    - reduced l10n for ppa builds
    - alternatively allow firefox-dev to xulrunner-dev as build-dep
    - warn early on GVFS and GIO in same build
    - generate transitionals
    - generate subsequentcheckbase
    - fix missing closing para wrt slide remote
    - move sessioninstaller from -gtk to -gnome for gio deps
    - move subsequentcheckbase jars to package
    - use --with-all-tarballs in addition to our flags for getting the source
      - this is so that ./configure doesnt stumble over other checks
        (e.g. still needing gnomevfs)
  * removed delta:
    - drop libreoffice-filter-mobiledev and ttf-sil-gentium-basic from Depends
      to Suggests on libreoffice
    - remove libreoffice-core postinst
    - fixed gnu make version
    - remove hotfixes get-orig-sources hack
    - some whitespace
  * silent some lintian noise for unversioned breaks:
    - promote Breaks to Conflicts against -binfilter as it will never return
    - promote Breaks to Conflicts from langpacks against en-US
    - remove Breaks against -style-industrial which is long gone
  * libreoffice-core already ...

Read more...

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
ObrienDave (truckinpapa) wrote :

Letter wizard not working.
I get following error;

The wizard could not be run, because important files were not found.
Under 'Tools - Options - LibreOffice - Paths' click the 'Default' button to reset the paths to the original default settings.
Then run the wizard again.

Applying said fix and/or restarting Libreoffice, does not work.

Thanks,
David B

Libreoffice 4.0.3.3
Xubuntu 13.04

ObrienDave (truckinpapa) wrote :

Please ignore above comment.
This problem has been resolved by disabling the following OpenOffice extension.

DSFJ SozaiOOo 1.0

My apologies,
David B

ObrienDave, thank you for your comments. As this report has been marked Fixed Released, in order to have your issue addressed, please file a new report via the terminal:
ubuntu-bug libreoffice

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers