Ubuntu

[Upstream] Font "Nimbus Sans L" squashed in Impress slideshow

Reported by Rebecca Palmer on 2011-05-08
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libreoffice

Text in some fonts, including Nimbus Sans L, Century Schoolbook L, Courier 10 Pitch and URW Palladio L, appears squashed in slideshow mode.

1) lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.4.3-3ubuntu2
  Candidate: 1:3.4.3-3ubuntu2
  Version table:
 *** 1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/779366/+attachment/2119346/+files/fontbug.odp && loimpress --nologo fontbug.odp

is the text with Nimbus Sans L font looks in edit view as it does in slide show.

4) What happens instead is the font shows differently in slide show https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/779366/+attachment/2119348/+files/fontbug_slideshow.png versus edit mode https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/779366/+attachment/2119347/+files/fontbug_editview.png

WORKAROUND: Uncheck Hardware Acceleration (Tools > Options > LibreOffice > View)

Also observed in amd64 11.04 and amd64 12.04 (LibreOffice); not present in amd64 10.10 (OpenOffice).

Rebecca Palmer (rebecca-palmer) wrote :
  • fontbug.odp Edit (13.4 KiB, application/vnd.oasis.opendocument.presentation)
Rebecca Palmer (rebecca-palmer) wrote :
Rebecca Palmer (rebecca-palmer) wrote :

Rebecca Palmer, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [impress][regression] Font "Nimbus Sans L" squashed in slideshow
+ Font "Nimbus Sans L" squashed in Impress slideshow
Changed in df-libreoffice:
status: New → Incomplete

I have a related problem with Nimbus Sans L after switching to Oneiric. This font appears in condensed mode both in the edit and slideshow modes (in this bug report, this problem is reported only in slideshow mode).

If you face this too, here is a workaround that I applied to make the edit mode work again...

1/ Look for the font files for "Nimbus Sans L Condensed"

grep "Nimbus Sans" /usr/share/fonts/type1/gsfonts/*.afm | grep Condensed/usr/share/fonts/type1/gsfonts/n019043l.afm:FullName Nimbus Sans L Regular Condensed
/usr/share/fonts/type1/gsfonts/n019044l.afm:FullName Nimbus Sans L Bold Condensed
/usr/share/fonts/type1/gsfonts/n019063l.afm:FullName Nimbus Sans L Regular Condensed Italic
/usr/share/fonts/type1/gsfonts/n019064l.afm:FullName Nimbus Sans L Bold Condensed Italic

2/ Remove the corresponding files:
rm /usr/share/fonts/type1/gsfonts/n0190{43,44,63,64}l.*

Again, this just fixes edit mode, not slideshow mode, which is still broken (probably becahse of the LibreOffice bug reported here)

In my case, this is sufficient, because I export my documents to PDF, and I don't observe any problem viewing the PDF files then.

To revert your changes:
sudo apt-get install --reinstall gsfonts

Hope this helps. Don't hesitate to let me know if you wish me to file a separate bug.

Michael Opdenacker

Hello!
  I've noticed that some fonts (e.g. "URW Palladio L", "Bitstream Charter", "Century Schoolbook L", "Utopia", "URW Bookman L" and maybe some others) look stretched vertically in Slide Show mode.
  In editing mode as well as in the exported PDF file everything is fine.

  This Launchpad bug seems to describe the similar issue: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/779366

  Regards,
    Vladimir

Bálint Aradi (baradi09) wrote :

It seems as if in the presentation modus the condensed letters are used, but with a spacing as big as for the normal font. For whichever reasons. Similar to Michael, the characters are already looking wrong in Edit mode (they are condensed).

Possible workaround is to change the font in your documents from Nimbus Sans to Liberation Sans. Depending on your documents, you must change the Default style (Graphics Styles) as well as the various Outline styles (Presentation Styles).
After the change my presentations looked exactly as before, in Edit mode as well as in Presentation mode.

Probably Nimbus Sans (former default font for OpenOffice) was silently replaced with Liberation Sans in previous versions of Ubuntu with OpenOffice, but that's only speculation... It is nevertheless very annoying, when your carefully designed presentations do not look as before.

Hope this helps,

  Bálint

It's also possible to substitute a font by another in all your documents at once, by going through Tools->Options->LibreOffice->Fonts

I discovered this nice option while investigating this issue.

Michael.

This bug is still present for LibreOffice 3.5.0beta2

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
summary: - Font "Nimbus Sans L" squashed in Impress slideshow
+ [Upstream] Font "Nimbus Sans L" squashed in Impress slideshow
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

I've seen the same behavior in 3.4.4 for Ubuntu Oneiric.

Cristián Rojas (mechonbarsa) wrote :

I've seen the same behavior in 3.4.4 using Courier 10 Pitch.

I got a similar issue with Writer and thanks to the Michael Opdenacker directions I fixed it, however I deleted all the Nimbus fonts and then rebuilt the font cache, after that I reinstalled finally the fonts the same way Mr. Opdenacker suggested and the strange font behavior stopped.

So far my variations to said commands. The numbers 03, 04, 23 and 24 correspond to the other Nimbus fonts present on my system:
rm /usr/share/fonts/type1/gsfonts/n0190{03,04,23,24,43,44,63,64}l.*
sudo dpkg-reconfigure fontconfig
apt-get install --reinstall gsfonts

I don't know if this is relevant to this bug, but I post it hoping it can help to fix the situation. Thanks to Michael Opdenacker for the solution!

Version 3.4.5 for Ubuntu Oneiric (PPA repository) still shows the same behavior.

Same bug on LibreOffice 3.5.0rc3 for Mac OS 10.6.8

Can you confirm that turning off use-hardware-acceleration fixes this ? :-)
Sample document cf. bug#46901 shows this clearly:
https://bugs.freedesktop.org/attachment.cgi?id=57920>

It is caused by the cairo canvas: in a nutshell :-) should be Linux only in 3.5.2. Thanks for the nice clean report.

(In reply to comment #4)
> Same bug on LibreOffice 3.5.0rc3 for Mac OS 10.6.8

@gka: Which fonts did you use for this test on MacOS?

I want to test if this bug is still present with LibreOffice 3.5.2.x, but because the bug seems to depend on the fonts used, I'd like to test with the same fonts you used for your test.

(BTW: I wanted to give it a try with Utopia (PostScript Type 1 from Adobe) or Bitstream Charter (PostScript Type 1), but both fonts don't even show up in the font menus of LibreOffice -- like all old-styled PostScript Type 1 / Mac fonts they are just ignored by LibreOffice -- but this is a different problem; the point is just that I can't use these fonts for testing and don't know which fonts I should test.)

@<email address hidden> vladimir,

(In reply to comment #5)
> Can you confirm that turning off use-hardware-acceleration fixes this ? :-)
> Sample document cf. bug#46901 shows this clearly:
> https://bugs.freedesktop.org/attachment.cgi?id=57920>
>
> It is caused by the cairo canvas: in a nutshell :-) should be Linux only in
> 3.5.2. Thanks for the nice clean report.

Can you please look at it? Thanks,

Cor Nouws/Michael Meeks, unchecking Use hardware acceleration does prevent the problem.

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Status -> NEW

  Hello!
(In reply to comment #7)
> @<email address hidden> vladimir,
>
> (In reply to comment #5)
> > Can you confirm that turning off use-hardware-acceleration fixes this ? :-)
> > Sample document cf. bug#46901 shows this clearly:
> > https://bugs.freedesktop.org/attachment.cgi?id=57920>
> >
> > It is caused by the cairo canvas: in a nutshell :-) should be Linux only in
> > 3.5.2. Thanks for the nice clean report.
>
> Can you please look at it? Thanks,
  Yes, I have just tried it with
    LibreOffice 3.5.2.2
    ID сборки: 350m1(Build:202)
and it turned out that turning off the hardware acceleration does indeed "fixes" the problem. The fonts look normally without acceleration.

tags: added: amd64 i386 natty oneiric
description: updated
Marcus Dapp (digisus) wrote :

Just to confirm that switching off "hardware acceleration" in LibreOffice does fix the problem (even without leaving LO).

Thanks to everybody for the clean reporting and workaround.

Description: Ubuntu 12.04 LTS
Release: 12.04

LibreOffice 3.5.2.2
Build ID: 350m1(Build:202)

This one might be a DUP of "Bug 47673 SLIDESHOW: Particular fonts like "Century Schoolbook L" too narrow with hardware acceleration" (might still happen)
or
"Bug 46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated - cairo canvas used in error on windows" (should be fixed in between)

We still do not really know what is happening here and what the roots might be, so NEEDINFO again due to <https://wiki.documentfoundation.org/BugTriage#Process> item 5

@<email address hidden>:
Can you decide whether this one is a DUP of one of the above ones or something different?

(In reply to comment #10)
>
> @<email address hidden>:
> Can you decide whether this one is a DUP of one of the above ones or
> something different?
This bug is definitely about the same problem as the Bug 47673
I also checked the "hardware acceleration" option, and yes, everything is fine with this option turned off.
My current LO version is 3.6.2.2

Changed in df-libreoffice:
status: Confirmed → Incomplete

Still present in Ubuntu 12.04 (LibreOffice 3.5.4.2 Build ID: 350m1(Build:2)), and agreed that it appears to be a duplicate of freedesktop-bugs 47673 (also affects the fonts Century Schoolbook L, URW Palladio L and Courier 10 Pitch, and only appears with hardware acceleration on).

description: updated
tags: added: precise
summary: - [Upstream] Font "Nimbus Sans L" squashed in Impress slideshow
+ [Upstream] Some fonts squashed in Impress slideshow

Rebecca Palmer, let us preserve the bug title so that the specific font that this bug is dealing with is targeted by a developer, and to ease QA/triager efforts.

Thank you for your understanding.

summary: - [Upstream] Some fonts squashed in Impress slideshow
+ [Upstream] Font "Nimbus Sans L" squashed in Impress slideshow

*** This bug has been marked as a duplicate of bug 47673 ***

Changed in df-libreoffice:
status: Incomplete → Invalid

fix released with 3.6/quantal.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.