LibreOffice - missing packages for ARMEL

Bug #770627 reported by Ricardo Salveti on 2011-04-26
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Canonical ARM Developers
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Packages libreoffice-base-core, libreoffice-base, libreoffice-ogltrans, libreoffice-report-builder-bin, libreoffice-sdbc-postgresql, libreoffice-mysql-connector and libreoffice-evolution are all including ARMHF, but not ARMEL.

As a consequence all these packages are not available for ARM, also breaking the installation of openoffice-base, that depends on libreoffice-base.

Ubuntu: 11.04 Natty
Libreoffice: 3.3.2-1ubuntu4

Ricardo Salveti (rsalveti) wrote :

This debdiff includes armel into every package, but not yet sure if the build will work or not, also sending to a PPA to test.

Once the build is done will report the result.

tags: added: patch

The control file for Libreoffice is generated by debian/rules, so the patch is not usable as is unfortunately.
Also the missing armel keyword is not by accident:

 http://git.debian.org/?p=pkg-openoffice/libreoffice.git;a=commit;h=60f4380b
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=585829

and the changelog entry for the 3.2.1-2 release. Closing as invalid for now, please reopen, if the root problem is solved.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Ricardo Salveti (rsalveti) wrote :

Once the build is finished will try running the test cases again to see if I can still reproduce the issues. It's just weird that the support for armhf is there, probably just never tested properly.

If we should still keep it disabled we should also disable openoffice-base as it's asking for libreoffice-base.

Oliver Grawert (ogra) on 2011-04-27
Changed in ubuntu-release-notes:
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Changed in libreoffice (Debian):
status: Unknown → Fix Released
Steve Langasek (vorlon) wrote :

This is still an issue in precise, so seems it ought to go to the release notes.

Changed in ubuntu-release-notes:
importance: Undecided → Medium
status: New → Triaged
Adam Conrad (adconrad) wrote :

Upgrades deal with this fine (by removing the old packages), and they never worked right in the first place, so I see no point in release noting that we're removing packages that no one could have previously successfully used anyway. As such, I'm marking the release-notes task invalid, but leaving the bug open for later investigation/porting/whatever.

Changed in ubuntu-release-notes:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.