Calc Sheet Tabs and Buttons too small (control buttons corrupted)

Bug #769086 reported by Scott Palmer on 2011-04-22
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: libreoffice-calc

When using the Ambiance theme, the LibreOffice Calc sheet tabs are too small and the sheet control buttons are not displayed correctly (corrupted).

As a temporary solution use the Appearance program and switch your Theme from Ambiance to Clearlooks. This will make the sheet tabs and control buttons larger and the sheet controls are displayed correctly.
---
ApportVersion: 1.23-0ubuntu4
Architecture: i386
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Package: libreoffice 1:3.4.4-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Tags: oneiric running-unity
Uname: Linux 3.0.0-14-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Scott Palmer (skewty) on 2011-04-22
description: updated
description: updated
description: updated

In addition to the tabs being too small the edges of the tabs don't display correctly, it looks similar to the problem with the sheet control buttons.

The sheet tabs are small if you're using the Radiance theme, sheet control buttons are OK.
The Hanso theme yields the same results as Ambiance.

No way to edit comments? bah.

In addition to the tabs being too small the edges of the tabs don't display correctly, it looks similar to the problem with the sheet control buttons.

The sheet tabs are small if you're using the Radiance theme, sheet control buttons are small but otherwise OK.
The Hanso, Impression and Night-Impress themes yields the same results as Ambiance

Changed in libreoffice (Ubuntu):
status: New → Confirmed
matyy (matthias-mendler) wrote :

Another temporary solution, that I am using is to start libreoffice with

GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc libreoffice

Of course you can use any other theme you'd like to use.

nocrack (board-divers) wrote :

And here is a screenshot of what it does... quite unusable :(

nocrack (board-divers) wrote :

changing the theme to clearlooks unfortunately doesn't help for me as per the screenshot.

It's quite a shame to see that the bug has been open since April last year and no one has even reviewed the bug to decide if it's severity... let alone to assign someone...

skewty, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 769086
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected oneiric running-unity
description: updated

This bug is still marked as incomplete. Is there something else I must do?

skewty, marking back to Confirmed based on your apport. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status .

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
Thomas (sedevelopers01) wrote :

Any progress on this?

Calorus (calorus) wrote :

So ... any progress?

zxczc (astiktrumpam) wrote :

Nope, its still a very big problem in all linux distributions and all themes, or in other words, you still can put that open-source back to open-ass. I have no idea how anyone can use such a mess, its impossible to push those 1x1 pixel size buttons or read text ...

matyy (matthias-mendler) wrote :

This bug also exists in 14.04 - it's not incredibly small but quite small in Ambiance. Somehow this shouldn't depend on the theme, should it? Or some minimum size restriction...

atom32k (atomekk) wrote :

Same problem here Ubuntu 14.04. 3 yrs and still not solved. If every app would depend on theme style so heavy it will be a mess to have it all in line. Its just a tabs ! barely visible...

Adolfo Jayme (fitojb) wrote :

This problem was fixed upstream. The fix will be available in Ubuntu when we update the libreoffice package to the 4.4 series. See https://wiki.documentfoundation.org/ReleaseNotes/4.4#Tab_changes

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Triaged
importance: Undecided → Low
madbiologist (me-again) wrote :

Libreoffice 4.4 is now available in the Ubuntu 15.04 "Vivid Vervet" repositories.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers