Ubuntu

soffice.bin crashed with SIGSEGV in g_hash_table_lookup() (Libreoffice with lo-menubar crash from page preview)

Reported by Alexander Kallenbach on 2011-04-08
978
This bug affects 164 people
Affects Status Importance Assigned to Milestone
LibreOffice Menubar Extension
Undecided
Unassigned
LibreOffice Productivity Suite
Invalid
Medium
libreoffice (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
lo-menubar (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Libreoffice Writer crashed after I've activated the page view.

This only happens when lo-menubar package is installed.

[Test Case]
Open a document in a fresh instance of lowriter and click on the "Page preview" button on the toolbar and verify lowriter doesn't crash.

[Regression potential]
The bulk of the changes in this update is from when it was merged into libreoffice upstream they did some refactoring work. Upstream for lo-menubar attempted to backport just enough to fix this bug and gave up because the diff would end up being just as big as the changes we got from libreoffice and too much work to make it worth the effort. Our best hope of getting a fix for this in 12.04 is to take the new upstream version. It has been in quantal for nearly two months now and it clearly fixes this bug and we haven't seen new bugs introduced.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Apr 8 14:02:25 2011
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin -writer /home/username/Desktop/Protokoll\ FK\ Geschichte.odt -splash-pipe=5
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.utf8
 SHELL=/bin/bash
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 g_hash_table_lookup () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libreoffice/program/../share/extensions/menubar/Linux_x86/menubar.uno.so
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
Title: soffice.bin crashed with SIGSEGV in g_hash_table_lookup()
UpgradeStatus: Upgraded to natty on 2011-04-07 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public

StacktraceTop:
 g_hash_table_lookup_node (hash_table=0xb3654000, key=0x93dada8) at /build/buildd/glib2.0-2.28.5/./glib/ghash.c:313
 g_hash_table_lookup (hash_table=0xb3654000, key=0x93dada8) at /build/buildd/glib2.0-2.28.5/./glib/ghash.c:902
 MenuItemStatusListener::statusChanged (this=0x928d070, Event=...) at ../src/MenuItemStatusListener.cxx:28
 StateChanged () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
 SetState_Impl () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

MenuItemStatusListener never unregisters as a listener of the dispatches, even when itself or the FrameHelper containing the command url hash table die. This needs to be fixed.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

Seems to be connected to lo-menubar. When I uninstall lo-menubar page-view works. If it is installed Libreoffice crashes every time I want to activate page-view.

Yes, thats in lo-menubar.

Ok, also pushed to https://code.launchpad.net/~lo-menubar-team/lo-menubar/trunk
I would propose to make that a 0.1.1 release and a SRU.
@Ken VanDine: Your opinion about that?

Changed in lo-menubar:
status: New → In Progress
assignee: nobody → Ken VanDine (ken-vandine)

I just uploaded prerelease that should fix this to https://launchpad.net/~libreoffice/+archive/ppa as lo-menubar_0.1.1~pre1-0ubuntu1.

Martin Pitt (pitti) wrote :

From oneiric onwards the code lives in libreoffice. Keeping natty task for lo-menubar package.

Changed in lo-menubar (Ubuntu):
status: New → Invalid
Changed in libreoffice (Ubuntu Natty):
status: New → Invalid
Changed in lo-menubar (Ubuntu Natty):
status: New → Fix Committed
Andrey (aol-nnov) wrote :

Hi all!

i've stumbled upon this bug recently, and fix from Björn Michaelsen's ppa works fine except the following scenario:

1) open writer, see that menu is displayed globally (not in the writer window)
2) push 'page preview' button (on the tool bar!)
3) exit page preview mode
4) global menu disappeared and went back to the writer window

the weird thing is that if you choose file->page preview from the menu first time, then menu stays global despite of what have been selected for the page preview action next time - the toolbar button or the menu item.

Andrey

Created attachment 47334
gdb log

How to reproduce?
1. Open some document in Writer
2. Click File | Page Preview...

Now LibreOffice segfault.

Unfortunately, I can not test it on LibreOffice 3.4 rc2, because it doesn't start nor from debs, nor from dev-install.

OS: Ubuntu 11.04

I've attach gdb log

Hi Alexander, i tested your scenario with several files and, so far, I cannot confirm the crash/segfault.

Would it be possible to attach the document which causes the segfault? Thanks

System: Ubuntu 10.10, gnome 2, German UI, Intel 32-bit
LibreOffice: 3.3.2 PPA and 3.4rc2

(In reply to comment #1)
> Hi Alexander, i tested your scenario with several files and, so far, I cannot
> confirm the crash/segfault.
>
> Would it be possible to attach the document which causes the segfault? Thanks
>
> System: Ubuntu 10.10, gnome 2, German UI, Intel 32-bit
> LibreOffice: 3.3.2 PPA and 3.4rc2

Hi,

it happens with any files that I opened, even with the new one.

I tested it with a clean profile, but it still falls.

As I can see from gdb log it failed in menubar.uno.so. I have got installed lo-menubar for the global menu. When I remove this package LibreOffice start work ok.

I think this happens becouse I have got this extension, but have not got global menu. I play with global menu in unity some times ago. Now I switched to the ubuntu classic desktop, but forget remove extension. Nevertheless, LibreOffice shouldn't failed. ;)

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 39228 has been marked as a duplicate of this bug. ***

Nicolas Diogo (nicolasdiogo) wrote :

problem persists on Natty amd64 using repository 'natty-proposed'

any suggestions on how to fix this problem?

This is also present in Oneiric (see bug 847013)

papukaija (papukaija) on 2011-09-11
tags: added: oneiric

Reopening because it still appears in certain scenarios.

Changed in libreoffice (Ubuntu):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
tags: added: lo-menubar-p-default

*** Bug 37726 has been marked as a duplicate of this bug. ***

Changed in lo-menubar:
assignee: Ken VanDine (ken-vandine) → nobody
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
Mark Alan (malan) wrote :
Download full text (3.4 KiB)

Starting with a freshly installed and perfectly working libreoffice,
by just copying a few templates (.ott & .otg) into the template dir ~/.config/.libreoffice/3/user/template/
starts the dysfunctional behavior of libreoffice crashing with every click on the "Page Preview" button.

To restore normality it is enough to remove the ~/.config/.libreoffice directory and restart libreoffice.
  rm -fr ~/.config/.libreoffice

The above proposed package https://launchpad.net/~libreoffice/+archive/ppa does not install in Ubuntu 11.10

M.

Sysinfo:

cat /etc/issue
   Ubuntu 11.10 \n \l

dpkg -l | grep 'libreoffice\|lo-menubar'
   ii libreoffice 1:3.4.3-3ubuntu2 office productivity suite
ii libreoffice-base 1:3.4.3-3ubuntu2 office productivity suite -- database
ii libreoffice-base-core 1:3.4.3-3ubuntu2 office productivity suite -- shared library
ii libreoffice-calc 1:3.4.3-3ubuntu2 office productivity suite -- spreadsheet
ii libreoffice-common 1:3.4.3-3ubuntu2 office productivity suite -- arch-independent files
ii libreoffice-core 1:3.4.3-3ubuntu2 office productivity suite -- arch-dependent files
ii libreoffice-draw 1:3.4.3-3ubuntu2 office productivity suite -- drawing
ii libreoffice-emailmerge 1:3.4.3-3ubuntu2 office productivity suite -- email mail merge
ii libreoffice-filter-mobiledev 1:3.4.3-3ubuntu2 office productivity suite -- mobile devices filters
ii libreoffice-gtk 1:3.4.3-3ubuntu2 office productivity suite -- GTK+ integration
ii libreoffice-help-pt 1:3.4.3-1ubuntu1 office productivity suite -- Portuguese help
ii libreoffice-impress 1:3.4.3-3ubuntu2 office productivity suite -- presentation
ii libreoffice-java-common 1:3.4.3-3ubuntu2 office productivity suite -- arch-independent Java support files
ii libreoffice-l10n-common 1:3.4.3-1ubuntu1 common files for LibreOffice language and help packages
ii libreoffice-l10n-pt 1:3.4.3-1ubuntu1 office productivity suite -- Portuguese language package
ii libreoffice-l10n-pt-br 1:3.4.3-1ubuntu1 office productivity suite -- Portuguese_brazilian language package
ii libreoffice-math 1:3.4.3-3ubuntu2 office productivity suite -- equation editor
ii libreoffice-report-builder-bin 1:3.4.3-3ubuntu2 LibreOffice extension for building database reports -- libraries
ii libreoffice-style-human 1:3.4.3-3ubuntu2 office productivity suite -- Crystal symbol s...

Read more...

The PPA doesn't work here as well. Maybe missing dependencies might be the cause.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

I've tested this with LO 3.5 beta3 and it works for me. I mean that there is no bug, it works as should be.

> I've tested this with LO 3.5 beta3 and it works for me. I mean that there is no
> bug, it works as should be.
I change status to WorksForME
Please, if problem appears again, change status to Reopened

Changed in df-libreoffice:
status: Incomplete → Invalid

This is aldo present on precise.

Changed in lo-menubar:
status: In Progress → New
status: New → In Progress
Tayroni Alves (tayroni-alves) wrote :

This is also present on precise.

Changed in libreoffice (Ubuntu):
status: Triaged → Invalid
Changed in lo-menubar (Ubuntu):
status: Invalid → Triaged
tags: added: metabug precise
Tayroni Alves (tayroni-alves) wrote :

Relevant line on /var/log/syslog

Apr 5 23:08:28 copernico kernel: [44910.183082] soffice.bin[29235]: segfault at c0000029 ip 00007f0d743417f7 sp 00007fffab016730 error 4 in menubar.uno.so[7f0d74335000+16000]

lorenzo11 (coutey-lorenzo) wrote :

I've got also the same problem on precise.

No freeze if preview was run from the menu "file --> preview" but freeze if run from the icon preview.

Bug #970261 has been marked as a duplicate. Alberto Ruiz has been assigned to this bug for lo-menubar in that bug report, so could someone update this bug report with his name?

Should we change the title to make it easier to find and prevent people from reporting it again in a different bug report?

I was saying in the duplicate that two related bugs are:
- Bug #969136 : "lo-menubar should be pulled in by ubuntu-desktop to better integrate LibreOffice with Unity"
- Bug #957847 : "HUD does not work with LibreOffice"

This bug is a big concern for Ubuntu users as LibreOffice is one of the main apps, and it is not integrated well at all, which makes the whole operating system look inconsistent. As this is a serious bug, lo-menubar is not integrated by default, and it means that there is no global menu for it, and therefore the HUD doesn't work, when LO would be one of the main reason people would use HUD because of the high number of actions available in this software.
This problem adds to the fact that there is no overlay scrollbars either for LO (Bug #847918 ?).

Hopefully this can be fixed, tested and added to 12.04 as soon as possible to make a real mature LTS.

Cheers and thanks for everybody's work :)

description: updated
papukaija (papukaija) on 2012-05-04
description: updated
papukaija (papukaija) on 2012-05-04
summary: - soffice.bin crashed with SIGSEGV in g_hash_table_lookup()
+ soffice.bin crashed with SIGSEGV in g_hash_table_lookup() (crash from
+ page preview)
Linux Lover (obake) wrote :

I changed the tittle to make it easier to find this bug report, and prevent more duplicates.

summary: - soffice.bin crashed with SIGSEGV in g_hash_table_lookup() (crash from
- page preview)
+ soffice.bin crashed with SIGSEGV in g_hash_table_lookup() (Libreoffice
+ with lo-menubar crash from page preview)
Matthijs ten Kate (igadget) wrote :

+1 @ Stéphane / #32. What is keeping these bugs from being fixed? Or are people already working on them but we simply don't know yet? What can I / we do to help?

Marking Medium as this is a bug that has a severe impact on a non-core application (lo-menubar).

Changed in lo-menubar (Ubuntu):
importance: Undecided → Medium
Changed in lo-menubar (Ubuntu Natty):
importance: Undecided → Medium
Changed in libreoffice (Ubuntu):
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
importance: Medium → Undecided
no longer affects: libreoffice (Ubuntu Natty)
Rafael P. (rafael-p) wrote :

The bug not only happens in LibreOffice Writer as the title suggests but also in Calc.

Changed in lo-menubar (Ubuntu):
status: Triaged → Fix Released
Ken VanDine (ken-vandine) wrote :

The fix has been uploaded to precise-proposed and is still pending approval by the SRU team. Once let it into precise-proposed, to verify the fix start lowriter and click on page preview and verify it doesn't crash. The menu will appear inside the window again instead of the global appmenu, but it will no longer crash libreoffice.

Note to the SRU team, this is a bug with many duplicates affecting quite a few people. I uploaded a new upstream release that includes the fix along with some refactoring since the version that is currently in precise. Upstream attempted to backport just this fix, but it would have been a significant effort and a pretty big diff, our best hope for a fix is to just take the 0.1.1 release.

Changed in libreoffice (Ubuntu Precise):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lo-menubar (Ubuntu Precise):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Given that this is a new upstream release surely there are other changes being made. Would it be possible to document those so we know what else we are getting with this SRU?

papukaija (papukaija) wrote :

The bug 919659 is about getting LO 3.5.4 SRUed to Precise and its comment 92 has a list of all the changes in that release: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/919659/comments/92

Wasn't Brian's question about the the LO-menubar changelog, rather than the last LO version's?

description: updated

Hello Alexander, or anyone else affected,

Accepted lo-menubar into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lo-menubar (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

I've accepted this into precise-proposed; this seems to be a high-impact bug.

Although it's justifiable, the changes are quite invasive, so I'd like this to bake a bit longer than usual in -proposed before being released to -updates.

Mozaic (mozaic) wrote :

I install lo-menubar 0.1.1-0ubuntu0.1 on Ubuntu precise and page preview don't crash LibreOffice, now.

But, lo-menubar lost this first feature: give menubar on all the top (in same clock's plan). Now, i don't see difference between libreoffice with lo-menubar or not

Download full text (3.4 KiB)

When the preview pane is open the menu bar integration is lost until
lo-writer is restarted, atleast it doesn't crash.
2012/6/19 Mozaic <email address hidden>:
> I install lo-menubar 0.1.1-0ubuntu0.1 on Ubuntu precise and page preview
> don't crash LibreOffice, now.
>
> But, lo-menubar lost this first feature: give menubar on all the top (in
> same clock's plan). Now, i don't see difference between libreoffice with
> lo-menubar or not
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (862642).
> https://bugs.launchpad.net/bugs/754562
>
> Title:
>  soffice.bin crashed with SIGSEGV in g_hash_table_lookup() (Libreoffice
>  with lo-menubar crash from page preview)
>
> Status in LibreOffice Productivity Suite:
>  Invalid
> Status in LibreOffice Menubar:
>  In Progress
> Status in “libreoffice” package in Ubuntu:
>  Invalid
> Status in “lo-menubar” package in Ubuntu:
>  Fix Released
> Status in “lo-menubar” source package in Natty:
>  Fix Committed
> Status in “libreoffice” source package in Precise:
>  Invalid
> Status in “lo-menubar” source package in Precise:
>  Fix Committed
>
> Bug description:
>  Binary package hint: libreoffice
>
>  Libreoffice Writer crashed after I've activated the page view.
>
>  This only happens when lo-menubar package is installed.
>
>  [Test Case]
>  Open a document in a fresh instance of lowriter and click on the "Page preview" button on the toolbar and verify lowriter doesn't crash.
>
>  [Regression potential]
>  The bulk of the changes in this update is from when it was merged into libreoffice upstream they did some refactoring work.  Upstream for lo-menubar attempted to backport just enough to fix this bug and gave up because the diff would end up being just as big as the changes we got from libreoffice and too much work to make it worth the effort.  Our best hope of getting a fix for this in 12.04 is to take the new upstream version.  It has been in quantal for nearly two months now and it clearly fixes this bug and we haven't seen new bugs introduced.
>
>  ProblemType: Crash
>  DistroRelease: Ubuntu 11.04
>  Package: libreoffice-core 1:3.3.2-1ubuntu2
>  ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic i686
>  Architecture: i386
>  Date: Fri Apr  8 14:02:25 2011
>  ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
>  InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
>  ProcCmdline: /usr/lib/libreoffice/program/soffice.bin -writer /home/username/Desktop/Protokoll\ FK\ Geschichte.odt -splash-pipe=5
>  ProcEnviron:
>   LANGUAGE=de_DE:en
>   LANG=de_DE.utf8
>   SHELL=/bin/bash
>  Signal: 11
>  SourcePackage: libreoffice
>  StacktraceTop:
>   g_hash_table_lookup () from /lib/i386-linux-gnu/libglib-2.0.so.0
>   ?? () from /usr/lib/libreoffice/program/../share/extensions/menubar/Linux_x86/menubar.uno.so
>   ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
>   ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
>   ?? () from /usr/lib/libreoffice/program/../basis-link/program/libsfxli.so
>  Title: soffice.bin crashed with SIGSEGV in g_hash_table_looku...

Read more...

Miklos Juhasz (mjuhasz) wrote :

@Mozaic, @Sérgio: The menu with the page preview is expected to appear inside the window instead of the global appmenu. See comment #38

Mozaic (mozaic) wrote :

Sorry, my explication is light. I give you a picture.

The general appararence of LibreOffice is the same with or no with lo-menubar:
With the 0.1.0-0ubuntu4, the menu and the clock are on the same line (red line in my picture). But without lo-menubar or with 0.1.1 they aren't in the same line.

I think it's the feature of lo-menubar: have the menu and the clok in the same line and give space of screen for the work.

Whoopie (whoopie79) wrote :

I also see the issue that lo-menubar 0.1.1 doesn't work as expected. The libreoffice menubar is not in the global menu bar.

Miklos Juhasz (mjuhasz) wrote :

I see that libreoffice 3.5.4-0ubuntu1 is still waiting for approval in the proposed queue. I wonder if the new lo-menubar version needs the updated libreoffice as well.

Miklos Juhasz (mjuhasz) wrote :

The proposed package works fine for me.

I opened a document in a fresh instance of lowriter and clicked on the "Page preview" button on the toolbar: lowriter did not crash.
The menu is in the global appmenu so there's no regression for me. As soon as I click the "Page preview" button the menu moves into the application window which is expected.
The menubar works well with loimpress and localc as well, no regression spotted.

Steve Langasek (vorlon) on 2012-07-03
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lo-menubar - 0.1.1-0ubuntu0.1

---------------
lo-menubar (0.1.1-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream release.
    - Fix for crash on page preview (LP: #754562)
  * debian/control
    - Added build dep for libboost1.46-dev
 -- Ken VanDine <email address hidden> Tue, 12 Jun 2012 00:26:08 -0400

Changed in lo-menubar (Ubuntu Precise):
status: Fix Committed → Fix Released
Mozaic (mozaic) wrote :

Sorry don't work for me in LibreOffice 3.5.3.2 or 3.5.4.2
Like i say in comment #49, preview don't crash with lo-menubar/libreoffice but, lo-menubar is not in the global menu bar

It's why i am in virtual box with Ubuntu 2D ??

Whoopie (whoopie79) wrote :

Ok, after some tests, the version 0.1.1-0ubuntu0.1 doesn't work for me in any environment, neither Unity, nor Unity2D or Gnome Classic.

mohican (mohican) wrote :

Same for me libreoffice 3.5.3, Ubuntu 12.04 64bits with Unity :
after update of lo-menubar the menu of libreoffice does not integrate anymore into the global menu, which is what lo-menubar is supposed to do !

Detlef Kuonen (detlef-kuonen) wrote :

Same here! There are no more crashes, but the menu is no longer integrated in the global menu...

lo-menubar is not working at the actual state!

SilverLoz (launchpad-loznet) wrote :

@Mozaic, @mohican, @Detlef, I had the same problem after the update. However, after uninstalling and then reinstalling lo-menubar from the software centre eveything now works properly. The menu is integrated back into the global menu and page preview doesn't cause a crash. It might be worth you trying this too.

Scott Kitterman (kitterman) wrote :

See Bug #1021946 for verirication failure.

tags: added: verification-failed
removed: verification-done
Adam Conrad (adconrad) wrote :

Bouncing this out of -updates and back to -proposed for now.

Changed in lo-menubar (Ubuntu Precise):
status: Fix Released → Fix Committed
Micah Gersten (micahg) wrote :

Bug #1021946 was reported after this was moved to precise-updates, so it was decided to move this SRU back to precise-proposed for the time being. As there is no SRU master bug, I've marked this bug as verification-failed to prevent migration to -updates. It appears from the comments here that this issue isn't fully fixed either.

Mozaic (mozaic) wrote :

@ SilverLoz: You are right. \o/
After uninstalling and then reinstalling lo-menubar from the software centre, come back global menu and preview don't crash in my desktop.

When i open LO the menu is integrated in the global menu, but during the preview it comes back to its usual place (where it would be without lo-menubar) and doesn't go back to the global menu when i go back to document processing.

Brian Murray (brian-murray) wrote :

Another potential regression may be found in bug 1022379.

Coeur Noir (gerald-maruccia-e) wrote :

Same here, no more crashes but once preview button has been used, lo-menubar does no longer work.

Ubuntu 12.04 - unity 3D - amd 64 - LO 3.5.4.2 - lo-menubar 0.1.1-ubuntu0.1

Coeur Noir (gerald-maruccia-e) wrote :

Can't I edit my message ?

In addition : in the top panel appear desktop menus instead of LO menus.

http://forum.ubuntu-fr.org/viewtopic.php?pid=10122061#p10122061 [french]

Aritchie (aritchie) wrote :

Ubuntu 12.04 32-bit
Unity-3d
libreoffice 3.5.4.2
lo-menubar 0.1.1-ubuntu0.1

The only time is crashes is if I use the print preview in the toolbar first. I noticed the menu bar for the print preview window does not integrate with the global menu.
If I first go to Fle -> Print Preview, everythng works just fine and no problems. I did not uninstall it since it is not a big deal for me to first use if from the menu. The toolbar print preview button works just fine and so does the global menu if I use the menu item first.

Jimmy Merrild Krag (beruic) wrote :

I second that for 3.5.6.2 on 64 bit, except it also crashes when going through the file menu.

lo-menubar 0.1.1-ubuntu0.1 is working fine with LibreOffice 3.6.0.1 (Build ID: 360m1(Build:101) from the LibreOffice Prereleases PPA, as is HUD. It also doesn't seem to crash on print preview.

Changed in lo-menubar:
status: In Progress → Won't Fix
Changed in lo-menubar (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in lo-menubar (Ubuntu Natty):
status: Fix Committed → Won't Fix
Michael Zaugg (AOI) (it-oas) wrote :

Precise, LO LibreOffice 3.5.4.2, Build-ID: 350m1(Build:2)

I had to delete '.config/libreoffice/3/user/extensions' after updating to proposed lo-menubar (0.1.1-0ubuntu0.1).
Otherwise the menu was not integraded into panel and LO-Menus where not available via HUD.

Skini151 (skini151) wrote :

Install lo-menubar package walk through the test case and try to break things but fix works fine, i think there is need to move this package from "-proposed" to "-updates".
Tested on LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)
Here is machine specs: https://launchpad.net/~skini151/+hwdb-submissions

Amr Ibrahim (amribrahim1987) wrote :

This bug is not Fix Released, lo-menubar 0.1.1 is still in -proposed.

Is it going to be moved to -updates?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.