LibreOffice needs an update of the Ubuntu color palette

Bug #753627 reported by Björn Michaelsen
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Fix Released
Undecided
Paul Sladen
libreoffice (Ubuntu)
Fix Released
Wishlist
Björn Michaelsen
Precise
Fix Released
Wishlist
Björn Michaelsen

Bug Description

Binary package hint: libreoffice

"Ubuntu orange" #ff6309
"Ubuntu yellow" #ffb515"
"Ubuntu red" "#c90016"
The brand identity has changed in the meantime.
A proposal would be:

"Ubuntu orange " #DD4814
"Ubuntu light aubergine" #77216F
"Ubuntu mid aubergine" #5E2750
"Ubuntu dark aubergine" #2C001E
"Ubuntu warm grey" #AEA79F
"Ubuntu cool grey" #333333
"Ubuntu text grey" #333333

from http://design.canonical.com/brand/5.%20Ubuntu%20colour%20palettes%20and%20colour%20landscape.pdf

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

@Paul Sladen: Please advice or confirm on the colors and names.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

@Paul Sladen: ping?

John Lea (johnlea)
Changed in ayatana-design:
assignee: nobody → Paul Sladen (sladen)
status: New → Confirmed
Revision history for this message
Paul Sladen (sladen) wrote :

Yikes, good catch there Björn!

I would drop the "Ubuntu Text Grey" and capitalise the rest + lowercasing the hex numbers:

  "White" #ffffff
  "Ubuntu Orange " #dd4814
  "Ubuntu Warm Grey" #aea79f
  "Ubuntu Cool Grey" #333333
  "Ubuntu Light Aubergine" #77216f
  "Ubuntu Mid Aubergine" #5e2750
  "Ubuntu Dark Aubergine" #2c001e
  "Canonical Aubergine" #772953
  "Black" #000000

All present and correct, yes.

Changed in ayatana-design:
status: Confirmed → Fix Committed
Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
milestone: none → ubuntu-12.04
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
milestone: ubuntu-12.04 → precise-updates
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Björn, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Mozaic (mozaic) wrote :

Sorry, but i try find in draw and i see nothing with "Ubuntu Orange" or something similar in color box or in Menu -> tools -> LibreOffice -> Color.
May be it's my comprehension of this bug is not good (i am not an english speaker), have you a file's test or screencast to compare??

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

I've installed the proposed package and only found the old colors in Impress.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

If you have a user-layer (that is some changed settings), the defaults might be overwritten. Try with an new user or remove ~/.libreoffice and ~/.config/libreoffice.

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

removing those directories did help. The issue is solved.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Mozaic (mozaic) wrote :

After delete ~/.config/libreoffice I have the color

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Christian Giordano (nuthinking) wrote :

Can someone list the steps to test this?

John Lea (johnlea)
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments