Impress not the default app for ODP documents

Bug #752814 reported by Steve Magoun on 2011-04-06
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
desktop-file-utils (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned
libreoffice (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

Binary package hint: libreoffice

1) lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu12
  Candidate: 2.32.0-0ubuntu12
  Version table:
 *** 2.32.0-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

3) What is expected to happen in Ubuntu 11.04 is when one opens an .odp file via double clicking the icon or secondary clicking icon -> click first entry at the top, it opens it with LibreOffice Impress.

4) What happens instead is that either opens in Evince (Document Viewer).

WORKAROUND: Secondary click the icon -> Open With -> LibreOffice Impress.
WORKAROUND: Secondary click the icon ->click Open With -> Other Application -> highlight LibreOffice Impress -> check the Remember this application for "OpenDocument Presentation" files checkbox -> click Open button.
WORKAROUND: Open the file via the Terminal: loimpress -nologo example.odp

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Apr 6 14:43:29 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to natty on 2011-04-04 (2 days ago)

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Jack Deslippe (jdeslip) wrote :

It should also be mentioned that evince is completely incapable of displaying any .odp document I have tried to open. Impress should definitely be made default.

description: updated
tags: added: regression-release
tags: added: lo33

Steve Magoun, thank you for reporting this bug and helping make Ubuntu better. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

Here is a very quick fix i can propose:

In the file mimeapps.list located in the folder ~/.local/share/applications, add this four lines:

[Default Applications]
application/vnd.oasis.opendocument.presentation=libreoffice-impress.desktop

[Added Associations]
application/vnd.oasis.opendocument.presentation=libreoffice-impress.desktop;

Cheers,

Olivier

Fabián Rodríguez (magicfab) wrote :

BTW when LibreOffice is *not* installed evince is also the default app giving the impression LibreOffice produces invalid/unreadable documents.

David Burke (bufke) wrote :

This also happens with the LibreOffice PPA on 10.04 and 10.10. In

/usr/share/applications/defaults.list

Looks like everything is still set to openoffice, at least in 10.04 and LibreOffice is not anywhere here. Replacing openoffice with Libre fixes it. Maybe odt and ods are just getting lucky since there isn't anything else to open them. It's odd that evince is associated with odp at all since it can't actually open them.

quick fix:
sudo sed -i 's/openoffice\.org/libreoffice/g' /usr/share/applications/defaults.list

Marking as invalid in LibreOffice as the defaults are set in package desktop-file-utils. Should be updated desktop-file-utils at least for natty, as LibreOffice is the default there.

Changed in desktop-file-utils (Ubuntu):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: Triaged → Invalid
Changed in desktop-file-utils (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.18-0ubuntu3

---------------
desktop-file-utils (0.18-0ubuntu3) natty; urgency=low

  * debian/defaults.list: use libreoffice rather than openoffice (lp: #752814)
 -- Sebastien Bacher <email address hidden> Tue, 19 Apr 2011 11:46:11 +0200

Changed in desktop-file-utils (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: New → Fix Released

I'm out of the office until 1st August.

On 20 Apr 2011, at 10:40, Launchpad Bug Tracker <<email address hidden>
 > wrote:

> ** Branch linked: lp:ubuntu/desktop-file-utils
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/752814
>
> Title:
>  Impress not the default app for ODP documents
>
> Status in One Hundred Paper Cuts:
>  New
> Status in “desktop-file-utils” package in Ubuntu:
>  Fix Released
> Status in “libreoffice” package in Ubuntu:
>  Invalid
> Status in “desktop-file-utils” source package in Natty:
>  Fix Released
> Status in “libreoffice” source package in Natty:
>  Invalid
>
> Bug description:
>  Binary package hint: libreoffice
>
>  1) lsb_release -rd
>  Description:        Ubuntu Natty (development branch)
>  Release:        11.04
>
>  2) apt-cache policy libreoffice-impress
>  libreoffice-impress:
>    Installed: 1:3.3.2-1ubuntu2
>    Candidate: 1:3.3.2-1ubuntu2
>    Version table:
>   *** 1:3.3.2-1ubuntu2 0
>          500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386
> Packages 100
>  /var/lib/dpkg/status
>
>  apt-cache policy evince
>  evince:
>    Installed: 2.32.0-0ubuntu12
>    Candidate: 2.32.0-0ubuntu12
>    Version table:
>   *** 2.32.0-0ubuntu12 0
>          500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386
> Packages 100
>  /var/lib/dpkg/status
>
>  3) What is expected to happen in Ubuntu 11.04 is when one opens an
>  .odp file via double clicking the icon or secondary clicking icon ->
>  click first entry at the top, it opens it with LibreOffice Impress.
>
>  4) What happens instead is that either opens in Evince (Document
>  Viewer).
>
>  WORKAROUND: Secondary click the icon -> Open With -> LibreOffice
> Impress.
>  WORKAROUND: Secondary click the icon ->click  Open With -> Other
> Application -> highlight LibreOffice Impress -> check the Remember
> this application for "OpenDocument Presentation" files checkbox ->
> click Open button.
>  WORKAROUND: Open the file via the Terminal: loimpress -nologo
> example.odp
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: libreoffice (not installed)
>  ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  NonfreeKernelModules: nvidia
>  Architecture: amd64
>  Date: Wed Apr  6 14:43:29 2011
>  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64
> (20100901.1)
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   PATH=(custom, user)
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  SourcePackage: libreoffice
>  UpgradeStatus: Upgraded to natty on 2011-04-04 (2 days ago)

Gonzalo (gonzalo-poseidonlinux) wrote :

I tried with 10.04 and didn't work. And the package available for me is desktop-file-utils - 0.16-0ubuntu2 :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers