[Upstream] master text styles show up on actual slides

Bug #734726 reported by Alex Engelmann on 2011-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Debian)
Fix Released
Medium
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

Binary package hint: libreoffice

1)
Maverick:
Ubuntu 10.10 64 bit

Oneiric:
lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

2)
Maverick:
LibreOffice 3.3.0
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Oneiric:
apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.4.4-0ubuntu1
  Candidate: 1:3.4.4-0ubuntu1
  Version table:
 *** 1:3.4.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.4-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ oneiric/main i386 Packages
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/734726/+attachment/1908953/+files/Chemotherapeutics%20Ctips.pptx -O example.pptx && loimpress -nologo example.pptx

is the slides show up cleanly, without the Master Page styles text showing up.

4) What happens instead is the Master Page styles text shows up on slides (slide 3 screenshot https://launchpadlibrarian.net/66336499/impress.png ).

WORKAROUND: Manually delete the text from the slide.

Alex Engelmann, thank you for reporting this bug and helping make Ubuntu better. Could you please attach an Impress file that demonstrates this problem?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Alex Engelmann (alex-engelmann) wrote :

Certainly! Thanks for the fast reply! I've attached my classmates' presentation. It is their work, so use good judgment in how you use/distribute it.

By the way, I've had this happen with many but not all presentations.

Changed in libreoffice (Ubuntu):
status: Incomplete → New

Upstreaming from https://launchpad.net/bugs/734726

Example file attached.
Seen on pptx files produced in Powerpoint 2007
Text from master slide covers real slides
http://launchpadlibrarian.net/66336499/impress.png

Seems like a likely regression.

tags: added: lo33 maverick natty
Jack Leigh (leighman) wrote :

I can confirm this on 3.3.1 in Natty.
I've upstreamed the bug.
Do you know if this is a newly introduced regression since OpenOffice 3.2?

Changed in libreoffice (Ubuntu):
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Alex Engelmann (alex-engelmann) wrote :

No I remember seeing this bug in OpenOffice 3.2 and 3.3 as well, I just didn't submit it because I was under the impression that OpenOffice was barely being developed anymore.

I can confirm this bug manifests in the following configurations:

 * LibreOffice version 3.4.3 000340m1 (build:302) on Windows 7 SP1 64-bit.
 * LibreOffice version 3.4.3 OOO340m1 (Build:302) on Debian GNU/Linux 6.0.3 64-bit.

summary: - master text styles show up on actual slides
+ [Upstream] master text styles show up on actual slides
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium

As per downstream bug this was first seen in:

Ubuntu 10.10 64 bit
LibreOffice 3.3.0
OOO330m19 (Build:6)

Version -> 3.3.0

Also reproducible in Ubuntu 11.10 32-bit, 3.4.4.

lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.4.4-0ubuntu1
  Candidate: 1:3.4.4-0ubuntu1
  Version table:
 *** 1:3.4.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.4-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ oneiric/main i386 Packages
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Michael J Kaye, please do not toggle the version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version

Changed in libreoffice (Debian):
importance: Unknown → Medium
status: Unknown → Confirmed

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete
Changed in libreoffice (Debian):
status: Confirmed → Incomplete

I just tested this on the 3.5.0 beta2 and the bug is still present.

Problem reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Changed in df-libreoffice:
status: Incomplete → Confirmed
Changed in libreoffice (Debian):
status: Incomplete → Confirmed

I can confirm that this problem is reproducible in:

LOdev 3.5.0beta2
Build ID: c3bcb31-760cc4d-f39cf3d-1b2857e-60db978
Debian GNU/Linux 6.0.3 x64

(In reply to comment #3)
> ...Michael J Kaye, please do not toggle the version. For more on this please
> see:
> http://wiki.documentfoundation.org/BugReport_Details#Version

Very sorry about that. Thanks for the docs link.

Michael.

bash321 (bash321) wrote :

i'm not the only person who has decided that this was a problem from a class mates presentation... Can LibreOffice please fix this bug!!!!!
It's really important I have received power point slides for Ancient History from my teacher and they are 40mb! plus!!! i can't convert all of the pptx files as it takes to long with online converters and saving them in microsoft office 2010 on windows as odp is a complete disaster... I am using an unstable development version of libreoffice 3.6 LOdev 3.6.0alpha0+ e9d045f-f8506ca-8a74106-f0d66f on a mac and I even have libreoffice 3.5 on ubuntu. I am also going to report this bug to libreoffice mailing list... it is really important that it gets fixed because everything else in the pptx file works really except this annoying bug!!!! these powerpoints have more than 40 slides!!!!! can some help ressolve this issue???? instead of deleting the text one by one on all the slides... i tried saving these on mac office 2011, as a ppt file and it just crashed!!!1?
If a fix is released in a daily version unstable release of libreoffice on one of the mirrors even if its windows mac or linux.. i can access that version and save those slides as an odp so that it works really well with libreoffice 3.5.. on my ubuntu desktop as an odp file!!!
bash321

bash321 (bash321) wrote :

work around... deleted the bug and problem by deleting everything in master view in microsoft 2011 on mac.. I think the problem is when someone opens a presentation as ppt file say for microsoft 2003, and then they save it as microsoft 2010 format .pptx it then gets all jumbled up with libreoffice.... there should be an option (one button click) to delete all styles and charts and graphics and tittle and footer boxes in master view on libreoffice as well.. (delete the whole master slide!) so its a blank power point canvas in master view. just by deleting all the slides and ending up with the last one as a blank white canvas. ( I don't think you can do that in libreoffice for ALL the slides like you can in microsoft office. (even microsoft office can't do that very well what I just described :)
bash321

And still [Reproducible] with "LOdev 3.6.0alpha0+ English UI/Locale [Build ID: aa7e105-b2dd236-9eed775-d06f752-4dba2d1 (libreoffice-3-5-branch-point)]" {Win-x86@9-Voreppe Win32 pull time 2012-02-14 16:17:23}. OS: German WIN7 Home Premium (64bit)

OOo 3.1.1, 3.3, 3.4 do not show that problem

@Thorsten:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.

bash321 (bash321) wrote :

Do not understand how to fix bugs. As am not good at coding only good at identifying and solving without coding.
Bash321

Changed in libreoffice (Ubuntu):
status: Triaged → In Progress
bash321 (bash321) wrote :

But I found another work around also. In office 2011 for Mac of you select all of your slides by clicking on a slide and then using the keyboard shortcut (command a)that will select all the slides. If you click layout under the home button ribbon. And select blank. It changes the master slide layouts. That is what worked for me. Then you can open it as a pptx file in impress. Something isn't working to well with layouts in Libreoffice I suspect.
Bash321

bash321 (bash321) wrote :

I cannot assign myself as I cannot code.
Bash321

Spartan117 (ljeloudev), please do not toggle the Status. For more on this please see: https://wiki.ubuntu.com/Bugs/Status

Changed in libreoffice (Ubuntu):
status: In Progress → Triaged
bash321 (bash321) wrote :

thank you for changing status. i have also reported this bug to ask.libreoffice.org

Rodo, you worked in that area - can you have a look please?

i can attach it to a dropbox link that can be retrieved without signing in.

the blank slides which are blank etc slide 12 have txt in them, they are normal slides don' t worry about them. I just have to change font colour. the only problem is the master slide one.

im student who has received this presentation. I think they were old and converted automatically to pptx from an old office version. probably microsoft office 2003-2010. I cannot get ppt version.

just realized dropbox converted the file to suite there needs including changing fonts and stuff, the power point looks really good now.
but any way.

ill have to upload original file to ubuntu one.

(In reply to comment #18)
> i can attach it to a dropbox link that can be retrieved without signing in.
>
> the blank slides which are blank etc slide 12 have txt in them, they are normal
> slides don' t worry about them. I just have to change font colour. the only
> problem is the master slide one.
>
> im student who has received this presentation. I think they were old and
> converted automatically to pptx from an old office version. probably microsoft
> office 2003-2010. I cannot get ppt version.
>
> just realized dropbox converted the file to suite there needs including
> changing fonts and stuff, the power point looks really good now.
> but any way.
>
> ill have to upload original file to ubuntu one.

http://ubuntuone.com/6QKc2hbgMeVoeW5EvfRebj

(In reply to comment #19)
> (In reply to comment #18)
> > i can attach it to a dropbox link that can be retrieved without signing in.
> >
> > the blank slides which are blank etc slide 12 have txt in them, they are normal
> > slides don' t worry about them. I just have to change font colour. the only
> > problem is the master slide one.
> >
> > im student who has received this presentation. I think they were old and
> > converted automatically to pptx from an old office version. probably microsoft
> > office 2003-2010. I cannot get ppt version.
> >
> > just realized dropbox converted the file to suite there needs including
> > changing fonts and stuff, the power point looks really good now.
> > but any way.
> >
> > ill have to upload original file to ubuntu one.
>
> http://ubuntuone.com/6QKc2hbgMeVoeW5EvfRebj

25mb pptx file

*** Bug 46594 has been marked as a duplicate of this bug. ***

*** Bug 37311 has been marked as a duplicate of this bug. ***

Seems this is fixed with Muthu's http://cgit.freedesktop.org/libreoffice/core/commit/?id=90352e5f1e50291960c944f9a1f44ab3e91d6503

So, mark as FIXED, it will be (at least) available in LibreOffice 3.6.

Checked with daily build Win-x86@6-fast, pull time 2012-05-08 21.43.52, Build ID: 7f3f6e4, with the file in comment 1 and it doesn't have the text above the images.

Changed in df-libreoffice:
status: Confirmed → Fix Released
Changed in libreoffice (Debian):
status: Confirmed → Fix Released

Created attachment 61278
slide 2

Created attachment 61279
slide 7

REFERS TO ATTACHMENTS AS WELL.
this is a cross post from bug 46594
i have tested this problem in other os's but at the moment it is happening in
Windows 8 Consumer Preview 64 bit... libreoffice works very well even in windows 8.

LibreOffice version 3.6.0alpha0+ x86 fast (Build ID: 7f3f6e4)
9/5/12 8:30pm AEST Build that was time of download
Last Modified 09-May-2012 2:28

great to see a fix is happening, cannot believe it really...
Problem is still happening on some slides but not all.
such as the 1st slide of my presentation does not have this problem or the 7th slide which is attached, but then the second slide does (attached).

it is now only on slides 2,9,18 out of 30 slides in this presentation.

and it still occurs on some other presentations which are .pptx that I have but not on all the slides.

(In reply to comment #16)
> it is now only on slides 2,9,18 out of 30 slides in this presentation.

Could you please attach the pptx file here?

ljelly, this bug is VERIFIED FIXED for the attachment noted in https://bugs.freedesktop.org/show_bug.cgi?id=35372#c1 . If you are having a problem in LibreOffice, please file a new bug.

Thanks!

I can confirm fix with parallel installation of Master "LOdev 3.6.0alpha0+ – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7f3f6e4]" (tinderbox: Win-x86@6-fast, pull time 2012-05-08 21:43:52) for <https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/734726/+attachment/1908953/+files/Chemotherapeutics%20Ctips.pptx>

If there are problems left please open a new Bug report.

i have filed a new bug and i will post my attachment noted there.
it is bug 46594.
It has the same issues as this bug.
i'm sorry for this to be a problem.
i just thought that if i posted in this bug report as well, it might solve the problem for other pptx files as well, not just the one attached.

ljelly.
(In reply to comment #21)
> ljelly, this bug is VERIFIED FIXED for the attachment noted in
> https://bugs.freedesktop.org/show_bug.cgi?id=35372#c1 . If you are having a
> problem in LibreOffice, please file a new bug.
>
> Thanks!

Fixed upstream, should be released on Ubuntu with 3.6.x on quantal

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.10
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released

Fixed in Future Versions of LibreOffice

3.6.5 and 4.0+

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.