LibreOffice erases user settings, and block the use of interface styles...

Bug #731556 reported by jgratero on 2011-03-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
High
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Same thing as reported here:

https://bugs.freedesktop.org/show_bug.cgi?id=33915

In my case, not only user settings are overwritten and lost, but there is also an additional effect: LibreOffice disables the visual styles (Galaxy, Crystal, etc.), all but the default, Tango...

This is happening in both Ubuntu (10.04) and Xubuntu (10.04), different PC's... Installed LibreOffice via PPA...

Created attachment 42940
file that is overwritten by the bug

user settings and configurations as paths, menus, keyboard shortcuts, default font, document view, etc., stored in the ".libreoffice/3/user/registrymodifications.xcu" file all get lost after several restarts (usually about 4-5) and are reset to default (Times New Roman, minimized window, etc), thereby the file getting overwritten with the consequent loss of all settings.

Reproducible: always

LibreOffice 3.3.0
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

installed on Ubuntu Lucid, Kernel 2.6.32.28

Other users with the same problem, see:
http://ubuntuforums.org/showpost.php?p=10351798&postcount=44
http://listarchives.libreoffice.org/de/users/msg00331.html

workaround: make a backup of "registrymodifications.xcu" and copy at again to its location at ".libreoffice/3/user/"

Though, it is rather annoying and time-costly

NOT reproducible with "LibreOffice 3.3.0 RC4 - WIN7 Home Premium (64bit) German UI [OOO330m19 (build 6 / tag 3.3.0.4)]".

Seems to be Linux specific?

(In reply to comment #1)
> NOT reproducible with "LibreOffice 3.3.0 RC4 - WIN7 Home Premium (64bit)
> German UI [OOO330m19 (build 6 / tag 3.3.0.4)]".
>
> Seems to be Linux specific?

I think so, as the other two users run Linux too

Created attachment 43136
java error log, created when the LibreOffice settings are reset to their defaults

I can confirm this bug for

Kubuntu 10.10
LibreOffice 3.3.0
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Ubuntu package 1:3.3.0-1maverick1
(this is a ppa-Installation from https://launchpad.net/~libreoffice/+archive/ppa)

Unfortunately I am not able to reproduce the bug in a consistent manner, save it happens very often. The method described in comment #0 is not working on my systems. Nonetheless the symptoms I am experiencing are the same: All user preferences get lost.

Very often (but not always) the error occurs in conjunction with an java error. Java then creates the attached error log (see above).

Indeed, the problem seems to be much worse, as another user indicates, not only "/home/"username"/.libreoffice/3/user/registrymodifications.xcu" gets overwriten by accident but also "/home/"username"/.libreoffice/3/user/basic/script.xlc" and "dialog.xlc" thereby deleting all user configured data bases. Please see:

http://<email address hidden>/msg00361.html

(In reply to comment #4)
> I can confirm this bug for
>
> Kubuntu 10.10
> LibreOffice 3.3.0
> OOO330m19 (Build:6)
> tag libreoffice-3.3.0.4
> Ubuntu package 1:3.3.0-1maverick1
> (this is a ppa-Installation from
> https://launchpad.net/~libreoffice/+archive/ppa)
>
> Unfortunately I am not able to reproduce the bug in a consistent manner, save
> it happens very often. The method described in comment #0 is not working on my
> systems. Nonetheless the symptoms I am experiencing are the same: All user
> preferences get lost.
>
> Very often (but not always) the error occurs in conjunction with an java error.
> Java then creates the attached error log (see above).

Seems problem has been resolved on RC LibreOffice 3.3.1 OOO330m19 (Build:7)
tag libreoffice-3.3.1.1

Good news!

Please feel free to reopen this Bug if you find out that the problem reappears in the latest release of LibO.

The problems mentioned by the other user (configuration files being overwritten)perists: http://listarchives.libreoffice.org/de/users/msg00531.html

"/home/"username"/.libreoffice/3/user/basic/script.xlc and ...dialog.xlc"

problem with ".libreoffice/3/user/registrymodifications.xcu" occasionally reappears in LO 3.3.1

I also have to confirm the persistence of this bug. After several days working with 3.3.1, the Problem occurs - in my case - virtually everytime I close the last instance of LibreOffice.

Mostly in connection with a java error (see comment 3). (It might have something to do with it: LanguageTool 1.2 is installed.)

(In reply to comment #11)
> I also have to confirm the persistence of this bug. After several days working
> with 3.3.1, the Problem occurs - in my case - virtually everytime I close the
> last instance of LibreOffice.

I can confirm this, it even seems to happen more often than with the RC LibreOffice 3.3.1. :-(

more info on bug behavior:

1. bug will only occur with restart after closing the latest instance AND the Quickstart too.
2. When it occurs, program start is significantly slower than usual and splash screen does not appear.
3. Additionally, the user will not be asked to recover earlier documents either, whereas this will happen after restoring the registrymodifications.xcu file.

Created attachment 44010
java error log, created when the LibreOffice settings are reset to their defaults

ocurred with LibreOffice 3.3.1 OOO330m19 (Build:8)

Great catch in the comment #13. Is the problem 100% reproducible with that steps?

Could you please try to get strace log. I think that it would make sense to get both strace logs. One when you run libreoffice, enable quickstarter, quit LO and the quickstarter and the second when you start libreffice against and the setting is lost.

BTW: How do you quit the quickstarter? By "Disable Quickstarter" or by "Quit
     Quickstarter" or ?

Though I'm facing it, I am not able to describe steps to reproduce the bug in a consistent manner. Could one of you please give a detailed description on how to reproduce it? Even after playing around for a while, I could not figure it out.

In my case it only happens after working for some time with the Writer component. From now on I will start LO with strace. Within the next days, as soon as the bug occurs, I will post an strace log.

(In reply to comment #15)
> Great catch in the comment #13. Is the problem 100% reproducible with that
> steps?
No, but it occurs very often after exiting the program in the described way.
>
> Could you please try to get strace log.

Sorry, I don't knwow how to do that nor what it is

 I think that it would make sense to get
> both strace logs. One when you run libreoffice, enable quickstarter, quit LO
> and the quickstarter and the second when you start libreffice against and the
> setting is lost.

Okay, as soon as I manage to understand the strace log concept I'll do that
>
> BTW: How do you quit the quickstarter? By "Disable Quickstarter" or by "Quit
> Quickstarter" or ?

Quit Quickstarter is sufficient to provoke it

Created attachment 44092
contains to strace log files, one after settings overwritten, the other after restoring settings

Created attachment 44113
created after starting LO, quitting (ctrl+q) and quitting Quickstarter

Contains the strace log file created after starting LO (with strace command) normally (bug did not occur), then subsequently shutting LO with ctrl+Q and then quitting also the Quickstarter

Created attachment 44238
strace log files before and after setting wipe

My settings are lost every time that I restart my computer, it does not happen when I exit LibreOffice and I do not have Quickstarter enabled. I have tried every proposed fix I can find but nothing helps. LibreOffice is almost unusable for me without keyboard shortcuts, macros, toolbar layout, etc. I have attached strace log files in the hopes that they will help, since I am using a newer version of LibreOffice from the previous logs. If there is any additional information that I can provide to help isolate this bug please let me know.

Ubuntu 10.10, Kernel 2.6.35-27
LibreOffice 3.3.1
OOO330m19 (Build:8)
tag libreoffice-3.3.1.2

Same thing here, but with an additional flavor: When I do lose my settings, all the styles (Galaxy, Cristal, etc) are so to speak, disabled. I can only use the Tango style (default)

Quite annoying...

Created attachment 44278
java error log

Comment on attachment 44278
java error log

created just after LO failed to load user settings, i.e. overwrote them

Created attachment 44279
strace log of the same event

Created attachment 44364
same for LO 3.3.2.RC1

just installed LO 3.3.2.RC1
LibreOffice 3.3.2
OOO330m19 (Build:201)
tag libreoffice-3.3.2.1

after installing it happened again

(In reply to comment #26)
> Created an attachment (id=44364) [details]
> same for LO 3.3.2.RC1
>
> just installed LO 3.3.2.RC1
> LibreOffice 3.3.2
> OOO330m19 (Build:201)
> tag libreoffice-3.3.2.1
>
> after installing it happened again

I should add perhaps that with this release the bug happens much less frequent than before, actually, the only instance to ocurr was shortly after installing the new 3.3.2.RC1

currently unable to collect more instances of bug behavior on LO 3.3.2.RC1, seems could have been fixed. However, needs confirmation from other Linux users, I think.

Created attachment 44547
strace log of wipe

Unfortunately this problem persists for me after installing 3.3.2 RC1. See the attached strace log.

I am also having this problem repeatedly. I'm running Ubuntu Linux and LO 3.3.1 000330m19(Build:8)

Nowe running LibreOffice 3.3.2 OOO330m19 (Build:202)tag libreoffice-3.3.2.2 on Ubuntu 10.04 kernel 2.6.32.30 and no single ocurrence of the bug until now.

It seems that it primary happens on Ubuntu => assigning to Bjoern

Ok, for triaging this bug we have so far:
- happens on Ubuntu systems (Did anyone have it on Debian or OpenSUSE too? If so, please report)
- happens with the build from Ubuntu PPA
- does *NOT* happen with the 3.3.3.2 build from libreoffice (If you see the bug there please report.)
- seems to be related to JVM and QuickStarter

Could those seeing the bug confirm this?

(In reply to comment #33)
> Ok, for triaging this bug we have so far:
> - happens on Ubuntu systems (Did anyone have it on Debian or OpenSUSE too? If
> so, please report)
> - happens with the build from Ubuntu PPA
> - does *NOT* happen with the 3.3.3.2 build from libreoffice (If you see the bug
> there please report.)
> - seems to be related to JVM and QuickStarter
>
> Could those seeing the bug confirm this?

Running 3.3.2 for several days now on Ubuntu, bug did not show up so far. As for JVM and Quickstarter, I am not sure, don't understand too much of it.

> > - happens with the build from Ubuntu PPA
> > - does *NOT* happen with the 3.3.3.2 build from libreoffice (If you see the bug
> > there please report.)

I am running a version from the LO download site, not PPA
> >
> > Could those seeing the bug confirm this?
>
> Running 3.3.2 for several days now on Ubuntu, bug did not show up so far. As
> for JVM and Quickstarter, I am not sure, don't understand too much of it.

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed
tags: added: lo33

(In reply to comment #35)
> I am running a version from the LO download site, not PPA

So you are running 3.3.2 from the LO download site and you are _not_ experiencing the bug. Was the version you used the before (where you did see the bug) also from the LO download site?

(In reply to comment #36)
> Was the version you used the before (where you did see
> the bug) also from the LO download site?

Yes, I was never able to install from PPA because of error

> Ok, for triaging this bug we have so far:
> - happens on Ubuntu systems (Did anyone have it on Debian or OpenSUSE too? If
> so, please report)
> - happens with the build from Ubuntu PPA
> - does *NOT* happen with the 3.3.3.2 build from libreoffice (If you see the bug
> there please report.)
> - seems to be related to JVM and QuickStarter
>
> Could those seeing the bug confirm this?

I'm getting mine from http://ppa.launchpad.net/libreoffice/ppa/ubuntu maverick main

(In reply to comment #33)

> - happens on Ubuntu systems (Did anyone have it on Debian or OpenSUSE too? If
> so, please report)

Happens on Opensuse too, please see: http://listarchives.libreoffice.org/de/users/msg00753.html

> - happens with the build from Ubuntu PPA
Not only

> - does *NOT* happen with the 3.3.3.2 build from libreoffice (If you see the bug
> there please report.)

Until now, seems not to happen, see other user experience: http://listarchives.libreoffice.org/de/users/msg00753.html

(In reply to comment #36)
> (In reply to comment #35)
> > I am running a version from the LO download site, not PPA
>
> So you are running 3.3.2 from the LO download site and you are _not_
> experiencing the bug. Was the version you used the before (where you did see
> the bug) also from the LO download site?

I am still getting this bug with 3.3.2 from download site. I have tried both PPA and download with previous versions, bug was present in both sources.

(In reply to comment #40)
> (In reply to comment #36)
> > (In reply to comment #35)
> > > I am running a version from the LO download site, not PPA
> >
> > So you are running 3.3.2 from the LO download site and you are _not_
> > experiencing the bug. Was the version you used the before (where you did see
> > the bug) also from the LO download site?
>
> I am still getting this bug with 3.3.2 from download site. I have tried both
> PPA and download with previous versions, bug was present in both sources.

Also same for me at Linux Mint 10 using PPA version. I would even pay to have this done.

This issue was resolved for me when I upgraded to Ubunutu 11.04, still running LO 3.3.2.

molybtek (ubuntu-truong) wrote :

Not sure if this is related, but I find my settings are reverted back to the default even when I open a new file.

I'm seeing this in 3.4.2 on OSX 10.6.8. LO crashed opening about 20 files with "Update links when opening" set to "Always". After that, my "Update Links" setting disappeared, and won't persist after LO exits.

@James:
<http://wiki.documentfoundation.org/BugReport_Details#Version>

@björn:
Can you please leave a brief explanation concerning "jvmcrash" on <http://wiki.documentfoundation.org/BugReport_Details#Whiteboard> or somewhere else?

If I were trying to create a fault with the same symptoms, I would:

  - rewrite the configuration file often, and on startup
  - using java

and either:
  - rewrite it in place, so if the java failed early, it would be blank
or:
  - write it to a temporary file and rename it, but not detect the java error

I have not examined the relevant code, and I am on MacOS, so I am unlikely to exercise the fault. Can someone who knows determine whether the code is compatible with my theory of the fault?

removing jvmcrash whiteboard status, does not seem to be a generic problem anymore.
Disowning bug for now as it is not Ubuntu specific.

.3. / 3.4 lifecycle is terminated, so being listed in "MAB" is useless.

Still a 3.5 Problem?

(In reply to comment #47)
> .3. / 3.4 lifecycle is terminated, so being listed in "MAB" is useless.
>
> Still a 3.5 Problem?

No further ocurrences of the bug at least on LibreOffice 3.5.1.2
Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
Ubuntu Natty

resolving as WORKSFORME then.

Changed in libreoffice (Ubuntu):
status: New → Fix Released

As per upstream bug:
No further ocurrences of the bug at least on LibreOffice 3.5.1.2
Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
Ubuntu Natty

Changed in df-libreoffice:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.