soffice.bin crashed with SIGSEGV in uno_type_sequence_construct()

Bug #730571 reported by Jean-Baptiste Lallement on 2011-03-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Automated Desktop Testing: 20110307

I got this crash when the application closed at the end of the test.
The test just launch loffice then launch and close each of writer, calc, impress and draw

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.1-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CrashCounter: 1
Date: Mon Mar 7 11:08:29 2011
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110221)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin -splash-pipe=5
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x472ea1: mov 0x8(%edx),%eax
 PC (0x00472ea1) ok
 source "0x8(%edx)" (0x00000110) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3
 uno_type_sequence_construct () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
 cppu::OInterfaceContainerHelper::removeInterface(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> const&) () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
Title: soffice.bin crashed with SIGSEGV in uno_type_sequence_construct()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare sudo

Jean-Baptiste Lallement (jibel) wrote :

StacktraceTop:
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3
 uno_type_sequence_construct () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
 cppu::OInterfaceContainerHelper::removeInterface(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> const&) () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3
 ?? () from /usr/lib/libreoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3

Changed in libreoffice (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgtk2.0-0-dbg: installed version 2.24.1-1ubuntu1, latest version: 2.24.1-1ubuntu2
libgcc1-dbg: installed version 1:4.5.2-3ubuntu3, latest version: 1:4.5.2-5ubuntu1

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
visibility: private → public
Changed in libreoffice (Ubuntu):
status: Invalid → Fix Released
Roy Dyton (l2ksnailor) wrote :

Bug problem with Libre Office writer has become so frustrating that I am seriously planning to revert to Windows XP

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers