libreoffice-java-common should depend on or recommend JRE (libjaxp1.3-java libserializer-java-openoffice.org libxerces2-java)

Bug #727354 reported by YunQiang Su on 2011-03-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

when promote install this package for searching in libreoffice help, just install this package, it can not do this job.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice-java-common 1:3.3.1-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Mar 2 03:08:29 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100812)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=zh_CN:zh:en_GB:en
 PATH=(custom, user)
 LANG=zh_CN.utf8
 SHELL=/usr/bin/zsh
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

YunQiang Su (wzssyqa) wrote :
summary: - libreoffice-java-common does not depend on jre
+ libreoffice-java-common should depend on or recommend JRE

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I've noticed, that new libreoffice-java-common 3.4.3 packages (from Ubuntu 11.10) depends on libjaxp1.3-java libserializer-java-openoffice.org libxerces2-java , see http://packages.ubuntu.com/oneiric/libreoffice-java-common

When I installed libjaxp1.3-java libserializer-java-openoffice.org libxerces2-java packages in Ubuntu 11.04 I got working libreoffice-java-common functionality, for now I can open example Excel 2003 XML files.

Ubuntu developers, please add libjaxp1.3-java libserializer-java-openoffice.org libxerces2-java to libreoffice-java-common version 3.3.3 depends or backport libreoffice 3.4.3 packages to Ubuntu 11.04 (Natty)

summary: libreoffice-java-common should depend on or recommend JRE
+ (libjaxp1.3-java libserializer-java-openoffice.org libxerces2-java)

natty is EOL and this is not an upstream issue.

Changed in libreoffice (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers