mozilla-libreoffice mislabeled as OpenOffice.org Plug-in

Bug #711673 reported by José Lou Chang on 2011-02-02
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: libreoffice

The mozilla-libreoffice package which allows Mozilla applications such as Firefox to load LibreOffice compatible documents incorrectly show up us "OpenOffice.org Plug-in" in Mozilla Firefox's Add-ons Manager.

Since we are transitioning to Libreoffice, it should be identified as "LibreOffice Plug-in" or just "Mozilla-LibreOffice"

***

OS: Kubuntu 10.10 64-bit

Applications:
Mozilla Firefox 4.0b11 pre; installed using "Ubuntu Mozilla Daily" PPA
Mozilla-Libreoffice (extension): 1:3.3.0-1maverick1; installed using PPA [https://launchpad.net/~libreoffice/+archive/ppa]

Chris Coulson (chrisccoulson) wrote :

Hmmmm, how come you assigned this to Firefox?

affects: firefox (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Invalid
Fabián Rodríguez (magicfab) wrote :

I guess this should not be named specifically after libre-office but rather after ODF - as this plugin would handle ODF documents, not "libreoffice documents".

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
tags: added: lo33
José Lou Chang (obake) wrote :

Hello Fabián Rodríguez. Thank you for commenting and confirming the bug.

The description for Mozilla-Libreoffice in a Package Manager shows:
"This package contains a Mozilla/Netscape plug-in which can handle ALL OO.o documents"

Doesn't that mean that ANY format that is supported by OpenOffice/LibreOffice (including perhaps doc files) can be used by Mozilla-Libreoffice? If it is, then it is not just ODF.

Fabián Rodríguez (magicfab) wrote :

@José I don't have a final answer for that but even "all OOo documents" would be covered by all ODF document types:
http://en.wikipedia.org/wiki/Odf#Specifications

Excluding PDF of course.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
no longer affects: ubuntu

for now only on master (-3-6 or later), so no precise target.

Changed in libreoffice (Ubuntu):
milestone: none → later

released with at least 3.5.0-2ubuntu1.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers