[upstream] Importing pptx files into Impress discards crop information of all images

Bug #705962 reported by Lyle Gordon on 2011-01-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

Upon loading a pptx file into Libreoffice Impress from MS Office 2007 or 2008 (prepared on windows 7) all the cropping information of the included images is lost. The images resort to their full dimensions and are often scaled anisotropically to fit into their previous dimensions. The dimensions of the images are maintained but the crop information is lost. Other than this bug everything seems to import well. It would be great o have this work.

Thanks very much,
Lyle

Thank you for your bug report. Could you maybe attach a sample pptx file showing this issue and/or a screenshot showing the problem? Thanks!

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Lyle Gordon (lgordon) wrote :
Lyle Gordon (lgordon) wrote :
Lyle Gordon (lgordon) wrote :
Lyle Gordon (lgordon) wrote :

I believe the difference between cropped and uncropped (and potentially the line that is being ignored) is:

<a:ext cx="2796737" cy="6065838"/>

in the file /ppt/slides/slide1.xml

Reported Lyle Gordon in the Ubuntu bug tracker for Libreoffice 3.3.0~rc4-1ubuntu1:
[https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/705962]

"Upon loading a pptx file into Libreoffice Impress from MS Office 2007 or 2008 (prepared on windows 7) all the cropping information of the included images is lost. The images resort to their full dimensions and are often scaled anisotropically to fit into their previous dimensions. The dimensions of the images are maintained but the crop information is lost. Other than this bug everything seems to import well. It would be great o have this work.

I believe the difference between cropped and uncropped (and potentially the line that is being ignored) is:

<a:ext cx="2796737" cy="6065838"/>

in the file /ppt/slides/slide1.xml"

this is an example document showing the issue:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/705962/+attachment/1802370/+files/example%20cropped.pptx
This is a screenshot of the correct rendering under windows:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/705962/+attachment/1802369/+files/powerpoint.png

Another remark: The thumbnailer from the libgsf project produces a correct thumbnail.

Thanks for the files, I can confirm the issue both with openoffice and libreoffice (3.3.0 rc 4). I opened an upstream bug report about the issue, you can track it and make comments at: https://bugs.freedesktop.org/show_bug.cgi?id=33361

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed

should say reproduced this on rc4

Changed in df-libreoffice:
status: Unknown → Confirmed
Fabián Rodríguez (magicfab) wrote :

Lyle, as a workaround, could you try saving to .ppt and then reproduce the same issue ? I'll will ask someone else to do the same but if you get to it faster than me that would be great.

Lyle Gordon (lgordon) wrote :

Saving the file as a ppt (attached) using Powerpoint 2010 in Windows XP and then opening it in Libreoffice 3.3 does solves the cropping issue. However this doesn't completely solve the problem as there are some new features that are lost when converting to the old ppt format.

-Lyle

Changed in df-libreoffice:
importance: Unknown → Medium
summary: - Importing pptx files into Impress discards crop information of all
- images
+ [upstream] Importing pptx files into Impress discards crop information
+ of all images

Created attachment 43916
presentation that demonstrated problem saving in PPTX

Libre Office 3.3.1.2 on Mandriva 64bit not saves crop information in pptx format. To reproduce this problem start this attachment, save as pptx and open then with MSoffice 2007. MS office 2003 with compaibilith extension can not open this file.

Created attachment 44259
image used in presentation

in Libreoffice 3.4 beta 5 works ok on Mandriva 64 bit and Windows 32 bit. I hope it fixed. Thanks!

Changed in df-libreoffice:
status: Confirmed → Fix Released

For original report (Marcel's), I tested his document and results are:
3.4.3 WORK
3.3.4 FAIL

Anyway, if it seems no known specific fix, please use WORKSFORME instead of FIXED. Thanks.

Changed in df-libreoffice:
status: Fix Released → Invalid

Lyle Gordon, I am closing this bug because this has been fixed in the latest development version of Ubuntu - Oneiric Ocelot.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

lsb_release -rd
 Description: Ubuntu oneiric (development branch)
 Release: 11.10

 apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.4.2-2ubuntu3
  Candidate: 1:3.4.2-2ubuntu3
  Version table:
 *** 1:3.4.2-2ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released

For the export (save) to .pptx issue in comment 3, I created spin-off to bug 48735.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.