Tooltips are white on yellow when editing XLS file, making them unreadable

Bug #702451 reported by Damiön la Bagh on 2011-01-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenOffice
Unknown
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

Papercut incident.

This is exactly the same as this bug
http://qa.openoffice.org/issues/show_bug.cgi?id=57226

Yet it still exists in the Ubuntu version of OpenOffice Calc.

The former bug was not solved due to insufficient information I can now provide sufficient information. But since this affects Ubuntu due to the standard Ubuntu theme I am reporting it here.

When you open an OpenOffice spreadsheet or excel document with comments in the fields the tooltips are white text on a yellow background making them impossible to read.

This is because the Ambiance theme (which is standard in Lucid) has white text as standard.

The solution is to add the following code to

.gtkrc-2.0

style "tooltips" {
        fg[NORMAL] = { 0.0, 0.0, 0.0 }
        text[NORMAL] = { 0.0, 0.0, 0.0 }
}

widget "gtk-tooltips*" style "tooltips"

This needs to be added to the standard install of Ubuntu so that users do not run into this issue.

I have attached a screen shot so you can see the issue.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: openoffice.org-calc 1:3.2.0-7ubuntu4.1
ProcVersionSignature: Ubuntu 2.6.32-27.49-generic 2.6.32.26+drm33.12
Uname: Linux 2.6.32-27-generic x86_64
NonfreeKernelModules: fglrx wl
Architecture: amd64
CheckboxSubmission: a3a053998eb48623dd168c329c2dfc37
CheckboxSystem: e704f33cc0866ff0f0256a33de39ea1c
Date: Thu Jan 13 16:26:18 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcEnviron:
 LANG=nl_NL.utf8
 SHELL=/bin/bash
SourcePackage: openoffice.org

Damiön la Bagh (kat-amsterdam) wrote :
Leo Arias (elopio) wrote :

I tried to reproduce it but I couldn't. For me, the text of the comment is black.

I'm using ambiance and Ubuntu 10.10. Can you please try to reproduce it with a newer version of the package?
You could use the live environment of the Desktop CD of the development release - Natty Narwhal.

Thanks for the report.

elopio@tangamandapio:~$ aptitude show openoffice.org-calc
Package: openoffice.org-calc
State: installed
Automatically installed: no
Version: 1:3.2.1-7ubuntu1.1

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Damiön la Bagh (kat-amsterdam) wrote :

I will try in a virtual machine with a newer version of Ubuntu and OpenOffice.org

The problem still needs to be fixed for 10.04 LTS
The Long Term Support release is essential for (small)business users of Ubuntu.

Damiön la Bagh (kat-amsterdam) wrote :

See the screenshot. Problem still exists in Maverick.

I did narrow it down to XLS files that exhibit the bad behavior.

Damiön la Bagh (kat-amsterdam) wrote :

I upgraded to Natty Narhwahl Alpha. But this release is so broken that it cannot display the Ambiance Theme at all. Just after logging in, it shows the Ambiance theme for about 10 seconds then it defaults back to the default GTK2.0 look with grey and black. So no way to test in Natty until this other bug is fixed. (I would guess that it's because not all the artwork is finished).

Today I am at work again and will create a blank XLS file with just the comment error in it. So anyone who is better at fixing these things can see what is going wrong.

Jack Leigh (leighman) wrote :

It looks like this has been fixed in Maverick according to #2 and my test.
If you can provide an XLS that shows this please attach it and set the status back to 'New'

Changed in openoffice.org (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Incomplete
Damiön la Bagh (kat-amsterdam) wrote :

Here is the requested XLS file that is showing the bug.

Damiön la Bagh (kat-amsterdam) wrote :

Here is a screenshot showing that in MS Excel 2003 the tooltip is shown correctly.
And in OpenOffice the tooltip is shown white on yellow.

This really needs to be fixed in Lucid 10.4.2 LTS or 10.4.3 LTS as this affects more users who use Long Term Support releases such as small businesses than home power users using the latest and greatest experimental release.

Damiön la Bagh (kat-amsterdam) wrote :

Here is more proof that this is not fixed in Maverick. this is the attached copy of the XLS file opened in a clean install of Maverick with all the updates.

So so far tested on two different machines (four if you count two virtual machines).
The VM's are clean installs of Maverick, with all the updates.

Changed in openoffice.org (Ubuntu):
status: Incomplete → New

Okay, I see the problem.
I suggest you attach the demo file upstream and ask that the bug be reopened.
You could also try reporting it at https://bugs.freedesktop.org//enter_bug.cgi?product=LibreOffice to get a fix in libreoffice which could be used on Lucid from a ppa.
If a fix appears you could try requesting a backport for openoffice in Lucid https://help.ubuntu.com/community/UbuntuBackports

summary: - openoffice-calc tooltips are white on yellow making them unreadable
+ openoffice-calc tooltips are white on yellow when editing XLS file,
+ making them unreadable
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Jack Leigh (leighman) on 2011-02-12
Changed in libreoffice (Ubuntu):
status: New → Confirmed

Upstream bug report has been updated.
http://qa.openoffice.org/issues/show_bug.cgi?id=57226

I've added the LibreOffice PPA and removed OpenOffice and installed LibreOffice.

LibreOffice has the exact same bug.

When I try to report it here as suggested:

https://bugs.freedesktop.org//enter_bug.cgi?product=LibreOffice

I get a certificate error with the website, showing it as unsafe to visit. Since I've not been to the website before I don't blindly trust it.

Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

It would be nice if people, when changing the statuses of bugs, would put a small description of why.

In this case openoffice.org has been set to Won't Fix because
1) Oracle will have to fix this bug upstream for OpenOffice
2) OpenOffice.org has been superceded in Ubuntu by LibreOffice. So hopefully it will get fixed there.

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - openoffice-calc tooltips are white on yellow when editing XLS file,
- making them unreadable
+ Tooltips are white on yellow when editing XLS file, making them
+ unreadable
papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1022640, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.