LibreOffice - smoketest disabled for the i386 build, fails on the buildds

Bug #696532 reported by Matthias Klose
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
High
libreoffice (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

the smoketest fails on the i386 buildds, disabled for now. need to investigate failures. the resulting packages work okish (all applications start and simple docs can be edited)

Revision history for this message
Jani Monoses (jani) wrote :

smoketest fails on arm too FWIW

Matthias Klose (doko)
affects: ubuntu → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu):
status: New → Incomplete
Revision history for this message
Matthias Klose (doko) wrote :

why incomplete?

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

I had smoketests failing on amd64 too on a local build. Well, the smoketest was fine, but the JVM crashed right after successfully finishing the smoketest. That failure mysteriously went away without any relevant changes. I have not yet reenabled the smoketest on i386, but will do soon to check, if it still fails on buildd.

No idea about the root cause as of yet.

Revision history for this message
In , KAMI (kami911) wrote :

Created attachment 43792
Zipped logfiles

Hi,

I tried several machine (Ubuntu 32/64 bit 10.10) And it seems java extensions crashes LibreOffice.

The logfiles start with (all logfile attached as zip)

 A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fc8603844ac, pid=10232, tid=140498621150976
#
# JRE version: 6.0_20-b20
# Java VM: OpenJDK 64-Bit Server VM (19.0-b09 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.9.5
# Distribution: Ubuntu 10.10, package 6b20-1.9.5-0ubuntu1
# Problematic frame:
# C [libuno_cppuhelpergcc3.so.3+0x224ac] _ZN4cppu14throwExceptionERKN3com3sun4star3uno3AnyE+0x2ac

Other Java apps (ex. in the browser works well)

Revision history for this message
In , KAMI (kami911) wrote :

These crashes occure mainly when I close one open window when more LO window open with different documents.

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

added lp696532 as this is likely the root cause

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
KAMI (kami911) wrote :

Hi Michaelsen,

I had this issue (same as reported in LibreOffice Bugzilla)
https://bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/710641

Revision history for this message
In , Tlillqvist-k (tlillqvist-k) wrote :

Bjoern, do you want to take this bug?

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

I currently cannot reproduce this the way I could before (my smoketests dies on exit). I would need a reproducible scenario to trigger the bug before going on.

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

I just was "happy" enough to be hit by this error while running LO under gdb. Unfortunately, the backtrace ends not in LO but in openjdk:

#0 0x00007fffcf40765a in InterpreterRuntime::monitorexit(JavaThread*, BasicObjectLock*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server/libjvm.so

I did not have debug symbols there, so not much joy ...

Revision history for this message
In , KAMI (kami911) wrote :

Should I try with Partners' repo: sun-java?

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

@KAMI: Please do! If we can isolate this issue to being OpenJDK only, that would be a huge step already!

Revision history for this message
In , KAMI (kami911) wrote :

However I tested it during half day it not produced java crash. I continue to test it.

Linux d 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64 GNU/Linux
ii sun-java6-jre 6.24-1build0.10.10.1

LibreOffice 3.3.1
OOO330m19 (Build:8)
tag libreoffice-3.3.1.2

Revision history for this message
In , KAMI (kami911) wrote :

Created attachment 44197
Logs with sun-java installed (partner repo) and selected in LibO

Revision history for this message
In , Brian Kjelin Olsen (brian-kjelin) wrote :

My LibreOffice application is crashing as well. It could be the same problem as you are addressing here, but I'm unsure how to check it. Could you help me?

By the way, I'm running LibreOffice on a Ubuntu 10.04 and LibreOffice is regularly updated.
Got this log message in /var/log/syslog
> Mar 31 23:06:32 localhost kernel: [36778.672809] soffice.bin[20237] general protection ip:7f22e43cbf0e sp:7fff318b53b0 error:0 in libuno_cppuhelpergcc3.so.3[7f22e43ac000+9e000]

Revision history for this message
In , Michael Meeks (michael-meeks) wrote :

Just to confirm - you're not building your binaries against gcj are you ?

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

@mmeeks: Oh yes, we (Ubuntu/Debian) are building with gjc! It would be half the fun without that.

And yes, not doing that might sure save us from a lot of Heisenbugs.

I will test the politics of that.

Revision history for this message
In , KAMI (kami911) wrote :

(In reply to comment #11)
> Just to confirm - you're not building your binaries against gcj are you ?

I am using latest sun-java JDK for build

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

Removing jvmcrash whiteboard status, disowning as not Ubuntu specific.

Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete
Revision history for this message
In , Björn Michaelsen (bjoern-michaelsen) wrote :

Cant reproduce with 3.5.0beta2 => WORKSFORME

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Seems stable with 3.5.0beta2, which is released to precise. => Fix released.

Changed in df-libreoffice:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.