[Upstream] Writer - line spacing defined in paragraph in table row with single line affects row height

Bug #681868 reported by Bob Blanchard on 2010-11-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
New
Medium
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org
Binary package hint: libreoffice

1) lsb_release -rd
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.3.3-0ubuntu3
  Candidate: 1:4.3.3-0ubuntu3
  Version table:
 *** 1:4.3.3-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Writer via a terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/681868/+attachment/1746109/+files/buggydoc.odt && lowriter -nologo buggydoc.odt

is the text fits to size vertically looking as it does in Ubuntu 8.04 OpenOffice.org Writer as per the screenshot https://launchpadlibrarian.net/68690860/Selection_007.png .

4) What happens instead is the vertical lines overrun the text vertically, as shown in the following screenshot https://launchpadlibrarian.net/68690535/LO3.3.png . This is a regression in OOo from Ubuntu 8.04 to 10.10.

WORKAROUND: Highlight text -> secondary click text -> primary click Paragraph... -> Indents & Spacing tab (notice it states under Line spacing the drop down box is Proportional with the combo box to the right is 80%) -> change the Line spacing drop down to Single -> OK button

WORKAROUND: Highlight text -> secondary click text -> primary click Paragraph... -> Indents & Spacing tab -> change the combo box to the right of the Proportional drop down to 100% -> OK button

WORKAROUND: Use Abiword.

WORKAROUND: Use Office 2013 15.0.4675.1003.

---
Architecture: amd64
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
Package: openoffice.org 1:3.2.0-7ubuntu4.1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.utf8
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Tags: lucid
Uname: Linux 2.6.32-25-generic x86_64
UserGroups: adm admin apache cdrom dialout docs elite glfs hr hrwn isql lpadmin mailadm margins mgmt network office plugdev purge sales sambashare sysadmin tech tecsys unitcost users

Bob Blanchard (blabj) wrote :

Bob Blanchard, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 681868
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Does LibreOffice Writer work for you?

sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-writer

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Bob Blanchard (blabj) wrote :

Tried LibreOffice 3.3 and the same problem exists. I will do the apport-collect shortly.

apport information

tags: added: apport-collected
description: updated
Changed in openoffice.org (Ubuntu):
status: Incomplete → New

Bob Blanchard, could you please post a screenshot with the area of the file that is affected highlighted?

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Changed in libreoffice (Ubuntu):
status: New → Incomplete
Bob Blanchard (blabj) wrote :

This screenshot shows how the previously attached "buggydoc.odt" shows in LibreOffice 3.3.

Notice how the cell borders actually touch the text in the cells.

Next I will add screenshot of how it views in stock OO 3.2.1.

Bob Blanchard (blabj) wrote :

This is a screenshot of the same document viewed with stock OpenOffice 3.2.1.

Notice that the cell borders do not touch the text.

In Ubuntu 8.04 OpenOffice.org Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/681868/+attachment/1746109/+files/buggydoc.odt && soffice -writer -nologo buggydoc.odt

It looked exactly like the screenshot -> https://launchpadlibrarian.net/68690860/Selection_007.png

This issue regresses in Ubuntu 10.10 LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/681868/+attachment/1746109/+files/buggydoc.odt && lowriter -nologo buggydoc.odt

and Ubuntu 10.10 OpenOffice.org Writer as they both look exactly like the screenshot -> https://launchpadlibrarian.net/68690535/LO3.3.png

Marking Confirmed for both.

lsb_release -rd
Description: Ubuntu 8.04.4 LTS
Release: 8.04

apt-cache policy openoffice.org-writer
openoffice.org-writer:
  Installed: 1:2.4.1-1ubuntu2.5
  Candidate: 1:2.4.1-1ubuntu2.5
  Version table:
 *** 1:2.4.1-1ubuntu2.5 0
        500 http://us.archive.ubuntu.com hardy-updates/main Packages
        500 http://security.ubuntu.com hardy-security/main Packages
        100 /var/lib/dpkg/status
     1:2.4.0-3ubuntu6 0
        500 http://us.archive.ubuntu.com hardy/main Packages

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2~maverick1
  Candidate: 1:3.3.2-1ubuntu2~maverick1
  Version table:
 *** 1:3.3.2-1ubuntu2~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy openoffice.org-writer
openoffice.org-writer:
  Installed: 1:3.2.1-7ubuntu1.1
  Candidate: 1:3.2.1-7ubuntu1.1
  Version table:
 *** 1:3.2.1-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386
Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
Changed in openoffice.org (Ubuntu):
status: Incomplete → Confirmed
tags: added: lo33
description: updated

Bob Blanchard, since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged for LibreOffice and let them handle it from here. Thanks for taking the time to make Ubuntu better!

tags: added: lucid regression-release
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
description: updated
description: updated
description: updated
Changed in abiword (Ubuntu):
status: New → Invalid

Bob Blanchard, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Bob Blanchard, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in df-libreoffice:
status: New → Incomplete
Bryan Quigley (bryanquigley) wrote :

Does this still affect on Ubuntu 14.04 or higher?

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete
Changed in df-libreoffice:
status: Incomplete → Invalid
Bob Blanchard (blabj) wrote :

Just tested LibreOffice 4.2.7.2 on Ubuntu 14.04 and same problem exists when opening the attached buggydoc.odt.

Tried Apache Openoffice 4.1.1 and it opens fine (does not exhibit problem).

Created attachment 112610
Document with table exhibiting problem

In LO writer, in a table row where height is "fit to size" - the paragraph line spacing affects the row height for single lines of text.

In OO writer, the row height doesn't affected by the line spacing defined for paragraphs in rows with single lines of text.

The attached document shows the problem. When opened with LO, the row borders are touching the text. When opened with OO, the spacing is correct, ie. not touching the borders.

This seems to only arise in documents where the fo:line-height is less than "100%" (eg. if paragraph line spacing set to proportional 80%).

In order to "fix" a document with LO, you need to select the table, right-click, Line Spacing -> Single (or 1.5 or double).

Line spacing should only affect row height when *more* than one line exists, since as the term implies, its the space between lines.

Created attachment 112611
Document with table exhibiting problem

content-type of attachment not detected properly

summary: - writer - line spacing defined in paragraph in table row with single line
- affects row height
+ [Upstream] Writer - line spacing defined in paragraph in table row with
+ single line affects row height
Changed in df-libreoffice:
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
tags: removed: lo33 migrateoootolo
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New
tags: added: lo33 migrateoootolo
tags: added: natty vivid
description: updated
description: updated
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
no longer affects: abiword (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.