[upstream] Writer imports Hebrew Word .doc file and missing some text after page break

Bug #373113 reported by Haggai Eran on 2009-05-07
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Low
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && lowriter -nologo example.doc

Search for the word "סיכום המחקרים"‎, LO finds it and highlights it.

4) What happens instead is it finds it, but does not highlight it. As well, the text does not appear in the document.

WORKAROUND: Convert the document to .odt:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && unoconv --listener && unoconv -f odt example.doc && lowriter -nologo example.odt

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Original Reporter Comments: It's a Microsoft Word document.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: openoffice.org-core 1:3.0.1-9ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=he_IL.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.28-11-generic i686

Haggai Eran (haggai-eran) wrote :
Haggai Eran (haggai-eran) wrote :

Here is the same document, after saving to .odt. In this version the text appears correctly.

dotancohen (dotancohen) wrote :

I can confirm this bug in OOo 3.0 on Kubuntu 9.04

An easier way to verify is to open both the odf and doc versions in two OOo instances. Page 9 appears blank in the doc file, the same page is populated in the odf file. However, performing a search for the text that should be there in fact finds the text.

In what program was this document originally created?

I think that this bug should be filed upstream at OOo. If need be, I can file it there as I have an active account there.

Changed in openoffice:
status: Unknown → New
Chris Cheney (ccheney) on 2009-05-08
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - Text disappears in Microsoft Word documents
+ [upstream] Text disappears in Microsoft Word documents
Changed in openoffice:
status: New → Confirmed

i can confirm this bug.

my system parameters are, for amd64 architecture:

Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

openoffice.org:
  Instalados: 1:3.1.0-3ubuntu2~jaunty1
  Candidato: 1:3.1.0-3ubuntu2~jaunty1
  Tabla de versión:
 *** 1:3.1.0-3ubuntu2~jaunty1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     1:3.0.1-9ubuntu3 0
        500 http://cl.archive.ubuntu.com jaunty/main Packages

Chris Cheney (ccheney) on 2010-05-13
tags: added: jaunty
Haggai Eran (haggai-eran) wrote :

In OpenOffice 3.2 (in lucid), the hidden text is still hidden, but it is now also hidden in the .odt version of the file.

Nigel Hessey (nigel-hessey) wrote :

I have .doc file and .odt version of it, in both of which the text disappears, but only when I scroll up. Scrolling down makes the text appear correctly. Is this the same bug? (openOffice 3.2, Ubuntu 10.04).

Haggai Eran (haggai-eran) wrote :

Well, for me scrolling up or down doesn't show the text. Perhaps this is a different bug with scrolling. Also, in this bug not all the text disappeared, but only the last few pages.

Created attachment 47529
example.doc

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=101627

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && lowriter -nologo example.doc

Search for the word "סיכום המחקרים"‎, LO finds it and highlights it.

4) What happens instead is it finds it, but does not highlight it. As well, the text does not appear in the document.

WORKAROUND: Convert the document to .odt:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && unoconv --listener && unoconv -f odt example.doc && lowriter -nologo example.odt

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

description: updated
tags: added: lo33
summary: - [upstream] Text disappears in Microsoft Word documents
+ [upstream] Writer imports Hebrew Word .doc file and missing some text
summary: [upstream] Writer imports Hebrew Word .doc file and missing some text
+ after page break
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Created attachment 47529
example.doc

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=101627

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && lowriter -nologo example.doc

Search for the word "סיכום המחקרים"‎, LO finds it and highlights it.

4) What happens instead is it finds it, but does not highlight it. As well, the text does not appear in the document.

WORKAROUND: Convert the document to .odt:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && unoconv --listener && unoconv -f odt example.doc && lowriter -nologo example.odt

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Hi,

I've tried LibreOffice Writer 3.5.0 beta2 on Mac OS, and the bug was still there.

Regards,
Haggai

Changed in df-libreoffice:
status: Confirmed → Incomplete

Hi,

I've tried LibreOffice Writer 3.5.0 beta2 on Mac OS, and the bug was still there.

Regards,
Haggai

Changed in df-libreoffice:
status: Incomplete → Confirmed

Still happens with LibO 3.6.3. Another thing I've noticed is that invoking any header related change (edit, delete) fixes the problem and the text reappears.

Still happens with LibO 3.6.3. Another thing I've noticed is that invoking any header related change (edit, delete) fixes the problem and the text reappears.

Another option is to change to print layout and back to web layout and everything looks OK.

Another option is to change to print layout and back to web layout and everything looks OK.

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.

4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03

Hi,

I tested LibreOffice 5.0.1.2 on Ubuntu 14.04, and the issue still exists.

I had to use a slightly different command line though:
  cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/373113/+attachment/2154880/+files/example.doc && unoconv -f odt example.doc && lowriter --nologo example.odt

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice
(5.1.6 or 5.2.3 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and
your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20161108

Verified on 5.1.6.

Verified on 5.4.1 (Arch Linux).

Still happens in:

Version: 6.0.0.0.alpha1+
Build ID: 9050854c35c389466923f0224a36572d36cd471a
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3;
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug

I believe this bug still exist in version 6.1.3.2. I tried it on Ubuntu 18.04 using the snap package.

Can someone please use MS Word to change this document, replacing the Hebrew text with Arabic text or even English text without changing directions, number of linesd, formatting etc?

I have a feeling this is not Hebrew-related, and perhaps not even RTL-vs-LTR related, but just a Word import issue.

Anyway, seeing this bug with

LO Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3;
Locale: en-US (en_IL); UI-Language: en-US
Calc: threaded

Created attachment 147860
example.doc loaded in Web View - phrase is visible

After loading example.doc, locating the phrase לסיכום המחקרים and switching from Normal View to Web View, this is what I see.

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3;
Locale: en-US (en_IL); UI-Language: en-US
Calc: threaded

another screenshot to follow

Created attachment 147861
example.doc loaded in Normal View - phrase is mostly-invisible

After loading example.doc, locating the phrase לסיכום המחקרים, switching to Web View and then back again to Normal View, this is what I see.

This is not a blitting glitch, or the effect of a screen refresh timeout - it stays the same even if you resize the Window, move it, change the zoom etc.

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3;

Created attachment 147862
example.doc loaded in Web View - phrase is visible

After loading example.doc, locating the phrase לסיכום המחקרים and switching from Normal View to Web View, this is what I see.

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3;

(a smaller version of 147860 - please ignore that one.)

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete
Changed in df-libreoffice:
importance: Low → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

Synchronising bug status with upstream.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.