Searching for selected text does not work with control characters

Bug #311762 reported by Michael Nagel on 2008-12-27
2
Affects Status Importance Assigned to Milestone
OpenOffice
Unknown
Low
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org-writer

if you have text selected and hit CTRL+F that text is inserted into the search field.
this does not work if the text contains control characters like newline, newparagraph or tabulators.
desired behaviour: it should work then, too.

tested on open office 2.4 hardy and intrepid.
---
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
Package: libreoffice 1:3.5.4-0ubuntu1.1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Tags: precise running-unity
Uname: Linux 3.2.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

If you have text selected and hit CTRL+F that text is inserted into the search
field. This does not work if the text contains control characters like newline,
newparagraph or tabulators.

Chris Cheney (ccheney) on 2009-01-22
Changed in openoffice.org:
importance: Undecided → Low
status: New → Triaged
Changed in openoffice:
status: Unknown → Confirmed

That's an enhancement, not a defect.
Reassigned

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

I checked using LibreOffice 3.2.2.2 on a Mac and this bug is present in LibreOffice as well.

summary: - [upstream] OOo searching for selected text does not work with control
- characters
+ Searching for selected text does not work with control characters

Michael Nagel, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p libreoffice 311762

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Michael Nagel (nailor) wrote :

Does not work as expected:
nailor@needle:~1$ apport-collect -p libreoffice 311762
Package libreoffice not installed and no hook available, ignoring

Behavior of CTRL-F changed as well in the meantime...
It still does not work properly, but I will close this bug...

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid

Michael Nagel, the reason apport-collect did not work is because you literally do not have the package libreoffice installed, but you do have the components of libreoffice (ex. libreoffice-writer). Please perform the following via the Terminal:
 sudo apt-get -y install libreoffice && apport-collect -p libreoffice 311762

Changed in libreoffice (Ubuntu):
status: Invalid → Incomplete

apport information

tags: added: apport-collected precise running-unity
description: updated

apport information

Michael Nagel, thank you for apport-collect'ing.

Regarding your bug description:

"if you have text selected and hit CTRL+F that text is inserted into the search field.
this does not work if the text contains control characters like newline, newparagraph or tabulators.
desired behaviour: it should work then, too."

The phenomenon of selecting text, hitting CTRL+F, and having it inserted into the search field is unverifiable in LibreOffice.

Could you please post a recording of this via recordmydesktop?

Michael Nagel (nailor) wrote :

as mentioned above, behavior of CTRL-F has been redefined in the meantime.
similar behavior can be reproduced by using CTRL-H now.

create a new document:
- type letter a
- type letter b
- hit tabulator key
- type letter c
- type letter d

now, if you select "ab" with the mouse and hit CTRL-H "ab" is inserted into the "search for" field. pressing "find" finds it.
if you however select with the mouse "b c" then "b c" is inserted in the "search for" field and nothing is found.

Michael Nagel, regarding your comments https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/311762/comments/9 :

>"as mentioned above, behavior of CTRL-F has been redefined in the meantime."

The behavior of CTRL+F being redefined was not mentioned above.

>"similar behavior can be reproduced by using CTRL-H now.

create a new document:
- type letter a
- type letter b
- hit tabulator key
- type letter c
- type letter d

now, if you select "ab" with the mouse and hit CTRL-H "ab" is inserted into the "search for" field. pressing "find" finds it.
if you however select with the mouse "b c" then "b c" is inserted in the "search for" field and nothing is found."

The problem is still not reproducible. Could you please provide a recording of the problem as requested in https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/311762/comments/8 ?

Michael Nagel (nailor) wrote :

I just tried to do a recording, but due to Bug #1005914 i cannot create a useful record (only the background shows).

Michael Nagel, https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/311762/comments/8 did not ask you to use gnome-screenshot. Instead, it requested you use the package:
recordmydesktop

Michael Nagel (nailor) wrote :

It creates a video of my desktop background.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
Changed in openoffice:
status: Confirmed → Unknown
Changed in openoffice:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.