[Upstream] Cannot remove highlight from .doc in Word exported from Writer

Bug #295014 reported by Robert Hutton on 2008-11-07
62
This bug affects 9 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org-core

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.3-1ubuntu2
  Candidate: 1:3.3.3-1ubuntu2
  Version table:
 *** 1:3.3.3-1ubuntu2 0
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in documented exported from Writer opened in Word via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/295014/+attachment/410599/+files/test_highlight.doc && wine ~/.wine/drive_c/Program\ Files/Microsoft\ Office/OFFICE11/WINWORD.EXE test_highlight.doc

click the Highlight button -> No Fill and the highlight is removed.

4) What happens instead is the highlight is not removed.

WORKAROUND: In Word click Format -> Boarders and Shading... -> Shading tab -> click No Fill button -> under Preview change drop down Apply to: text -> OK button

WORKAROUND: Use AbiWord to export documents with highlighting.

apt-cache policy abiword
abiword:
  Installed: 2.8.6-0.3build1
  Candidate: 2.8.6-0.3build1
  Version table:
 *** 2.8.6-0.3build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Robert Hutton (rwh-helms-deep) wrote :
Chris Cheney (ccheney) on 2009-01-06
Changed in openoffice.org:
importance: Undecided → Low
status: New → Triaged
Changed in openoffice:
status: Unknown → Confirmed
maticmatija (maticmatija) wrote :

I can confirm this bug.

description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Triaged
description: updated
tags: added: lo33
summary: - Highlights in a word document (.doc) saved in openoffice writer cannot
- be removed using MS Word
+ [Upstream] Cannot remove highlight from .doc in Word exported from
+ Writer
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

My colleague just noticed this issue like this:
"I never can remove color highlights in your *** documents made in your *** LibreOffice... Throw it in ***"... And so on...

The bug happens not only when you export as DOC, but also when you export as DOCX and then edit it in Office 2007 or 2010...

Additional info:
There are two buttons on the toolbar in Word 2010 – one changes highlight color and the other changes text background color (Word2003 has only one of those)

1. Make a document in LibreOffice that consists of 3+ paraghraph
2. Highlight ENTIRE central paragraph yellow
3. Save as DOC or DOCX
4. Open in Office 2007-2010
5. Enable display hidden characters (!)
6. Try to remove highlighting (background color)
a) Select the entire paragraph with the paragraph sign in the end. Change text background option using the control on the panel. Doesn't work.
b) Select the entire paragraph with the paragraph sign in the end. ... Does work.

Anyway, most people, when they see highlighted text in MS Word, assume it is "highlighted text", not "text background"... The second option is hidden deep in MS Word 2007-2010 and nonexistent in MS Word prior 2003...

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Changed in df-libreoffice:
importance: Medium → High
Changed in df-libreoffice:
status: Confirmed → Incomplete
Changed in df-libreoffice:
status: Incomplete → Confirmed
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 12.04.2 LTS with LibreOffice 3.5.7.2 Build ID: 350m1(Build:2).

tags: added: precise
Norbert (nrbrtx) on 2013-05-11
tags: added: quantal raring
description: updated

Created an attachment (id=538810)
higligting demo document created with LibreOffice Writer

User-Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

Broken interoperability between LibreOffice writer and Microsoft Office Word.

Reproducible: Always

Steps to Reproduce:
1. Create a DOC/DOCX document with some text and mark in LibreOffice Writer.
2. Use highlighting yellow marker from toolbar to mark some words.
3. Save document.
4. Open document in MS Word 2003+ and try to change higlight color from yellow to white.
5. Yellow highlighting is still present. There is only one way to remove it - change/remove its style from Styles and formatting sidebar.

Expected Results:
Highligting must be changed as it done in MS Office - via Highligting button, not from Styles.

This bug has 9 years history.

Norbert (nrbrtx) on 2013-05-11
no longer affects: libreoffice (openSUSE)
Changed in libreoffice (openSUSE):
importance: Unknown → Medium
status: Unknown → Confirmed

Romano: My entire previous comment was for both core devs quoted (Michael and Miklos) that I put on cc list. Sorry for the confusion.

Norbert,

If I understand correctly, your problem is in the DOC export filter. Could you please also create a file in Word that is "good", w.r.t. expected results?

Then I can try to analyze what's the difference between the two.

Thanks!

Created an attachment (id=546300)
higligting demo document created with Microsoft Office Word 2003 SP3 (DOC)

Created an attachment (id=546301)
higligting demo document created with Microsoft Office Word 2007 SP3 (DOC)

Changed in libreoffice (openSUSE):
status: Confirmed → Incomplete

Hello!

Bug is still exist in the latest Windows build of LibreOffice
(
LibreOffice 4.1.2.3
Версия: 4.1.2.3
ID сборки: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
).

Please fix it as soon as possible.

Highlighting marker is used very often.
It breaks normal document exchange between Microsoft Office Word users and LO/OO users.

Hello!

Bug is still exist in the latest Windows build of LibreOffice
(
LibreOffice 4.1.2.3
Версия: 4.1.2.3
ID сборки: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
).

Please fix it as soon as possible.

Highlighting marker is used very often.
It breaks normal document exchange between Microsoft Office Word users and LO/OO users.

I mean: "Highlighting marker is used very often.

But this bug breaks normal document exchange between Microsoft Office Word users and LO/OO users."

Good news:

Bug https://bugs.freedesktop.org/show_bug.cgi?id=65403 (which is a subset of this one) has been closed with the following patch:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b949134441056a1455d67ddfdd7e0bc5f2ee682

If I understand correctly, Zolnai Tamás (thanks!) has added the highlight property to LibreOffice. Now it just need to be linked with the "highlighting" tool and it should all work as expected... finger crossed!

NoRepro:4.2.0.3:OSX

open Sottolineatura_LO.doc

save as doc
save as docx

Open doc with MS Word 2011 > text with color-background is recognized as marked text
Open docx with MS Word 2011 > text with color-background is recognized as marked text

WORKSFORME.

Please re-open if I'm missing something obvious :)

Confirmed:4.2.0.3:OSX

Open test file, marked color is not removable when opened with MS Word 2011.

Changed in df-libreoffice:
status: Confirmed → Invalid
Norbert (nrbrtx) wrote :

Synced with upstream.

Changed in df-libreoffice:
importance: High → Unknown
status: Invalid → Unknown
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

Any GSoC participants who want to know what happens when they press the highlight toolbar button should review the SfxDispatcher mechanism. It calls on SfxTextShell::Execute(), the slot that it uses is SID_ATTR_CHAR_COLOR_EXT on line 1190 of sw/source/core/ui/textsh1.cxx.

I hope that helps a little bit. You'll probably also need to look at how Word handles highlighting in the docx format. I'll leave that as an exercise for the student :-)

Incidentally, if you ever want to work out what a button uses, then put a breakpoint on SfxDispatcher::Execute - that's how I worked out this.

Changed in df-libreoffice:
importance: High → Critical
Changed in df-libreoffice:
importance: Critical → High
Adolfo Jayme (fitojb) on 2015-04-14
affects: openoffice → hundredpapercuts
Changed in hundredpapercuts:
importance: Unknown → Undecided
status: Confirmed → New
no longer affects: openoffice.org (Ubuntu)
affects: df-libreoffice → ubuntu
Changed in ubuntu:
importance: High → Undecided
status: Confirmed → New
no longer affects: ubuntu
no longer affects: libreoffice (Ubuntu)
affects: libreoffice (openSUSE) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
importance: Medium → Undecided
status: Incomplete → New
no longer affects: libreoffice (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
affects: libreoffice (Debian) → libreoffice (Ubuntu)
no longer affects: libreoffice (Ubuntu)
affects: libreoffice (Fedora) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Low
status: New → Triaged

Not reproducible exporting .doc with highlight to Word 2013 via Xenial.

no longer affects: libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: New → Confirmed
affects: hundredpapercuts → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.