Floating toolbars prevent attaining focus when selected in Gnome taskbar

Bug #26303 reported by gmlion on 2005-11-27
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
OpenOffice
Invalid
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

If i use the taskbar to switch to openoffice, and openoffice has a floating bar,
the openoffice window get visible but not active.

Matthias Klose (doko) on 2006-03-12
Changed in openoffice.org2-amd64:
status: Unconfirmed → Confirmed
Matthias Klose (doko) on 2007-04-04
Changed in openoffice.org:
assignee: doko → nobody
Chris Cheney (ccheney) wrote :

Confirmed on Ubuntu 7.10 OpenOffice 2.3.0

Chris Cheney (ccheney) on 2008-03-24
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → New
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
vanadium (ftack) wrote :

Related to this issue: switching with the keyboard to an OOo Document where a floating window is active will display the Document and floating Window, but none of them is active and the keyboard does not seem to work.

Steps to reproduce the issue

1) Launch a Writer document. Open the style Window (F11) or open the navigator (already here, keyboard focus is lost and the user is obliged either to click or <alt+tab> to continue working)
2) Launch a second writer document
3) Press Alt+tab to go to the first instance: no window is active, no keys except system wide keys do anything. The user is obliged to click or alt-tab to regain focus.

The above can also be reproduced using the task bar with the mouse rather than Alt+tab.

In my opinion, this usability issue, which is an annoyance, deserves more attention than it currently has. The office suite is one of the central applications in modern desktop computing.

(Tested on Ubuntu 8.04 with OOo 2.4.1)

n_anacker (anacker) wrote :

This problem still exists in OO.o 3.0 and causes trouble for screen reader users.

Changed in openoffice:
status: New → Confirmed

The issue is related to the Windows manager. Currently I am using Compiz. With "Focus Prevention Level" set to "Off", there is no problem. I did not find such setting in metacity.

GercoKees (gercokees) wrote :

if that is the case, what about other window-managers? (fluxbox, Enlightenment, Sawfish)....?

fsando (stfs) wrote :

Confirmed in Ubuntu intrepid (all visual effects turned off) with Openoffice 3.

This happens when I double click a file, it opens fine is in front but last window (ie. nautilus where I just clicked) still has focus. Extremely annoying when looking through a lot of ooo-files opening and closing again. I constantly forget and close the nautilus window behind instead.

Narcis Garcia (narcisgarcia) wrote :

I've experienced the same problem since years/versions ago, and now with Ubuntu 9.04 (Jaunty Jackalope) and OpenOffice.org 3.0.1

Need to snap all floating toolbars to bottom of the window.

Changed in openoffice:
status: Confirmed → Invalid
Chris Cheney (ccheney) on 2009-10-29
summary: - [upstream] OpenOffice floating toolbars prevent attaining focus when
- selected in Gnome taskbar
+ [upstream] [3.2] OpenOffice floating toolbars prevent attaining focus
+ when selected in Gnome taskbar
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [upstream] [3.2] OpenOffice floating toolbars prevent attaining focus
- when selected in Gnome taskbar
+ Floating toolbars prevent attaining focus when selected in Gnome taskbar

Libreoffice needs affected version. => Incomplete.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
GercoKees (gercokees) wrote :

(Tested on LibreOffice 3.3.3
OOO330m19 (Build:301)
tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.3-1ubuntu2)

Changed in libreoffice (Ubuntu):
status: Incomplete → New

Since

http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=46ea2f6cb38536aa1b1a259af2145a581e19f6e8

if you tear off e.g. the font color toolbar pop so that it floats free then open a new calc or writer window it all behaves very strangely.

The most obvious problem is if you tear it off in calc, then open another calc windows under gnome then you can't type into the second calc window.

Either way the torn off window floats above all windows, but it only has meaning to the original window within which it was torn off.

Its eluding me right now how to get the right effect of 46ea2f6cb38536aa1b1a259af2145a581e19f6e8 to not be decorated and look pretty when not torn off yet, and how to get the old behaviour of only floating above its original parent window

Created attachment 59387
seems a little better

Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a482b89e4d9c41b6f7c1616d193ac6cde05a69a7

Resolves: fdo#48096 torn off popups trigger keyboard focus problems

caolanm->kendy: care to have a look to see if this is worth backporting to 3-5 series ?

I added Fix submitter as assignee because this will ease queries and bug tracking.

reopen, selfassign for backport.

possibly fixed with:
https://bugs.freedesktop.org/show_bug.cgi?id=48096
on upstream master

lets close this, cause it is fixed in 3-6-0, regardless of being backported to 3-5-X or not

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released

fix released with 3.6/quantal.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.