[snap] GUI not show. Any LibreOffice app snap won't open with AMD 4750 Pro (Ubuntu 21.04)

Bug #1936051 reported by Eduardo Rojas Rodríguez
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

In a laptop Thinkpad t14s AMD 4750 PRO (Renoir GPU) with Ubuntu 21.04 (5.11.0-22-generic)

When opening ANY LibreOffice app as a Snap, from GUI menu or from command line, 2 processes are opened, and the program GUI is not displayed.

eduardo@edu-ThinkPad-T14s:~$ pgrep -a soffice
10612 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --writer
10613 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --writer

eduardo@edu-ThinkPad-T14s:~$ pgrep -a soffice
10803 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --impress
10804 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --impress

eduardo@edu-ThinkPad-T14s:~$ pgrep -a soffice
11002 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --calc
11003 /snap/libreoffice/223/lib/libreoffice/program/soffice.bin --calc

Killing the last process of any LibreOffice app allows the program GUI to start fully and be displayed.

LibreOffice Snap version:

Name........Version.Rev.Tracking Publisher
thunderbird 78.11.0 12 latest/stable canonical✓

Here are the jurnalctl -t audit -f logs

jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000
jul 13 22:14:31 edu-ThinkPad-T14s audit[11213]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.libreoffice.writer pid=11213 comm="soffice.bin" exe="/snap/libreoffice/223/lib/libreoffice/program/soffice.bin" sig=0 arch=c000003e syscall=203 compat=0 ip=0x7fa1753ecc7f code=0x50000

After killing the last process the GUI its fully loaded and thunderbird snap work.

Here are the jurnalctl -t audit -f logs after killing the last process

jul 13 22:15:23 edu-ThinkPad-T14s audit[1059]: USER_AVC pid=1059 uid=103 auid=4294967295 ses=4294967295 subj=unconfined msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/" interface="org.freedesktop.DBus.Peer" member="Ping" mask="send" name="org.freedesktop.Avahi" pid=11212 label="snap.libreoffice.writer" peer_pid=1051 peer_label="unconfined"
                                                exe="/usr/bin/dbus-daemon" sauid=103 hostname=? addr=? terminal=?'

This is a related Answer form Launchpad
https://answers.launchpad.net/snappy/+question/697307

Maybe its something with new amdgpu drivers, since in another laptop (thinkpad t460 intel with Ubuntu 21.04) this does not happen.

tags: added: hirsute
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan Polak (jpolak) wrote :

It also affect CHROMIUM SNAP in machines with AMD CPU. Right clicking on parts of the application that would normally open a context menu, for example right clicking on the tabs along the top, results in the application freezing. This does not happen if you right click in the web page area

Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote (last edit ):

I must add that with the same Thinkpad 14s AMD 4750 PRO (Renoir GPU) with Ubuntu 20.04.2 LTS kernel 5.8 this problem does not happen. This can be important because in august the Ubuntu LTS its going to upgrade the kernel (if I understand correctly) this can break the snap for a lot of AMD laptops users

Hi Jonathan

Tested the Chromium snap and indeed there are a problem when right clicking, but I think maybe its an unrelated issue, better open another bug support in the chromium snap.

Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote :

Tested with linux kernel 5.11.0-31-generic and drivers updated from MESA 21.0 to 21.3 using the oibaf PPA. This problem persist

summary: - [snap] GUI not show. Opening LibreOffice snap causes 2 processes to open
- (Ubuntu 21.04)
+ [snap] GUI not show. Any LibreOffice app snap won't open with AMD 4750
+ Pro (Ubuntu 21.04)
Revision history for this message
Dmitry Agafonov (dmitry-agafonov) wrote :

Lenovo Legion 5 (AMD Ryzen 7 5800H with Radeon Graphics)
Almost the same here: no gui shows up, processes are running.

Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote :

Tested with Ubuntu 20.4.3 with the new kernel 5.11 and now the this problem is present in the LTS version.

tags: added: snap
Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote (last edit ):

Tested the new LO Snap:
Name: libreoffice
Version: 7.2.0.4
Rev: 227
Tracking: latest/stable
Publisher: canonical✓

The problem is solve for me, now the snap opens without problems, maybe someone may confirm that in the new Rev the problem its gone so I can close this bug? Dmitry may you check if the newer version fixes it for you too?

Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote (last edit ):

Confirm this is fixed in the new snap rev with LO 7.2

Closing

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers