[SRU] libreoffice 6.4.6 for focal

Bug #1892783 reported by Heather Ellsworth
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Heather Ellsworth
Focal
High
Heather Ellsworth

Bug Description

[Impact]

 * LibreOffice 6.4.6 is in its sixth bugfix release of the 6.4 line. Version 6.4.5 is currently in focal.
   For a list of fixed bugs compared to 6.4.5 see the list of bugs fixed in the two release candidates:
     https://wiki.documentfoundation.org/Releases/6.4.5/RC1#List_of_fixed_bugs
     https://wiki.documentfoundation.org/Releases/6.4.5/RC2#List_of_fixed_bugs
   (that's a total of 106 bugs)

 * Given the nature of the project, the complexity of the codebase and the high level of quality assurance upstream, it is preferable to SRU a minor release rather than cherry-pick selected bug fixes.

[Test Case]

 * No specific test case, bugs fixed upstream hopefully come with unit/regression tests, and the release itself is extensively exercised upstream (both in an automated manner and manually) by a community of testers. Each minor release normally goes through two release candidates.

 * The libreoffice packages include autopkgtests, those should be run and verified to pass.

 * General smoke testing of all the applications in the office suite should be carried out.

[Regression Potential]

 * A minor release with a total of 106 bug fixes always carries the potential for introducing regressions, even though it is a bugfix-only release, meaning that no new features were added, and no existing features were removed.

 * A combination of autopkgtests and careful smoke testing as described above should provide reasonable confidence that no regressions sneaked in.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Heather Ellsworth (hellsworth)
Changed in libreoffice (Ubuntu Focal):
assignee: nobody → Heather Ellsworth (hellsworth)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Heather, or anyone else affected,

Accepted libreoffice into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.4.6-0ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Heather Ellsworth (hellsworth) wrote :

Upgraded libreoffice from 1:6.4.5-0ubuntu0.20.04.1 to 1:6.4.6-0ubuntu0.20.04.1 from focal-proposed in a clean and up-to-date focal amd64 VM, and successfully ran test plan at https://wiki.ubuntu.com/Process/Merges/TestPlans/libreoffice.

tags: added: verification-done-focal
removed: verification-needed verification-needed-focal
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Heather Ellsworth (hellsworth) wrote :

More information about the upstream QA testing can be found here:
* Automated tests - https://wiki.documentfoundation.org/QA/Testing/Automated_Tests
* Automated UI tests - https://wiki.documentfoundation.org/Development/UITests
* Regression tests - https://wiki.documentfoundation.org/QA/Testing/Regression_Tests
* Feature tests - https://wiki.documentfoundation.org/QA/Testing/Feature_Tests

Recent test results of upstream's libreoffice-6-4 branch can be found here:
https://jenkins.libreoffice.org/job/gerrit_64/

Revision history for this message
Heather Ellsworth (hellsworth) wrote :
Revision history for this message
Heather Ellsworth (hellsworth) wrote :

Here is the upstream build that corresponds to the topmost commit included in 6.4.6:
https://ci.libreoffice.org/job/gerrit_64/1652/

I found this by finding the topmost merge on the libreoffice-6-4-6 branch (which is where this package would have been built from):
https://gerrit.libreoffice.org/c/core/+/100055

And then tracing back to the ci job. I can add this in future libreoffice SRU descriptions as well.

Revision history for this message
Chris Halse Rogers (raof) wrote :

I see the AMD64 autopkgtests listed there have a failure due to timeout on uitest-sw, but https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/amd64/libr/libreoffice/20200905_235254_13bfb@/log.gz appears to have passed, so this is probably flaky, or at least a likely victim of timeout under resource contention?

Revision history for this message
Heather Ellsworth (hellsworth) wrote :

Yes this uicheck-sw test in particular is flaky under resource contention. If I run the test locally, it passes every time.

Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.4.6-0ubuntu0.20.04.1

---------------
libreoffice (1:6.4.6-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream release (LP: #1892783)

 -- Heather Ellsworth <email address hidden> Mon, 24 Aug 2020 16:58:01 -0600

Changed in libreoffice (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers