Libreoffice Help does not work

Bug #1869561 reported by Tim Passingham on 2020-03-29
256
This bug affects 49 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Heather Ellsworth
Focal
High
Heather Ellsworth

Bug Description

In the latest PPA release of Libreoffice, the Help does not work. IN version 6.3.5.2 it is OK. I the version below it returns an error.

Version: 6.4.2.2
Build ID: 1:6.4.2-0ubuntu0.19.10.3
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: x11;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

The Error is:

Object not accessible.
The object cannot be accessed
due to insufficient user rights.

The Help used to open the help in a browser window. This latest version seems to try to open the old type of local help (rather than using a browser).

affects: launchpad-report-tool → libreoffice (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Tim Passingham (tim-8aw3u04umo) wrote :

Thanks Rico. I always struggle to find the right way to report issues, especially when there is no crash or other evidence (ubuntu-bug doesn't recognise libreoffice).

Heather Ellsworth (hellsworth) wrote :

The problem appears to be only in 6.4.X deb. Here's what I've tested.

* The 6.4.2 snap works probably because we are including the help directly, so that help opens the actual help rather than directing the user to the web.
* 6.4.2.2 deb = broken
* 6.4.1-0ubuntu1 deb = broken
* 6.4.0-0ubuntu8 = broken
* 6.3.5-0ubuntu0.19.10.1 = works

Tim Passingham (tim-8aw3u04umo) wrote :

I wish the local help could be included in the normal installation. It looks as if the change to the web-based version in earlier versions has been removed, but the local help doesn't work outside of snaps.

I have to admit I fail to understand snaps.

tags: added: focal
Changed in libreoffice (Ubuntu):
assignee: nobody → Heather Ellsworth (hellsworth)
tags: added: rls-ff-incoming
Changed in libreoffice (Ubuntu):
importance: Undecided → High
tags: removed: rls-ff-incoming
Olivier Tilloy (osomon) wrote :

It sounds like the problem is trying to open the local help custom UI, instead of the expected behaviour (opening the local HTML help in a browser). The debs produced by TDF do open the help in a browser, so there is a functional discrepancy here that should be investigated.

abtm (abalsam) wrote :

I just installed the newly released version of LibreOffice (6.4.3-0ubuntu0.20.04.1 and confirmed the help bug is still present.

Leó Kolbeinsson (leok) wrote :

I tested this yesterday 05.05.2020 on the daily builds for Groovy on Lubuntu,Xubuntu,Kubuntu and Ubuntu ISO´s and can also nconfirm this is still present in version 6.4.3.2 in all of the forementioned.

JohnEverest (john-everest) wrote :

Workaround until bug is fixed. Add "OFFICE HELP" application to launcher:-

"Firefox /usr/share/libreoffice/help/index.html"

Sebastien Bacher (seb128) wrote :

Sharing some findings after having poked a bit to the issue, the problems come from the /usr/lib/libreoffice/share/registry/main.xcd configuration, copying that file from the Debian build makes the documentation open in the default webbrowser and work.

The Ubuntu version is having no mention of DesktopBackend which seems relevant

The build log has those warnings which don't exist in Debian or Bionic
'...
no obvious way to instantiate implementation "com.sun.star.comp.configuration.Update"
no obvious way to instantiate implementation "com.sun.star.comp.configuration.backend.DesktopBackend"
no obvious way to instantiate implementation "com.sun.star.comp.configuration.backend.KF5Backend"
...'

They seem to come from tests and probably not the direct but could hint on an issue, if the backend fails to load then it could end up missing from the configuration

There is nothing obvious in the packaging diff between Debian and Ubuntu though...

Including the Debian file so it's easier for other to check the differences / test if it works for them as well by copying it over the system one

Sebastien Bacher (seb128) wrote :

Sebastien - that works for me - I now get the local web-based help (I'd still prefer the old fashioned sort, but never mind!),

With the new xcd it reports it is:

Version: 6.4.3.2
Build ID: 1:6.4.4~rc1-0ubuntu0.20.04.1
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: x11;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Although the version numbers seemed to have got confused. I think I really am on 6.4.4 rc1. Reverting to the original xcd it reports the correct version.

I was a little nervous about replacing the xcd (I have no idea what it does), so I'll revert to the original one for now. If there are some fairly simple changes I could make I'd be happy to try that.

tea for one (markexhome) wrote :

Thank you Sebastien.

Following your suggestion, I replaced the main.xcd file in /usr/lib/libreoffice/share/registry/ and F1 now displays the help screens as expected.

Sebastien Bacher (seb128) wrote :

Extra testing, uploading the libreoffice package used by Debian to ppa gave a build with the same 'no obvious way to instantiate implementation' warnings which aren't in Debian (but the build failed on a nospace error so it doesn't tell us if the resulting config was really buggy :-)

Other random change tried in case it worked but it didn't make a difference
export DEB_LDFLAGS_MAINT_STRIP := -Wl,-Bsymbolic-functions
in debian rules

(since that toolchain option is specific to Ubuntu and has been created issue for other packages in the past)

Sebastien Bacher (seb128) wrote :

Changes between Debian and Ubuntu, thanks ricotz!

Bug #1877970 is another issue that goes down to main.xcd missing entries which are there in Debian

ajgreeny (ajg-charlbury) wrote :

I am using the latest PPA version
Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
and in my system F1 or or LO Help from the menu opens firefox, my default browser, though I have made no changes to the system to get it to do that.

I assume that this newest PPA version must have already implemented that, though I would prefer the built-in help window as it was always a lot faster then opening filefox.

Strange. It doesn't work for me, and I've even moved on to the pre-release:

Version: 6.4.4.1
Build ID: 1:6.4.4~rc1-0ubuntu0.20.04.1
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Marcos Nascimento (wstlmn) wrote :

Replacing the main.xcd file is opening the help by the browser FF and not by the conventional window. :(

ubuntu 20.04
LibreOffice Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1

Norbert (nrbrtx) on 2020-05-17
tags: added: rls-ff-incoming
Sebastien Bacher (seb128) wrote :

There is a fix available now (thanks to ricotz), should be part of the next update

tags: removed: rls-ff-incoming

I have this problem too. The libreoffice install came along with Ubuntu 20.04. Pressing F1 shows a message: "the object cannot be accessed due to insufficient user rights". Purging and reinstalling the help package and the entire LO package does not solve the problem

Fixed for me in Version: 6.4.4.2
Build ID: 1:6.4.4~rc2-0ubuntu0.20.04.1
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Thanks very much.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
Changed in libreoffice (Ubuntu Focal):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.4.4-0ubuntu1

---------------
libreoffice (1:6.4.4-0ubuntu1) groovy; urgency=medium

  * Merge ubuntu-focal-6.4 to build for groovy

 -- Heather Ellsworth <email address hidden> Tue, 02 Jun 2020 09:54:53 -0600

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released

Hello Tim, or anyone else affected,

Accepted libreoffice into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.4.4-0ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal

Sorry, I don't understand. I have already tested this as I said in post #22. What else do I need to do?

The repository I have used is http://ppa.launchpad.net/libreoffice/libreoffice-prereleases/ubuntu . Is that different from 'proposed'?

Olivier Tilloy (osomon) wrote :

Tim: thanks for testing and confirming the fix.

Indeed the repository you used for testing is different from 'proposed'.

The above comment means that the update with the fix to this bug is being built in the Ubuntu archive (focal-proposed), and will soon be available for testing from there. Once it is confirmed (by either you or someone else interested in the issue) that the package in focal-proposed does fix the problem indeed, then it will be made available to all users in focal-updates.

If you feel like double-checking the fix, then you can follow the instructions in comment #24, and your feedback will be very welcome. Otherwise you can let Heather, who prepared the SRU, validate it, and just wait for it to become available in focal-updates. Either way, thanks again for your contribution!

To test just the proposed libreoffice changes I'll need some help. I cannot, for instance get this to work:

cat <<EOF >/etc/apt/preferences.d/proposed-updates
# Configure apt to allow selective installs of packages from proposed
Package: *
Pin: release a=$(lsb_release -cs)-proposed
Pin-Priority: 400
EOF

Each time I try, with or without sudo, I get permission denied.

So I tried creating proposed-updates using mousepad, but got a load of updates available. I then I replaced "$(lsb_release -cs)-proposed" with "focal-proposed". I now have no updates, as expected from the instructions. So far so good.

However, using sudo aptitude -t focal-proposed. I am not sure that I am finding the right libreoffice files in the lists of packages. There are 4 (at 12:30 GMT) but they have 'rc2' in the name. How many modules are being changed? The whole set or just a few? And what precisely should the names be?

Sorry if I'm being dim but to test properly I need to know that I am doing the right thing.

Paul White (paulw2u) wrote :

Tim: the version that you're wanting to test is still building. It takes a long time for Libreoffice to build. You can check it's progress in the "Builds" section on this Launchpad page:

https://launchpad.net/ubuntu/+source/libreoffice/1:6.4.4-0ubuntu0.20.04.1

I find it easiest to enable the -proposed repository by going into the "Software & Updates" application and enabling "Pre-released updates" on the Developer Options tab, "Reloading" when prompted and then making sure that I disable that option once the required packages have been updated.

Paul: That's precisely what I have been trying to do, as I imagined would be clear from the fact that I've been following the instructions on how to do just that, by editing the proposed-updates file.

But I don't know how to select just libreoffice (and all it's files) for update in aptitude.

Olivier Tilloy (osomon) wrote :

I'm not familiar with aptitude, but once all the packages are fully built and published in focal-proposed, the following commands should do the trick:

    sudo apt update
    NEWVERSION="1:6.4.4-0ubuntu0.20.04.1"
    sudo apt install $(apt list --upgradable | grep $NEWVERSION | cut -d/ -f1 | tr \\n " ")

Don't forget to disable the focal-proposed repository after the upgrade, otherwise you will keep on getting proposed versions for all Ubuntu packages, thus potentially compromising the stability of your system.

I don't suppose you could explain some of that could you? The install command is too complex for a simple fellow like myself - from the cut command on (I get as far as the selection of upgradable items with a name that includes the version number).

I don't think I'm in danger of getting updates I don't want, since the instructions in https://wiki.ubuntu.com/Testing/EnableProposed say they prevent that.

Or have I misunderstood?

Olivier Tilloy (osomon) wrote :

I suggest you run the command by parts (and look at the output after each command), this will demonstrate better than I can explain with words what it does, i.e.:

    NEWVERSION="1:6.4.4-0ubuntu0.20.04.1"
    apt list --upgradable
    apt list --upgradable | grep $NEWVERSION
    apt list --upgradable | grep $NEWVERSION | cut -d/ -f1
    apt list --upgradable | grep $NEWVERSION | cut -d/ -f1 | tr \\n " "

(in summary, it builds a list of packages to upgrade to the new version, and passes it to "sudo apt install", to make sure you upgrade only libreoffice and related packages from focal-proposed, not all the rest)

Note that at the time of this writing, the build in focal-proposed still hasn't finished, so you'll need to be a bit more patient before doing this.

Olivier - thanks - I understand now. I've done the update. It turned out that there were three modules that were't selected using this method (nlpsolver, wiki-publisher and fonts-opensymbol) so I installed them as well.

tags: added: verification-done-focal
removed: focal verification-needed verification-needed-focal

I am now using version Version: 6.4.4.2
Build ID: 1:6.4.4-0ubuntu0.20.04.1
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

The Help now works as expected.

Thanks.

I changed the tag - I hooe I got that right.

I updated both ubuntu 20.04 and mate 20.04, and I continue to get the error
that the object can't be opened.

On Sat, Jun 20, 2020 at 1:35 AM Tim Passingham <email address hidden>
wrote:

> I am now using version Version: 6.4.4.2
> Build ID: 1:6.4.4-0ubuntu0.20.04.1
> CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
> Calc: threaded
>
> The Help now works as expected.
>
> Thanks.
>
> I changed the tag - I hooe I got that right.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1869561
>
> Title:
> Libreoffice Help does not work
>
> Status in libreoffice package in Ubuntu:
> Fix Released
> Status in libreoffice source package in Focal:
> Fix Committed
>
> Bug description:
> In the latest PPA release of Libreoffice, the Help does not work. IN
> version 6.3.5.2 it is OK. I the version below it returns an error.
>
> Version: 6.4.2.2
> Build ID: 1:6.4.2-0ubuntu0.19.10.3
> CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: x11;
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
> Calc: threaded
>
>
> The Error is:
>
> Object not accessible.
> The object cannot be accessed
> due to insufficient user rights.
>
>
> The Help used to open the help in a browser window. This latest version
> seems to try to open the old type of local help (rather than using a
> browser).
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1869561/+subscriptions
>

Mip Mipendorf (mbruell) wrote :

The package that is installed in the stock version of ubuntu (20.04) is
1:6.4.3-0

As I said, still getting the same error.

On Sat, Jun 20, 2020 at 11:45 AM Marc Bruell <email address hidden> wrote:

> I updated both ubuntu 20.04 and mate 20.04, and I continue to get the
> error that the object can't be opened.
>
> On Sat, Jun 20, 2020 at 1:35 AM Tim Passingham <email address hidden>
> wrote:
>
>> I am now using version Version: 6.4.4.2
>> Build ID: 1:6.4.4-0ubuntu0.20.04.1
>> CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
>> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
>> Calc: threaded
>>
>> The Help now works as expected.
>>
>> Thanks.
>>
>> I changed the tag - I hooe I got that right.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1869561
>>
>> Title:
>> Libreoffice Help does not work
>>
>> Status in libreoffice package in Ubuntu:
>> Fix Released
>> Status in libreoffice source package in Focal:
>> Fix Committed
>>
>> Bug description:
>> In the latest PPA release of Libreoffice, the Help does not work. IN
>> version 6.3.5.2 it is OK. I the version below it returns an error.
>>
>> Version: 6.4.2.2
>> Build ID: 1:6.4.2-0ubuntu0.19.10.3
>> CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: x11;
>> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
>> Calc: threaded
>>
>>
>> The Error is:
>>
>> Object not accessible.
>> The object cannot be accessed
>> due to insufficient user rights.
>>
>>
>> The Help used to open the help in a browser window. This latest
>> version seems to try to open the old type of local help (rather than using
>> a browser).
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1869561/+subscriptions
>>
>

Heather Ellsworth (hellsworth) wrote :

The fix is released in 6.4.4 which is still in proposed for a few more days before it makes its way to focal-updates, so please be patient.

Mip Mipendorf (mbruell) wrote :

No worries - I was under the impression that I should test and send y'all
results. I'm happy to wait.

Thanks for all of your work on this and other bugs,
Marc

On Wed, Jun 24, 2020 at 12:20 PM Heather Ellsworth <
<email address hidden>> wrote:

> The fix is released in 6.4.4 which is still in proposed for a few more
> days before it makes its way to focal-updates, so please be patient.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1869561
>
> Title:
> Libreoffice Help does not work
>
> Status in libreoffice package in Ubuntu:
> Fix Released
> Status in libreoffice source package in Focal:
> Fix Committed
>
> Bug description:
> In the latest PPA release of Libreoffice, the Help does not work. IN
> version 6.3.5.2 it is OK. I the version below it returns an error.
>
> Version: 6.4.2.2
> Build ID: 1:6.4.2-0ubuntu0.19.10.3
> CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: x11;
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
> Calc: threaded
>
>
> The Error is:
>
> Object not accessible.
> The object cannot be accessed
> due to insufficient user rights.
>
>
> The Help used to open the help in a browser window. This latest version
> seems to try to open the old type of local help (rather than using a
> browser).
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1869561/+subscriptions
>

The verification of the Stable Release Update for libreoffice has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.4.4-0ubuntu0.20.04.1

---------------
libreoffice (1:6.4.4-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream release (LP: #1881007)
  * Don't use main.xcd configured with --disable-gui (LP: #1869561)

 -- Rico Tzschichholz <email address hidden> Thu, 14 May 2020 14:10:31 +0200

Changed in libreoffice (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers