package libreoffice-impress 1:6.1.6-0ubuntu0.18.10.1 failed to install/upgrade: forsøger at overskrive '/usr/lib/libreoffice/program/libOGLTranslo.so', som også er i pakken libreoffice-ogltrans 1:6.1.5-0ubuntu0.18.10.1

Bug #1828683 reported by Jimmy Frydkær Dürr on 2019-05-11
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned
Cosmic
High
Marcus Tomlinson
libreoffice-l10n (Ubuntu)
Undecided
Unassigned
Cosmic
High
Marcus Tomlinson

Bug Description

none

ProblemType: Package
DistroRelease: Ubuntu 18.10
Package: libreoffice-impress 1:6.1.6-0ubuntu0.18.10.1
ProcVersionSignature: Ubuntu 4.18.0-19.20-generic 4.18.20
Uname: Linux 4.18.0-19-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.3
Architecture: amd64
Date: Sat May 11 11:42:06 2019
ErrorMessage: forsøger at overskrive '/usr/lib/libreoffice/program/libOGLTranslo.so', som også er i pakken libreoffice-ogltrans 1:6.1.5-0ubuntu0.18.10.1
InstallationDate: Installed on 2018-06-14 (331 days ago)
InstallationMedia: Ubuntu-MATE 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180613)
Python3Details: /usr/bin/python3.6, Python 3.6.8, python3-minimal, 3.6.7-1~18.10
PythonDetails: /usr/bin/python2.7, Python 2.7.16, python-minimal, 2.7.15-3
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu5
 apt 1.7.4
SourcePackage: libreoffice
Title: package libreoffice-impress 1:6.1.6-0ubuntu0.18.10.1 failed to install/upgrade: forsøger at overskrive '/usr/lib/libreoffice/program/libOGLTranslo.so', som også er i pakken libreoffice-ogltrans 1:6.1.5-0ubuntu0.18.10.1
UpgradeStatus: No upgrade log present (probably fresh install)

[Impact]

 * This affects all Cosmic users attempting to upgrade LibreOffice to 6.1.6 from any previous version.

[Test Case]

 1. Install LibreOffice 6.1.5 on Cosmic
 2. Enable pre-released updates (cosmic-proposed)
 3. apt update && apt upgrade

[Regression Potential]

 * This issue and its associated fix are isolated to just this upgrade path, so potential for further regression is low.

Hi Jimmy, sorry about the trouble you're facing. The transition from 6.1.5 to 6.1.6 saw libreoffice-ogltrans merge into libreoffice-impress, though unfortunately it looks like the control file is not configured correctly to facilitate that replacement.

You'll need to run the following to complete the upgrade at this point:

sudo apt --fix-broken install

Changed in libreoffice (Ubuntu):
status: New → Triaged
Changed in libreoffice (Ubuntu):
assignee: nobody → Marcus Tomlinson (marcustomlinson)
importance: Undecided → High
Changed in libreoffice (Ubuntu Cosmic):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in libreoffice (Ubuntu):
assignee: Marcus Tomlinson (marcustomlinson) → nobody
status: Triaged → Fix Released
description: updated
description: updated
Changed in libreoffice (Ubuntu):
importance: High → Undecided
Olivier Tilloy (osomon) on 2019-05-13
Changed in libreoffice (Ubuntu Cosmic):
status: Triaged → In Progress

Hello Jimmy, or anyone else affected,

Accepted libreoffice into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.1.6-0ubuntu0.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Jimmy, or anyone else affected,

Accepted libreoffice-l10n into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-l10n/1:6.1.6-0ubuntu0.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice-l10n (Ubuntu Cosmic):
status: New → Fix Committed
Changed in libreoffice-l10n (Ubuntu):
status: New → Fix Released
Changed in libreoffice-l10n (Ubuntu Cosmic):
importance: Undecided → High
assignee: nobody → Marcus Tomlinson (marcustomlinson)

Upgraded libreoffice from 1:6.1.5-0ubuntu0.18.10.1 to 1:6.1.6-0ubuntu0.18.10.2 from cosmic-proposed in a clean and up-to-date cosmic amd64 VM, and successfully ran test plan at https://wiki.ubuntu.com/Process/Merges/TestPlans/libreoffice.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.1.6-0ubuntu0.18.10.2

---------------
libreoffice (1:6.1.6-0ubuntu0.18.10.2) cosmic; urgency=medium

  [ Marcus Tomlinson ]
  * New upstream release (LP: #1828210)
  * Japanese new era "Reiwa" support (LP: #1827451)
  * Fix libreoffice-ogltrans 'Replaces' version in libreoffice-impress (LP: #1828683)

  [ Rene Engelhard ]
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Sun, 12 May 2019 08:50:41 +0100

Changed in libreoffice (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:6.1.6-0ubuntu0.18.10.2

---------------
libreoffice-l10n (1:6.1.6-0ubuntu0.18.10.2) cosmic; urgency=medium

  [ Marcus Tomlinson ]
  * New upstream release (LP: #1828210)
  * Japanese new era "Reiwa" support (LP: #1827451)
  * Fix libreoffice-ogltrans 'Replaces' version in libreoffice-impress (LP: #1828683)

  [ Rene Engelhard ]
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Sun, 12 May 2019 08:50:41 +0100

Changed in libreoffice-l10n (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers