[upstream] Libreoffice Calc cannot export PDF to a network drive

Bug #1826468 reported by Jarosław Pióro on 2019-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Low
Unassigned

Bug Description

After upgrading from 18.10 to 19.04 I lost possibility to export a document to PDF, if a document is on a network drive (it's a DAVS network folder in my case). I receive a pop-up windows about general I/O error.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Apr 25 23:35:20 2019
InstallationDate: Installed on 2018-05-05 (355 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pl_PL.UTF-8
 SHELL=/usr/bin/fish
SourcePackage: libreoffice
UpgradeStatus: Upgraded to disco on 2019-04-23 (2 days ago)

Performed a clean install of opensuse tumbleweed to root while keeping an earlier ~. Under LO 6.1 I had no issues whatsoever creating files on a remote volume mounted using sftp via gvfs. In 6.2, attempting to create a new file (or rename a file via save as) results in two error messages:

"Error saving the document XXXXXXXX: Nonexistent file."
"Error saving the document XXXXXXXX: General Error. General input/output error."

The terminal has the following output:

(soffice:23435): GLib-CRITICAL **: 14:06:59.631: g_file_test: assertion 'filename != NULL' failed

The file is not saved. This makes it impossible to use LO effectively with remote data.

Hello,
LibreOffice 6.2.2.2 is going to be released today, could you please try again
with this version to see if the problem has been resolved meanwhile? Thanks in
advance

Tried to save a file to the network share via gvfs/sftp with LO 6.2.2.1 today and got essentially the same result; the GUI errors were the same and the terminal was essentially the same:

(soffice:11925): GLib-CRITICAL **: 10:10:32.502: g_file_test: assertion 'filename != NULL' failed

So it works in Libo 6.1 but not in Libo 6.2 ?

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided

Created attachment 150719
Help/About Window

It worked in LO 6.1 and not LO 6.2. I did run a distro update on this openSuSE tumbleweed system and the LO upgrade was part of that update. Attached a png of help/about.

Jarosław Pióro (jarek-pioro) wrote :

Hi Jarosław, please could you confirm which version of LibreOffice-Calc you’re using.

I’ve just tried this on 19.04 using 1:6.2.2-0ubuntu2 and seems to work alright for me at least (see screenshots).

Thank you!

Changed in libreoffice (Ubuntu):
status: New → Incomplete

I have the same version of LibreOffice installed. The problem is not only with exporting PDF to a network drive, but also with trying to "Save As" to the same drive. If I change the document and simply "Save" it, it works well.

I do not use the Libreoffice dialog box to access the network drive, I connect to it through Nautilus "Connect to server: davs://<>" etc. and then access it through Nautilus and open the document by double-clicking.

I had similar problem once after distro upgrade, I believe this bug is related to it:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1069757

You're right, this does seem to be the same upstream issue popping up again.

Would you mind filing an upstream bug report for this at https://bugs.documentfoundation.org/enter_bug.cgi?product=LibreOffice&format=guided and sharing the link to that bug here?

summary: - Libreoffice Calc cannot export PDF to a network drive
+ [upstream] Libreoffice Calc cannot export PDF to a network drive

Description:
After upgrading from Ubuntu 18.10 to 19.04 Libreoffice lost its ability to write to network drives. In my case it's a DAVS system, which I connect to using Nautilus. I access the file on the drive with Nautilus, open a file by double-clicking it, it opes without problems, I can change it and save it, but I cannot export the document as PDF or "Save As" another document at the same location. I get one popup window saying: "Error saving the document <document name>: Nonexistent file" and after closing it another one opens with "Error saving the document <document name>: General error. General input/output error".

The problem seems to emerge from time to time, as this example shows:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1069757

Steps to Reproduce:
1. Map a network drive through Nautilus
2. Access a LibreOffice document on this drive, open it by double-clicking it
3. Try to export the document as PDF to the same location or try to save it under another name without changing the location of the file

Actual Results:
one popup window saying: "Error saving the document <document name>: Nonexistent file" apperars and after closing it another one opens with "Error saving the document <document name>: General error. General input/output error".

Expected Results:
The software should export a file or write it down under a new name.

Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu2
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3;
Locale: pl-PL (pl_PL.UTF-8); UI-Language: en-US
Calc: threaded

Jarosław Pióro (jarek-pioro) wrote :

I have reported the bug there, here is the link:

https://bugs.documentfoundation.org/show_bug.cgi?id=124985

Thank you Jarosław.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

I have run into this same problem for my Linux clients. Windows client works fine. My server is Ubuntu 16.04 running samba and nothing has been changed on it. My client is Linux mint 19. After upgrading to Libreoffice 6.2.3 from 6.1, I can no longer create a new file, though an existing file can be updated.

Download full text (3.2 KiB)

Bibisected using the bibisect-linux-64-6.2 repo:

f90a939720a29fdaf65fef6ef2e05cb96021d87e is the first bad commit
commit f90a939720a29fdaf65fef6ef2e05cb96021d87e
Author: Jenkins Build User <email address hidden>
Date: Tue Nov 13 08:24:06 2018 +0100

    source sha:ca0308797df86ebece19260f3ca438a0cb437208

author Stephan Bergmann <email address hidden> 2018-11-13 08:13:00 +0100
committer Stephan Bergmann <email address hidden> 2018-11-13 08:13:00 +0100
commit ca0308797df86ebece19260f3ca438a0cb437208 (patch)
tdf#121337: Fail on GIO error in GIO UCP getPropertyValue

CCing Stephan Bergmann. Would you please take a look?

$ git bisect log
# bad: [8b2cf76950e32ea46ff293ce75177841ad920e38] source sha:1149d20ce9f8682b58f98d3fa3bf289fc5974087
# good: [f741463dfe1900d3acf87b538c0c043e42bc523d] source sha:3a801799536e6870f2fb111b1cc00b9575a35a39
git bisect start 'master' 'oldest'
# good: [f2a6a57cb2d0fbe45c9cfafdcf33a816c6ced63f] source sha:da8617d69a7b27a3eeb3f26e207ddf1b4de3eeb3
git bisect good f2a6a57cb2d0fbe45c9cfafdcf33a816c6ced63f
# good: [6ed11ecb665d289c0981da1f10c42877a870e5a2] source sha:b44b9c4519794d159b154a9713c10da1155a5198
git bisect good 6ed11ecb665d289c0981da1f10c42877a870e5a2
# bad: [b86f40dd1acc3d1baa3ffb3c15ac9f07eb53da66] source sha:f918e71d4e615fcc4527051a6e7f6bb4768d1269
git bisect bad b86f40dd1acc3d1baa3ffb3c15ac9f07eb53da66
# good: [a28cd13932f62645e77d63bd3309786c1e8c3cfc] source sha:52b5955100fdb5898110429814d5369275267a17
git bisect good a28cd13932f62645e77d63bd3309786c1e8c3cfc
# bad: [5d6d1ddefa763ebfca9e0a2522f33a8b1f28510f] source sha:698942ac73b8502eb1957b70dd165023e8d54c82
git bisect bad 5d6d1ddefa763ebfca9e0a2522f33a8b1f28510f
# good: [b27639cc47860e71920363a6720758e33243faaa] source sha:4d39ec07808276d7dbd2f92a08524f82ab5d715f
git bisect good b27639cc47860e71920363a6720758e33243faaa
# good: [095d4698cb1afdc4cea5038e18321f4798ab7c2f] source sha:b7d0b49f5708b55e24aabb719e26ce5ec8628161
git bisect good 095d4698cb1afdc4cea5038e18321f4798ab7c2f
# bad: [07065b7a0643f3fbd3e65bc879024c6c0ccba07f] source sha:b389aafee9cfba9dc4dfa552347be39ff9fe41b2
git bisect bad 07065b7a0643f3fbd3e65bc879024c6c0ccba07f
# bad: [727c2e08240b2ab0883d2d17bdd34e557c54b326] source sha:3460e91ac853964015215ec75be7cf63361ca0e9
git bisect bad 727c2e08240b2ab0883d2d17bdd34e557c54b326
# bad: [34ecd55e5ef85387279ddc20cbcc995b730d025f] source sha:f6b3b696ad9d454f7acbe930439cccc052e9fce2
git bisect bad 34ecd55e5ef85387279ddc20cbcc995b730d025f
# bad: [d3c8643f5a98e67791fa77e3e7ec072d33269b1d] source sha:3583f7a1256c901199574c8373443038e28813f0
git bisect bad d3c8643f5a98e67791fa77e3e7ec072d33269b1d
# bad: [ee785994dd46546781fa1123280dbc363dc3dcd5] source sha:630b5db9a10cd49d24d5e563374bd68f1fe670f5
git bisect bad ee785994dd46546781fa1123280dbc363dc3dcd5
# bad: [f90a939720a29fdaf65fef6ef2e05cb96021d87e] source sha:ca0308797df86ebece19260f3ca438a0cb437208
git bisect bad f90a939720a29fdaf65fef6ef2e05cb96021d87e
# first bad commit: [f90a939720a29fdaf65fef6ef2e05cb96021d87e] source sha:ca0308797df86ebece19260f3ca438a0cb437208

---

Note: It gives the following warning even if in good versions when the file is successfully saved, so this warning is possibly not rela...

Read more...

*** Bug 124985 has been marked as a duplicate of this bug. ***

Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6d3dd64391e67e6cfe406dea047e13227ea94c4b%5E%21

tdf#123472: Propagate getGFileInfo failure less aggressively

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Sebastien Bacher (seb128) wrote :

The upstream bug has been marked duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=123472 which states that the issue is fixed in git and for 6.3.0

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
Changed in df-libreoffice:
importance: Medium → Unknown
status: New → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released

Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/41747b75076e4446947873b3edc2abe3e3c4ebd1%5E%21

tdf#123472: Propagate getGFileInfo failure less aggressively

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

I confirm it is fixed in
版本: 6.3.0.0.alpha0+
Build ID: 1ae5ca077119982ae83833871326c86d9930ae11
CPU 线程: 4; 操作系统: Linux 4.18; UI 渲染: 默认; VCL: gtk3;
区域语言: zh-CN (zh_CN.UTF-8); UI 语言: zh-CN
Calc: threaded

6.2.4 released to Eoan.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released

can confirm it's fixed in 6.2.4.2

Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.16.04.1~lo1
CPU threads: 12; OS: Linux 4.15; UI render: default; VCL: gtk2;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Confirmed fixed, thank you.

Version: 6.2.4.2.0+
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

After further testing, the bug persists.

I had a file on an gvfs-mounted sftp share that was locked. I clicked on "enable editing," which creates a new file in that directory, and Writer crashed.

Less severe but the same behavior from a different functionality.

Mike, please open a new bug report on that, and add the link to this one to the See Also field. Please also try to get a backtrace as described here:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.