LibreOffice Impress embed video problem (libreoffice-gtk3)

Bug #1820062 reported by Gašper Sedej on 2019-03-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
libreoffice (Ubuntu)
High
Olivier Tilloy
Bionic
High
Marcus Tomlinson
Cosmic
High
Marcus Tomlinson
libreoffice-l10n (Ubuntu)
High
Olivier Tilloy
Bionic
High
Marcus Tomlinson
Cosmic
High
Marcus Tomlinson

Bug Description

LibreOffice Impress has problematic embedded video playback.

In Ubuntu 18.04, 18.10 and 19.04-alpha if you insert video in Impress slide, when played video stretches in fullscreen. (LO versions affected at least 6.0.x, 6.1.y and 6.2.1.1)

The video of miss-behavior: https://youtu.be/77E6IzVJ5jA

The issue is with current Libre Office vlc GTK3 (libreoffice-gtk3).

Solution #1
install gstreamer1.0-gtk3 (probably missing dependency)

Solution #2
Remove libreoffice-gtk3 and install libreoffice-gtk2

reference to Document Funtation bugzilla:
https://bugs.documentfoundation.org/show_bug.cgi?id=124068

[Impact]

 * This effects all libreoffice-gtk3 users wishing to embed videos into an Impress slide.

 * The fix is currently in LibreOffice 6.2.2+ on disco and eoan.

[Test Case]

 1. Insert a video into an Impress slide
 2. Play the video
 3. The video should play within the slide (not fullscreen like this: https://youtu.be/77E6IzVJ5jA)

[Regression Potential]

 * The fix is one line in the control file so potential for regression is low.

 * A combination of autopkgtests and manual testing as described above should provide reasonable confidence that no regressions sneaked in.

Description:
When embeding videos in Impress presentation when vcl "gtk3" is used

The video is displayed in fullscreen and on both monitors (when in presentation) and over full window when in edit mode and video play butoon is pressed.

This broken behavior is not present in "gtk2" mode. The GTK3 is default in new Ubuntu versions (e.g. 18.04 and 18.10). I have already contacted packaging team.

The bug is present in LO 6.0.?, 6.1.x and 6.2.1.1 (I am not sure what are exact older versions I tested)

I made video on this issue: https://youtu.be/77E6IzVJ5jA

I also opened this reddit tred: https://www.reddit.com/r/libreoffice/comments/b0jrdn/impress_embed_video_always_plays_fullscreen/

I tested: composition ("opengl") does not play role here (bug is present if OFF or ON)

Steps to Reproduce:
1. open impress in Ubuntu 18.04 or 18.10
2. embed any video in it
3. press F5 or "play button

Actual Results:
Video playback in in fullscreen and video is tearing. Also in both screens when presentation

Expected Results:
Vide should be played in the designated location and size inside slide

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Version: 6.2.1.1
Build ID: 1:6.2.1~rc1-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk2;
Locale: sl-SI (sl_SI.UTF-8); UI-Language: en-US
Calc: threaded

probably missing the gstreamer gtksink plugin on your machine (which works great, so install that if you can, package gstreamer1-plugins-good-gtk in fedora f.e), so its falling back to the non-gtksink implementation. I think Mark was making improvements to that fallback recently

Thanks for reply. The installing package "gstreamer1.0-gtk3" in ubuntu 18.04 did help. It's working now.

What can be done? I have the the "LibreOffice Packaging team" via "Contact admins", but I can find how to add additional info (solution for gtk3 gsteamer)

Hi,

That should have been fixed by the following commit.

commit 18138417485aeba6c52d935c616dba829b24ffd8
Author: Mark Hung <email address hidden>
Date: Mon Feb 18 21:51:57 2019 +0800

    avmedia: set gstreamer gst_video_overlay size and position.

    Have video fit to the media object size on the slide,
    allow more complicated interactions.

    Change-Id: Ice1fa4b521176ad7ed7f7d1d2b13e617e8282390
    Reviewed-on: https://gerrit.libreoffice.org/67978
    Tested-by: Jenkins
    Reviewed-by: Caolán McNamara <email address hidden>
    Tested-by: Caolán McNamara <email address hidden>

It should already be available in daily build.

Thanks for reply.

Though I am not sure about the fix. My LO 6.2.1.1 already works fine when installing package "gstreamer1.0-gtk3" on ubuntu. What I understand, my bug report is actually packaging problem - missing dependency. Does commit 18138417485aeba6c52d935c616dba829b24ffd8 fix the missing package (e.g. gstreamer1.0-gtk3 is not needed)?

For me the same problem as Gasper described. My system: LO 6.1.5.2 on Ubuntu 18.04.
After installing gstreamer1.0-gtk3 the problem is solved.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Close as WFM after comment 4 and comment 5

Changed in df-libreoffice:
status: Confirmed → Invalid
Gašper Sedej (gsedej) wrote :

I disagree with "invalid" bug in launchpad. Problem in in packaging. User should not manually install " gstreamer1.0-gtk3" package

Olivier Tilloy (osomon) on 2019-03-19
Changed in libreoffice (Ubuntu):
status: New → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
Olivier Tilloy (osomon) wrote :

Thanks for the report Gašper.

It is indeed a packaging problem, on the Ubuntu side of things.

gstreamer1.0-gtk3 is in universe, whereas libreoffice-avmedia-backend-gstreamer is in main, so the former cannot be made a direct/recommended dependency of the latter, per Ubuntu policy.

Olivier Tilloy (osomon) wrote :

The source package for gstreamer1.0-gtk3 (gst-plugins-good1.0) is in main though, so that should be fine.

Olivier Tilloy (osomon) wrote :

Note: adding gstreamer1.0-gtk3 to the stage packages fixes video playback in the libreoffice snap. I have triggered a new snap build with that change (https://git.launchpad.net/~libreoffice/+git/libreoffice-snap/commit/?id=aeb8d4444b538564d312c0a4ffc258da3abe02a5).

Olivier Tilloy (osomon) wrote :

The libreoffice snap version 6.2.2.2 in the candidate channel has that change. I tested and confirms that video playback is functional again.

Olivier Tilloy (osomon) wrote :

As done in debian, it is libreoffice-gtk3 that should recommend gstreamer1.0-gtk3 (https://salsa.debian.org/libreoffice-team/libreoffice/libreoffice/commit/a7307bd4d2ab671a47573e8b9b8f78a295e223e5).

Olivier Tilloy (osomon) wrote :

Archive administration considerations were discussed on IRC (#ubuntu-release):

<Laney> oSoMoN: If it's fine to promote (should be), I think it should be fine to add those recommends - it's a couple of new sinks so shouldn't affect things that don't opt in to those
<Laney> obviously it'd be good to watch out for it being buggy in any way
<oSoMoN> Laney, do you reckon that warrants a FFe ?
<Laney> arguably, but feel free to just paste this into the bug I think
<Laney> maybe check with d_idrocks or another archive admin that they'd be OK with promoting the package first
<sil2100> oSoMoN, Laney: since the source is in main I'd be fine to promote the binary to main if needed
<oSoMoN> ah, thanks sil2100
* sil2100 checks the binary real quick
<didrocks> oSoMoN: sure, I can promote that package, I'm still warry about binary promotion because sometimes MIRs are about "we can promote that part, but not that part", and this is lost in time, but as we have a maintainer (you!), I'm ok with promoting :)
<didrocks> oSoMoN: just tell me when it hits proposed and I'll promote it
<oSoMoN> excellent, thanks

Gašper Sedej (gsedej) wrote :

I am glad that the issue is being solved.

Is it also possible to fix current Ubuntu 18.04 LTS installation? LO version 6.0.x is installed by default. Can you add the dependency for LO 6.0 and all newer?

Olivier Tilloy (osomon) wrote :

This will require a Stable Release Update, of which a prerequisite is for the fix to be present in the development series.

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.2.2-0ubuntu1

---------------
libreoffice (1:6.2.2-0ubuntu1) disco; urgency=medium

  * New upstream release

  [ Rene Engelhard ]
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Olivier Tilloy <email address hidden> Sun, 24 Mar 2019 22:44:21 +0100

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Sam Colegrove (colegrove479) wrote :

The above image shows what happens when LibreOffice 6.2.2.2 Impress has an inserted video. When the video is started, the previous slide is shown on top of the video as it is played. Not a good view!!!! This happens on Kubuntu 19.04 and I have added all the packages suggested in the above "solution".

Gašper Sedej (gsedej) wrote :

Sam,
I found out similar issues also when starting slideshow with slide that contains video directly (shift + F5). This issue is not present if i start slideshow with first slide.
I also noticed if the video is not entirely inside slide - the video acts weirdly when in presentation.

However this is not the same issue as I reported. New bug should be opened. One should test if this issue is persistant with libreoffice-gtk2 (gtk3 removed) and also without any gtk2 or gtk3. Also test on other linux distros and/or Windows.

Oliver,
can you change title of bug to:

   LibreOffice Impress embed video dependency problem (libreoffice-gtk3)

Will Cooke (willcooke) on 2019-03-26
Changed in libreoffice (Ubuntu Bionic):
assignee: nobody → Olivier Tilloy (osomon)
Changed in libreoffice (Ubuntu Cosmic):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

Spin-off bug filed by Sam: bug #1821849.

Olivier Tilloy (osomon) on 2019-05-06
Changed in libreoffice (Ubuntu Bionic):
assignee: Olivier Tilloy (osomon) → Marcus Tomlinson (marcustomlinson)
Changed in libreoffice (Ubuntu Cosmic):
assignee: Olivier Tilloy (osomon) → Marcus Tomlinson (marcustomlinson)
Changed in libreoffice (Ubuntu Bionic):
importance: Undecided → High
Changed in libreoffice (Ubuntu Cosmic):
importance: Undecided → High
description: updated
description: updated
Changed in libreoffice (Ubuntu Bionic):
status: New → Triaged
Changed in libreoffice (Ubuntu Cosmic):
status: New → Triaged
Olivier Tilloy (osomon) on 2019-05-08
Changed in libreoffice (Ubuntu Bionic):
status: Triaged → In Progress
Changed in libreoffice (Ubuntu Cosmic):
status: Triaged → In Progress
Łukasz Zemczak (sil2100) wrote :

The gstreamer1.0-gtk3 new binary dependency is currently in universe, while libreoffice is in main. But since the source of gstreamer1.0-gtk3 (gst-plugins-good1.0) is already in main, I will simply promote it as well as per our policy.

no longer affects: libreoffice-l10n (Ubuntu Bionic)
Changed in libreoffice-l10n (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Changed in libreoffice-l10n (Ubuntu Cosmic):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in libreoffice-l10n (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)

Hello Gašper, or anyone else affected,

Accepted libreoffice into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.1.6-0ubuntu0.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in libreoffice-l10n (Ubuntu Cosmic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Gašper, or anyone else affected,

Accepted libreoffice-l10n into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-l10n/1:6.1.6-0ubuntu0.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Upgraded libreoffice to 1:6.1.6-0ubuntu0.18.10.1 from cosmic-proposed in a clean and up-to-date cosmic amd64 VM, and successfully ran test plan at https://wiki.ubuntu.com/Process/Merges/TestPlans/libreoffice.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic

Unfortunately the upgrade from 6.1.5 to 6.1.6 is actually broken. My apologies for the false verification. I will prepare a fix asap.

tags: added: verification-failed-cosmic
removed: verification-done-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Gašper, or anyone else affected,

Accepted libreoffice into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.1.6-0ubuntu0.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-cosmic
removed: verification-failed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Gašper, or anyone else affected,

Accepted libreoffice-l10n into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-l10n/1:6.1.6-0ubuntu0.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Upgraded libreoffice from 1:6.1.5-0ubuntu0.18.10.1 to 1:6.1.6-0ubuntu0.18.10.2 from cosmic-proposed in a clean and up-to-date cosmic amd64 VM, and successfully ran test plan at https://wiki.ubuntu.com/Process/Merges/TestPlans/libreoffice.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Gašper Sedej (gsedej) wrote :

Hello.

Thanks for updates. Sorry for late reply - I needed to set up 19.04, my daily drivers are 18.04 machines (which didn't include this update).

I tested on ubuntu 19.04. Enabled -purposed and upgraded libreoffice to "6.1.6"
The "gstreamer1.0-gtk3" did install.

So the current situation is that video plays correctly IF the video is fully inside the slide.

If the video is a bit outside the slide or video is bigger than slide, when pressing "play" button in right pane, libreoffice UI totally breaks.
Only the ~1/8 of window display content other space is white. If resizing the window, the content gets even smaller.
Also when running the slideshow, it's broken.
I need to close impress and run it again.

Can someone else confirm similar behavior?

Gašper Sedej (gsedej) wrote :

I made new video demonstrating current situation - better, but still issues (see previous post)

https://www.youtube.com/watch?v=e6UDDSBg4m8

Hi Gašper, thank you for the update.

The issue you're experiencing now really looks to be a separate problem in my opinion. I think we can safely say that the gstreamer patch in 6.1.6 fixes the original bug.

Could you please submit a new bug for this breaking UI issue? Thanks!

Gašper Sedej (gsedej) wrote :

I agree. The packaging looks now fine.

The issue new might be actual "libreoffice-gtk3" or "gstreamer1.0-gtk3". Where should i post the new bug - in the ubuntu or libreoffice bugtracker?

Please log the bug here against the Ubuntu package first. Then, if we find that it’s not Ubuntu-specific, we can link it to an upstream bug. Thanks again!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.1.6-0ubuntu0.18.10.2

---------------
libreoffice (1:6.1.6-0ubuntu0.18.10.2) cosmic; urgency=medium

  [ Marcus Tomlinson ]
  * New upstream release (LP: #1828210)
  * Japanese new era "Reiwa" support (LP: #1827451)
  * Fix libreoffice-ogltrans 'Replaces' version in libreoffice-impress (LP: #1828683)

  [ Rene Engelhard ]
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Sun, 12 May 2019 08:50:41 +0100

Changed in libreoffice (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:6.1.6-0ubuntu0.18.10.2

---------------
libreoffice-l10n (1:6.1.6-0ubuntu0.18.10.2) cosmic; urgency=medium

  [ Marcus Tomlinson ]
  * New upstream release (LP: #1828210)
  * Japanese new era "Reiwa" support (LP: #1827451)
  * Fix libreoffice-ogltrans 'Replaces' version in libreoffice-impress (LP: #1828683)

  [ Rene Engelhard ]
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Sun, 12 May 2019 08:50:41 +0100

Changed in libreoffice-l10n (Ubuntu Cosmic):
status: Fix Committed → Fix Released

Hello Gašper, or anyone else affected,

Accepted libreoffice into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.0.7-0ubuntu0.18.04.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic

Upgraded libreoffice from 1:6.0.7-0ubuntu0.18.04.5 to 1:6.0.7-0ubuntu0.18.04.6 from bionic-proposed in a clean and up-to-date bionic amd64 VM, and verified that the [Test Case] now passes.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.0.7-0ubuntu0.18.04.6

---------------
libreoffice (1:6.0.7-0ubuntu0.18.04.6) bionic; urgency=medium

  [ Ikuya Awashiro ]
  * debian/patches/new-japanese-era-name.patch (LP: #1827451):
    Add new Japanse era name "Reiwa" support which taken from upstream:
    https://cgit.freedesktop.org/libreoffice/core/commit/?id=cacbb0faef77ae8462de9ff5c7307a6a2e28b2bb
    https://cgit.freedesktop.org/libreoffice/core/commit/?id=597c5d75b8e72d429e096535334eaac7973455ef

  [ Olivier Tilloy ]
  * debian/patches/java.vendor-Ubuntu.patch: update to also recognize
    "Private Build" as java.vendor (for custom PPA builds) (LP: #1822839)
  * debian/patches/java.vendor-Ubuntu.patch: also make jvmfwk recognize
    "Ubuntu" as java.vendor (LP: #1822839)

  [ Rene Engelhard ]
  * debian/patches/java.vendor-Debian.diff: make jvmfwk recognize "Debian"
    as java.vendor as that's what is set in openjdk 11 >= 11.0.3+4-2
    - see #926009 (closes: #926318) (LP: #1822839)
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Tue, 07 May 2019 12:35:49 +0100

Changed in libreoffice (Ubuntu Bionic):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Hello Gašper, or anyone else affected,

Accepted libreoffice-l10n into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-l10n/1:6.0.7-0ubuntu0.18.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice-l10n (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Changed in libreoffice-l10n (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → Marcus Tomlinson (marcustomlinson)

Upgraded libreoffice-l10n from 1:6.0.7-0ubuntu0.18.04.6 to 1:6.0.7-0ubuntu0.18.04.7 from bionic-proposed in a clean and up-to-date bionic amd64 VM, and verified that the test case passes.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:6.0.7-0ubuntu0.18.04.7

---------------
libreoffice-l10n (1:6.0.7-0ubuntu0.18.04.7) bionic; urgency=medium

  * debian/patches/cpdmgr-check-dbus-desc.diff (LP: #1798074):
    - Only create CPDManager if D-Bus descriptions present.
    - Fixes LibreOffice startup crash when CPD packages installed.

libreoffice-l10n (1:6.0.7-0ubuntu0.18.04.6) bionic; urgency=medium

  [ Ikuya Awashiro ]
  * debian/patches/new-japanese-era-name.patch (LP: #1827451):
    Add new Japanse era name "Reiwa" support which taken from upstream:
    https://cgit.freedesktop.org/libreoffice/core/commit/?id=cacbb0faef77ae8462de9ff5c7307a6a2e28b2bb
    https://cgit.freedesktop.org/libreoffice/core/commit/?id=597c5d75b8e72d429e096535334eaac7973455ef

  [ Olivier Tilloy ]
  * debian/patches/java.vendor-Ubuntu.patch: update to also recognize
    "Private Build" as java.vendor (for custom PPA builds) (LP: #1822839)
  * debian/patches/java.vendor-Ubuntu.patch: also make jvmfwk recognize
    "Ubuntu" as java.vendor (LP: #1822839)

  [ Rene Engelhard ]
  * debian/patches/java.vendor-Debian.diff: make jvmfwk recognize "Debian"
    as java.vendor as that's what is set in openjdk 11 >= 11.0.3+4-2
    - see #926009 (closes: #926318) (LP: #1822839)
  * debian/control.gtk3.in:
    - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

 -- Marcus Tomlinson <email address hidden> Fri, 31 May 2019 11:43:00 +0100

Changed in libreoffice-l10n (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.