libreoffice cannot start on live or installed ubuntu budgie 19.04

Bug #1813506 reported by fossfreedom on 2019-01-27
This bug report is a duplicate of:  Bug #1798074: LIbreoffice crashes on startup. Edit Remove
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Olivier Tilloy

Bug Description

On both the 19.04 daily iso and the installed version of 19.04 UB, libreoffice writer, calc etc cannot start. All you see is a "Document Recovery" window despite that this is the first time the application is started.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: libreoffice 1:6.1.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu19
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Sun Jan 27 22:08:51 2019
InstallationDate: Installed on 2019-01-21 (6 days ago)
InstallationMedia: Ubuntu-Budgie 19.04 "Disco Dingo" - Alpha amd64 (20190121)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

fossfreedom (fossfreedom) wrote :
Sebastien Bacher (seb128) wrote :

Do you get an error if you start it from a command line? Could you add your journalctl log after getting the issue?

Changed in libreoffice (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Ubuntu budgie (ubuntu-budgie) wrote :

I got this when running "libreoffice" from the command line

javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx

So I restarted back into the live session - installed default-jre and libreoffice-java-common

This time - nothing on the command line, but still the same issue.

Nothing relevant appeared when I ran 'journactl -f' and then ran libreoffice

Changed in libreoffice (Ubuntu):
status: Incomplete → New
fossfreedom (fossfreedom) wrote :

Note - https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1813755

The above bug report is reported against Ubuntu 18.04.1

However the same observation - purge the package libreoffice-gtk3 ensures libreoffice starts successfully - no "document recovery" issues are observed on first start.

Obviously the styling of libreoffice is windows 95 like. ho-hum.

Ubuntu budgie (ubuntu-budgie) wrote :

Note 2 - I've tried the latest 18.04.1 Ubuntu Budgie daily iso and I cannot reproduce this issue - so it appears to be 19.04 specific.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
fossfreedom (fossfreedom) wrote :

From UbuntuForums https://ubuntuforums.org/showthread.php?t=2407348&page=2

"Digging around i've found https://bugs.documentfoundation.org/show_bug.cgi?id=122116#c26"
which suggest a libcpdb removal: purged libcpdb-libs-common1 and cpdb-backend-cups as dependant."

I can confirm that purging those two packages allows libreoffice to start.

Document Foundation describes this bug https://bugs.documentfoundation.org/show_bug.cgi?id=122116#c26

The end of the bug report says that it is fixed in libreoffice v6.2.0.2.

Will disco be getting that version (or later of libreoffice) ?

Olivier Tilloy (osomon) wrote :

Yes, disco will get 6.2 shortly.

Changed in libreoffice (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.