Reports won't open

Bug #1802208 reported by Michael Sharman on 2018-11-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Reports that were working as of June this year (I haven't opened them since then) now are failing with the following error:

Can not activate the factory for org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory

I tried creating a fresh report to see if its some kind of out of date file format but I get the same error:
  1. select "Create Report in Design View..."
  2. select "Save"
  3. Double click report
  4. Same error as above

Of course I'm expecting the report to open without an error.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libreoffice-report-builder 1:6.0.6-0ubuntu0.18.04.1
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Uname: Linux 4.15.0-38-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Nov 8 12:16:08 2018
InstallationDate: Installed on 2018-02-17 (263 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
PackageArchitecture: all
SourcePackage: libreoffice
UpgradeStatus: Upgraded to bionic on 2018-05-01 (190 days ago)

Michael Sharman (msharman) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers